Wowza Community

Need Help for Multi-bitrate Video On Demand Streaming


I want to stream the following code into Multi-bitrate Video using smil file.

<embed height=“349” width=“500” type=“application/x-shockwave-flash” src=“player.swf” id=“mpl” name=“mpl” quality=“high” allowscriptaccess=“always” allowfullscreen=“true” wmode=“opaque”

flashvars="streamer=rtmp:// t&image=images/NEWBREED.jpg&frontcolor=0xffffff&backcolor=0x00000 0&flashvars=foo=Hello&lightcolor=0xDB5131&logo=ima ges/action_videos.gif&bwfile





Please let me know what all the steps to stream video on multi bitrate using smil file.

Note: I have tried the following tutorial , but dont know how to stream in html page.

The first thing you have to do is create a smil file that references different bit rate videos. You change this:


To this:


Then create the filed name mySmil.smil and upload to your bucket. The link below shows how to create the smil file. It is going to be sitting next to the videos in the same bucket, so the smile file /video src should just be the video names, not bucket or path.

I think JW player 4.7 or try the latest 5 version should work.

Also add Flashvar “type=rtmp”. Or if JW 5 make it “provider=rtmp”

(also, take this out of the Flashvars “&flashvars=foo=Hello”)


I will give you the same answer here. JW Player seems to be pre-pending smil: to the stream name. Wowza cannot handle the smil: prefix. JW Player should not be pre-pending smil: to the stream name.


It’s the tutorial you mentioned, about half way down the page in the “Multi-bitrate Video on Demand” section:

			<video src="mp4:Extremists_700.m4v" system-bitrate="700000"/>
			<video src="mp4:Extremists_350.m4v" system-bitrate="350000"/>
			<video src="mp4:Extremists_200.m4v" system-bitrate="200000"/>


The Flashvars is a problem. It’s not well formed and you are trying to do too much too soon. I suggest fixing it and simplifying it. The “provider=rtmp” part is important in this case and it might not be being read because you have nested “flashvars” in the Flashvars. There might be a soft or hard return in the middle of it too. Try it like this for testing:


I tried to test this but got connection rejected, so I assume you have SecureToken enabled. So if you are not supplying the token correctly, that could also be a problem


I see the problem, you are using Wowza 1.7.2.

Multi-bitrate and smil files are not supported in that version. You need to be using a Wowza Server 2 AMI:


hm, when I checked the streamer in the source earlier this morning it said:



Try taking out “&bwstreams=100,250,500” from Flashvars.

Maybe this is conflicting with the smil file.


This is because some versions of JW player look for .mp4 extension and add the “mp4:” prefix. So it is getting doubled up mp4:mp4:streamname.mp4

So don’t add the prefix.


I get “application rejected connection” from your ec2 server with the smil file.

Do you have SecureToken installed? If so, can you remove that for testing. And do you have a sample video in that bucket (eg Extremists.flv) so I can test that.

Also, sorry, but I can’t find what you sent to support. Can you resend and reference this thread.



When I go to it says 2.0.0

Please give me tutorial link for how to create smil file for wowza streaming server as per your above reply.


I have done the following steps for Multi-bitrate Video On Demand Streaming as per .

Please let me know if i had missed anything.

I. I have updated the following steps in vods3/Application.xml

  1. Set the Streams/StreamType property to: default

Answer: It has set default. So i didn’t change anything.

  1. Set the HTTPStreamers property to: cupertinostreaming,smoothstreaming

Answer: It has set default. So i didn’t change anything.

  1. Add the following property to the application level container at the bottom of the Application.xml file (be sure to get the correct container - there are several in the Application.xml file)





Answer: I have added above code manually to container which is last of vods3/Application.xml.

4.Smooth Streaming only: Using a text editor create the file [install-dir]/conf/clientaccesspolicy.xml with the following content (For more information see the article Network Security Access Restrictions in Silverlight):

Answer: It has set default. So i didn’t change anything.

II. Created smil file and streaming

  1. I have created new smil file(mySmil.smil) in mybucket with following code


I have changed the flashvars as per your instructions but it still not working

My Embed Code :

mysmil.smil Code :


Hello Richard,

I have removed the “&bwstreams=100,250,500” from Flashvars. But it still not works.

Now My Embed code is

Please let me know how to fix this issue.

I have tried to stream smil file from my own server directly with following code

<embed height=“349” width=“500” type=“application/x-shockwave-flash” src=“player.swf” quality=“high”

allowscriptaccess=“always” allowfullscreen=“false” wmode=“opaque” flashvars=“file=”/>

It works fine. So problem is not possible with smil file or jw player or embed code.

Note 1 : I have sent my queries to support with attachment of /conf and /logs folders of my wowza server. But i didn’t get any reply for that mails. Please let me know how can i contact support team for direct communication.

In my embed code,

Without prepending “mp4:” is working


With prepending “mp4:” is not working


In flv player it shows following error,

Stream not found:


In error log file it show following error,

WARN server comment 2010-01-18 06:20:08 - - - - - 448453.887 - - - - - - - MediaCache.createNewCachItem: Cannot find MediaCacheSource for (mp4:amazons3/actionvideos/THROTTLE_JUNKY.Title7.mp4).

WARN server comment 2010-01-18 06:20:08 - - - - - 448453.887 - - - - - - mp4:amazons3/actionvideos/THROTTLE_JUNKY.Title7.mp4[1]: Item not in cache: mp4:amazons3/actionvideos/THROTTLE_JUNKY.Title7.mp4

Hello Richard,

I have disabled the hotlinkdenial module. I haven’t enabled SecureToken module. Now you can able to test my videos .

Please have a look on

I have sent mail to “” with subject “Need Help on Multi-bitrate Video On Demand Streaming - With reference of”.

I got the following reply

“It is most likely a problem with JW Player. It seems to be prepending the smil: prefix to the stream name. We cannot handle a prefix of smil:. It is not valid. You may want to post this issue in the JW Player forums.”

Please guide me in right way.