Wowza Community

s3 s3fs 'ls' hangs on EU-Irish buckets

Hi All,

This is really an EC2 sys admin question, but I figured I’d ask here with no luck at AWS.

I have wowza ec2 instances in different regions and s3 buckets in different regions mounted via s3fs as documented. But when i ‘ls /mnt/my-eu-ireland-bucket’ it just hangs the whole ssh session. All other regional buckets act fine. I tried new instances, new buckets, no luck.

Also, when I mount the bucket from outside AWS (local server in Switzerland) access to the UE bucket works fine. so it is not a key problem or configuration or ?? i don’t know. It is just from EC2 to S3 Ireland over fuse/s3fs that fails.

Are there any ideas or any logs/debug stuff i can look at 'cause i’m completely stumped now



can somebody please do a test to confirm if I am Krazy or not.

-From AWS Dashboard or CLI make a bucket in region EU Ireland, my-eu-bucket

-Login to a Wowza EC2 server

ssh -i /home/EC2.pem

-make new mount point

mkdir /mnt/s3-eu

-mount new EU bucket

/usr/bin/s3fs my-eu-bucket -o accessKeyId=xxxxxx -o secretAccessKey=xxxxxxx /mnt/s3-eu

list contents

ls -la /mnt/s3-eu


but mount a us or Singapore bucket and it functions perfect.



We are close to a new release. I will be sure to grab the most recent s3fs code when I do. It will most likely be sometime this week.


The latest AMI is running version s3fs-1.40.tar.gz.


We will investigate upgrading to this newer version of FUSE in the next release of our AMIs.



It is probably still not supported, it’s an issue with S3FS. There is a S3FS patch that fixes this, but last I heard it was not integrated. More info in this thread and link to the S3FS patch.


Thanks for the reply Richard.

Sorry I didn’t find that thread earlier.

It makes perfect sense. and the reason it works from my server outside AWS is because I compiled and installed the latest s3fs binary which includes the patch.

Since the Wowza AMI does not include a compiler we can not install the patch. Is it possible you compile the latest s3fs binary on your AMI source for us to download, or even better, could you update the AMI.

latest fuse

latest s3fs



Thanks Charlie!


We’ve created an EU(west) bucket on AWS and we have used the April 25, 2011 Wowza AMI (ami id: ami-3bab9c4f).

However, when we try to use the s3fs application to mount the bucket, we are facing the above issue. Do the latest AMIs have the updated patch or do we have to install it ourselves?


Hi Charlie,

I figured out the issue. s3fs 1.4 needs fuse version 2.8.4 or greater.

The fuse version on the AMI is 2.7.x, which was giving us the problem.

On upgrading the fuse version and re-compiling s3fs-1.40.tar.gz, the issue got fixed. :slight_smile: