Wowza Community

Stream from an IP Camera

i have 2 different inputs:

  1. normal h.264 rtsp stream from helix server.

  2. h.264 rtsp stream from hikvision ip camera.

the first input works kinda good, but the 2nd is errored:

“ERROR server comment - RTPDePacketizerRFC3984H264.handleRTPPacket: java.lang.ArrayIndexOutOfBoundsException: 127866”

it seems like i’m having the same problem like this guy:

the thing is, that although the server is keep throwing error messages, when i’m trying to access the stream from VLC, i DO watch a true full image from time to time,and after it happen, it’s blurring again, graying, idled, and then cleaned again.

so if there isn’t a way to fix this problem, maybe there’s a way to tell the server to ignore the packetizing errors and just stream it as it is…?


First be sure you are running the most recent patch:

If that doesn’t help you can try some of the suggestions in this post:

If none of this help send an email with the RTSP URL to the camera and we can take a look at it (


For live streaming to IPhone, ensure the h.264 video is Baseline Profile level 3, or lower, and that the value of your Application.xml /LiveStreamPacketizers is “cupertinostreamingpacketizer”


i tried patch 11 and the problem solved.

the rtmp stream work just great!

now i’m struggling to understand why the iphone stream (blablabla/playlist.m3u8) doesn’t work… (the “moov not find” error). chance on any help for this one too?

thanks a lot…

[ btw, i got the budget for the server :stuck_out_tongue: ]