Wowza Community

Streaming a Tricaster rtmp push to multicast mpegts amino

No there nothing in the files that looks different in the logs. It binds to tricaster fine and binds to the multicast address fine.

However, the stream has a lot of corrupted packets. Player shows bite rate that does not match the bit rate of the stream with is 512k and shows aprox. 9m or above bit rate for the incoming stream.


Is the new Windows machine on the same network as the working server?

I do not know. There might be. Wowza is being installed on a new Windows 2008 64 bit machine.

So you are seeing video and hearing audio in player now, but just not well? What player, VLC?

I am seeing a scambled video. No audio. in VLC player.

Is Tricaster publishing or are you staring stream with StreamManager?

Tricater is pushing rtmp h264 512k bit stream.

I starting a stream in the startStream.xml file that points the uncast address and port, application and stream.

Is there still doubt about the bitrate of the stream?

the bitrate of the stream is 512K however the bitrate in tsreader si 9 to 2 megs. We tried multcasting a media file VLC and playing it VLC and is worked.

Have you tried to play it back in Wowza LiveVideoStreaming example Flash player over rtmp?

Yes and it works perfect.

Zip up and send conf and logs folders to Include screen shot(s) of tricaster settings, and include a link to this forum post for reference.

Ok thanks. Will do,



Could there be a problem with Wowza and mutcast udp when a server has 2 nics but ones enabled and ones disabled? The server has a 2 Broadcom nics one is enabled and one is disabled.


Does not look I did get response to ticket.


Thanks for information.

In the Application.xml file?


This is were are currently. We installed a Windows 2008 64 bit Server local as vm. Used the same Java, Wowza 2.2.4 exe file, plugins, the the same configuration, except pointed the Tricaster at the local Wowza server that is at client site. And the udp multicast worked. We zipped the all the Wowza server files, moved the files at the client site and copied the local files on vm test system to the client site and it did not work. We basicly mirrored the vm Wowza install at client site. The only difference is the local vm Windows 2008 does not have the patches that the client site has. We are applying the patches to see if that makes a difference. Do you have any what might cause this issue?


Was there an attachment with the ticket response?

I am going to try and see if the spam filter here is needs to be changed, Or you attached something that our filter did not like.



How much did you zip and move? Can you detail the steps you took to do that? Were custom jar files include?

Everything from the root directory of Wowza. Including the plugins: wms-plugin-collection.jar, wms-plugin-multicastpublish.jar.

I zipped up everything below the root Wowza directory upload to Jira and download to client computer. Copied the WowzaMediaServer-2.2.4 folder to new folder name. Removed the WowzaMediaServer-2.2.4. Unzipped the wowza files into the WowzaMediaServer-2.2.4 folder and started the server. Because we were use push stream and the same multicast address nothing needed to changed. Started Wowza and checked the stream. It was the same.


I have remove the LiveStreamingPacketizers but it did not help. Still working on the license.


I have some new information. I am going to send some Wireshark dumps to the support email address that has some information that I hope is useful. The client has a IBM blade server that case with some other servers on a backplane and the backplane is attached to a Cisco switch. All the blade server nics are to the real Cisco switch as one nic using virtualization. When we ran a multicast stream using vlc as the server there was one multicast stream entry in wireshark attached to the nic on the ibm server. However, when I used the Wowza server I get on mutticast stream entry on the ibm nic and the cisco nic virtual nic. And the Cisco one has a 20-30 Mb multicast stream, this is in layer 2. In layer 3 it looks like the 20Mb muticast stream is comming from the server.




RTMP on the tricaster to live stream client works.

VLC to multicast UDP does not work.

NIC to switch is os switch to lan flouds. It happens when there is VLC client joined to the stream.


I tried the forcing it a particular nic but that did not work.


Does muticast snooping need to be turned on to route the packets in Wowza server?


I know that multicast does not work on the Internet. Bu some switches allow for IGMP packet snooping to find group packs on the LAN.

Is the a whay I can change the ttl on the multicast packet. When vlc multicast to multicast works the ttl is 1. Where Wowza set it to 63. I think it may be looping between the switch and the nic. So, if set the time to live to 1 it may drop the flooding and work. Then I would know if was looping.


I tried setting the ttl in the mulcastmap.txt file like you described above. However, when trace the multicast packets with Wireshark I still get TTL of 63 on the packets. When I do VLC the packets ttl is set to 1 and when trace the packets on wire shark is 1. I think this may be the problem, but need confirm setting packet ttl one Woza stay one and the stream works.


stream2={name:stream2,stream:,isRTPWrapped:false,ttl:1} but it did not change the ttl in the packets.

Is there an issue with setting the time to live option?


There is a problem with TTL values propogating properly. Install this patch to fix it:



This should fix my probem. I will let you know.

The patch worked.


For all the help.


Is an actual stream file needed in the content directory, and if so what should be in it? Or, is the entry in the multicastmap.txt file enough?