Wowza Community

Using an MPEG Transport Stream (MPEG-TS) encoder with Wowza Pro (MPEG-TS)

KB, you can use ModuleMediaCasterStreamMonitorAdvanced to monitor, debug and reset MediaCaster streams:

Loudenboomer, The symptom sounds like stream bitrate higher than client bandwidth problem. In any case, if you find encoding parameters that work and others that don’t, obviously keep what works, use that as a baseline. The ModuleMediaCasterStreamMonitorAdvanced should be useful for you too.


You can send url to the stream, and zip up conf and logs also. Include a link to this thread for reference

I’m not sure if we can help. It seems like an encoding/player issue. My advice is use what works.


Make sure you are not using contiguous ports. Skip at least one in your assignment.



I use the fastvdo smartcapture usb and mpeg-ts stream.

  1. Is it possible to define a default “Stream” for the rtplive application and map the mpeg-ts stream (udp://[ip-address]:[port]) to?

I want to hide the udp://[ip-address]:[port] from the user and instead map “livestream” to my udp://[ip-address]:[port] so the client side url for the stream becomes:



  1. How can setup security when using a mpeg-ts encoder that push stream the udp port on the wowza server? To only allow certain IP’s to send stream.


I’ve got some questions:

  1. what is part of publish stream name? What does it mean? Where can I read about it?

  2. how to protect port(with wowza plugin) from udp flooding from another computer (I mean, legal and hacker encoders will send packets to the same port, so video will become spoiled)?

Thank you!

You can use StreamNameAlias package to protect server:

Do you mean that if hacker will flood UDP to specific port, then this packets will be ignored by Wowza?

I understand all about streamname alias, but nevertheless if hacker does not know the port - he can flood to all ports (there are not so many of them, right?) to spoil all published mpeg-ts videos.

So… question is still opened.


What are default PIDs?

I mean when no audioPID and videoPID are specified.

Thanks Charlie,

So I just tell the encoder to send basically udp://wms.server.addr:anyport And Wowza will know to listen on that port based on a player connect? So it’s the player that actually starts the stream publishing?



Hi. Im new to this forum but i got a few questions regarding the TS option.

  1. Can the streamer do a IGMPv1 join to a existing Multicast stream containing a Mpeg2TS 188bytes stream (h.264 and aac Elementary streams)?

  2. Can it remux and remap it unicastly over RTMP for viewing on Flash 10?

  3. Are there any security mechanisms that i can set restrictions from the streamingserver regards to where the client comes from and so on?

best regards D

Hi. I now got the license and installed 1.7.2 with ure 2.patch to a:

Vmware ESXI 4.0 Image

Centos 5.3 64bit

Sun Java x64

Java configured at heapsize 1024mb

  1. When starting the startup script i get:

Exception in thread “main” java.lang.NoClassDefFoundError: com/wowza/wms/bootstrap/Bootstrap

Caused by: java.lang.ClassNotFoundException: com.wowza.wms.bootstrap.Bootstrap

at$ Source)

at Method)

at Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClassInternal(Unknown Source)

Could not find the main class: com.wowza.wms.bootstrap.Bootstrap. Program will exit.

SOLVED: Had to reinstall the whole server with a uninstall first. Worked then… beats me why… It also now popped up with a serial question… dunno why it didnt do that the first time… Now i used rpm -i instead of the bin file directly…

But i still havnt found any info on how to set up the server to join a multicast/udp via igmp v1 message.

Configure logging: file:///usr/local/WowzaMediaServerPro/conf/

INFO server server-start Wowza Media Server Pro10 1.7.2 build12154 -

INFO server comment - Serial number: XXXXX-XXXXX-XXXXX-XXXXX-YAUE9

INFO server comment - Maximum connections: 10

INFO server comment - Hardware Available Processors: 2

INFO server comment - Hardware Physical Memory: 7408MB/7983MB

INFO server comment - Hardware Swap Space: 3999MB/3999MB

INFO server comment - Max File Descriptor Count: 1024

INFO server comment - Open File Descriptor Count: 31

INFO server comment - OS Name: Linux

INFO server comment - OS Version: 2.6.18-128.7.1.el5

INFO server comment - OS Architecture: amd64

INFO server comment - Java Name: Java HotSpot™ 64-Bit Server VM

INFO server comment - Java Vendor: Sun Microsystems Inc.

INFO server comment - Java Version: 1.6.0_16

INFO server comment - Java VM Version: 14.2-b01

INFO server comment - Java Spec Version: 1.6

INFO server comment - Java Home: /usr/java/jre1.6.0_16

INFO server comment - Java Max Heap Size: 7MB

INFO server comment - Java Architecture: 64

INFO server comment - CMDInterface now listening: [any]:8083

INFO server comment - vhost home directory: /usr/local/WowzaMediaServerPro

INFO vhost vhost-start defaultVHost -

INFO vhost comment defaultVHost RTMP/RTMPT bind attempt ([any]:1935)

INFO vhost comment defaultVHost Bind successful ([any]:1935)

ERROR server comment - messageReceived: java.nio.BufferOverflowException

INFO vhost vhost-stop defaultVHost -

best regards TE

Whether to support the VLC play video, if so, how to set up? Whether they can be Internet access?

Thanks. And only HE-AAC?

We can only handle H.264/AAC over MPEG-TS. We cannot handle MP3 audio.


Hi there, I’m having a bit of an issue with Wowza and the re-broadcast of a multicast stream into a flash site.

We have Cisco routers which are acting as multicast controllers. When I fire up VLC on the same host as wowza transmitting to I have no trouble connecting with the RTPMulticastListener. However… we have implemented the actual stream to our edge Cisco routers not via local vlc.

When I connect to the stream I see all the right things happening in Wowza. And a tcpdump on the eth0 interface shows the IGMPv3 join packet going out to the routers.

02:26:55.039008 IP (tos 0xc0, ttl 1, id 0, offset 0, flags [DF], proto IGMP (2), length 40, options (RA)) > igmp v3 report, 1 group record [gaddr to_ex, 0 source ]

The problem is that the stream never starts. I’m told by the Cisco guys here they they see the IGMPv3 query coming through but that they are using “source specific multicast” for these streams and that, as the join lacks the source IP, the router is rejecting the request.

I’m told if I can configure Wowza to send this… or alternatively configure it to send a IGMPv2 join they can apply a hack on the router which will map the group to the source.

Are either of these things possible?


Sending the source IP for the source specific multicast IGMPv3 join or sending an IGMPv2 join instead?


Thank you very much for implementing that.

Unfortunately my system operations department looked at me in a very disapproving manner when I mentioned the requirement to install preview software in production…

I’ve been told that they are keen for me to test this in the lab (which I will do) with the intention to roll it out when Wowza 2 goes full release.

In the meantime the network guys are going to statically join the network ports for these 3 servers to the multicast stream.

I’ll let you know how it goes in the lab and how the rollout goes when Wowza 2 is released.


Hrmm a small question about this plugin.

I’m currently solving my IGMPv3 problem by statically joining the ports to the multicast stream.

I’m sending a raw UDP/TS stream to the port. 500k/s H.264 and 96k/s HE-AAC audio.

When I connect in my browser all the backend stuff seems to work. I buffer for a few seconds and then the stream starts playing but it’s highly jittery in video and audio. It stop and starts and jumps all over the place.

What’s weird is that if I set my encoder to deliver mpeg for the audio the video stream cleans up to perfect and plays smoothly but I have no audio. (logs show no connection to an audio stream)

Is this a problem with codecs? Or me sending a UDP/TS rather than an RTP stream?

Debug below.

INFO|server|comment|2009-12-08|06:21:53|-|-|-|-|-|-|-|-|-|-|354438.641|-|-|-|-|-|-|-| bloomberg=udp://

INFO|server|comment|2009-12-08|06:21:53|-|-|-|-|-|-|-|-|-|-|354438.642|-|-|-|-|-|-|-|MediaStreamMediaCasterPlay: startPlay



INFO|server|comment|2009-12-08|06:21:53|-|-|-|-|-|-|-|-|-|-|354438.648|-|-|-|-|-|-|-|RTPMediaCaster.Reconnector: start

INFO|server|comment|2009-12-08|06:21:53|-|-|-|-|-|-|-|-|-|-|354438.648|-|-|-|-|-|-|-|RTPSessionDescriptionDataProviderBasic.getStreamInfo: URI: udp://





INFO|server|comment|2009-12-08|06:21:53|-|-|-|-||rtplive|-|-|-|-|354438.664|-|-|-|-|-|-|-|RTPMediaCaster.Reconnector: stop


INFO|server|comment|2009-12-08|06:21:53|-|-|-|-||rtplive|-|-|-|-|354438.862|-|-|-|-|-|-|-|RTPDePacketizerMPEGTS.handleRTPPacket: videoPID: 0x820

INFO|server|comment|2009-12-08|06:21:53|-|-|-|-||rtplive|-|-|-|-|354438.862|-|-|-|-|-|-|-|RTPDePacketizerMPEGTS.handleRTPPacket: audioPID: 0x830


Never mind… ignore me… It does look like it’s because the Stream is a RAW UDP/TS… I attached to the stream with VLC, re-encapsulated it in an RTP multicast stream and then Wowza sends it fine.

I’ll find a way to work round this…

Thanks for your time

Hopefully this should be an easy question. Is there anywhere that lists all the possible properties for an RTP stream or streams in general in the Applications file?

I’m getting seriously jerky audio/video when re-streaming RTP video from a particular encoder we’re using but the video plays fine when rtp streaming from VLC.

I just want to know what settings I can tweak other than “sortPackets” and “BufferSize” if anything.

Setting the logs to debug shows no obvious errors, it just doesn’t play correctly.

Hrmm that’s odd. Because it plays fine if I take the very same stream and re-encapsulate it in RTP with VLC. I’m more suspecting that the particular encoder we are using is doing something funny with the RTP headers that Wowza isn’t expecting?

All other sources play fine, except from this one encoder.

Here are a TS Reader output for both streams.

one of the major things I can see is that the VLC stream Puts the PCR on the same PID as the video stream which the encoder doesn’t do. Could this cause the problem?

Looks like it’s an Audio timing issue… I followed the instructions in this thread here.

(point 4. MPEG-TS missing audio) and all of a sudden I have working video and audio! Hurrah!

My problem now is that the video and audio fall out of sync over time no matter what I set the servers sortbuffersize to.

I’ve also tried all three options for the


I get situation A. If I play it drifts out of sync. If I stop and restart the stream in the player they are initially in sync and slowly fall out of sync.