Wowza Community

Wowza s3 upload plugin not uploading to S3

I have followed all the steps written in guide but no .upload files are being created and hence no files have been uploaded to S3.

I have manually tried to upload to S3 successfully.

Below are my settings for module section enter image description here

and these are my custom properties enter image description here

Both the above configuration changes are on this page


I am using Wowza Streaming Engine 4.4.1 and AWS JAVA SDK 1.11.5

What is that I am missing?


Just to add to the question above and elaborate what I have tried till now. This is the exception that shows up in the error log with SDK 1.11.5

java.lang.reflect.InvocationTargetException|at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)|at sun.reflect.NativeMethodAccessorImpl.invoke(|at sun.reflect.DelegatingMethodAccessorImpl.invoke(|at java.lang.reflect.Method.invoke(|at com.wowza.wms.module.ModuleFunction.invoke(

I have tried with AWS SDK 1.4.7 with common-codecs 1.9 as described in this thread java.lang.reflect error

But this did not work. I thought that maybe the SDK version is a bit old so i tried the last major SDK version 1.10.77 but it also did not work.

I would really appreciate it if someone could help us out.


The uploader is built against version 1.10.16 of the AWS SDK. I will test it against later versions to see what the problem is.

Thanks for letting us know.



I’ve tested the uploader with version 1.10.77 of the SDK and it looks like it is working. Because this isn’t the latest version, there isn’t a single jar file so you will need to get the following files from Maven (or compile the SDK yourself:

In the 1.11.x versions of the SDK, it looks like AWS have updated the version of Apache httpclient that it requires so that the version which ships with WowzaStreamingEngine is no longer compatible.




The module should upload a recording once it has completed. Are you not finding that to be the case? Note that recordings that get versioned due to a new recording don’t count as recordings, but any active recording should be uploaded once the recording ends.


The module works but only copy to the last file S3 recorded in EC2. Is it possible to record all emissions of an application? Example: MyStream.mp4; MyStream_01.mp4, etc …

I’m facing the same issue with the new (build 21295).

Anyone can confirm is not working?

in my wowza lib dir I have



what should I do?

solved adding the new aws sdk (1.11.xx) in Wowza/lib