Results 1 to 8 of 8

Thread: RTSP starts with much delay

  1. #1

    Default RTSP starts with much delay

    Hello,
    We are experiencing much delay in RTSP playback. Below are what we are doing:

    - Encoder is sending on rtmp: 320x240 @ 200bitrate @ 15fps
    - My wowza server is 150ms away from the encoder
    - My client is 150ms away from the server
    - I get almost 15 second delay in playing RTSP though the audio comes before video which is 10 seconds.

    Below are the logs for the playback:
    2011-10-14 06:36:50 PKT describe rtsp INFO 200 2041166771 - _defaultVHost_ newsone _definst_ 13990.258 178.86.20.88 1935 rtsp://178.86.20.88:1935/newsone/newsone_sub 110.38.138.244 rtsp - RealMedia Player HelixDNAClient/10.0.0.6839 (S60 HX cvs_cays221_20100816:12:00:00utc 16 Aug 2010 12:00) 2041166771 0 0 - - - - newsone_sub - - - - - rtsp://178.86.20.88:1935/newsone/newsone_sub rtsp://178.86.20.88:1935/newsone/newsone_sub - rtsp://178.86.20.88:1935/newsone/newsone_sub -
    2011-10-14 06:36:51 PKT comment server INFO 200 - RTPUDPTransport.bind[newsone/_definst_]: in:0.0.0.0/0.0.0.0:6970 out:/110.38.138.244:28058 - - - 13990.894 - - - - - - - - - - - - - - - - - - - - - - - - -
    2011-10-14 06:36:51 PKT comment server INFO 200 - RTPUDPTransport.bind[newsone/_definst_]: in:0.0.0.0/0.0.0.0:6971 out:/110.38.138.244:28059 - - - 13990.899 - - - - - - - - - - - - - - - - - - - - - - - - -
    2011-10-14 06:36:51 PKT comment server INFO 200 - UDPTransport.firstPacket: bind:0.0.0.0/0.0.0.0:6970 msg:/110.38.138.244:28058 - - - 13999.265 - - - - - - - - - - - - - - - - - - - - - - - - -
    2011-10-14 06:36:51 PKT comment server INFO 200 - UDPTransport.firstPacket: bind:0.0.0.0/0.0.0.0:6971 msg:/110.38.138.244:28059 - - - 13999.269 - - - - - - - - - - - - - - - - - - - - - - - - -
    2011-10-14 06:36:51 PKT comment server INFO 200 - RTPUDPTransport.bind[newsone/_definst_]: in:0.0.0.0/0.0.0.0:6972 out:/110.38.138.244:28060 - - - 13991.325 - - - - - - - - - - - - - - - - - - - - - - - - -
    2011-10-14 06:36:51 PKT comment server INFO 200 - RTPUDPTransport.bind[newsone/_definst_]: in:0.0.0.0/0.0.0.0:6973 out:/110.38.138.244:28061 - - - 13991.327 - - - - - - - - - - - - - - - - - - - - - - - - -
    2011-10-14 06:36:51 PKT comment server INFO 200 - UDPTransport.firstPacket: bind:0.0.0.0/0.0.0.0:6972 msg:/110.38.138.244:28060 - - - 13999.679 - - - - - - - - - - - - - - - - - - - - - - - - -
    2011-10-14 06:36:51 PKT comment server INFO 200 - UDPTransport.firstPacket: bind:0.0.0.0/0.0.0.0:6973 msg:/110.38.138.244:28061 - - - 13999.699 - - - - - - - - - - - - - - - - - - - - - - - - -

  2. #2

    Default

    Hello eboundservices,

    I test with the Wowza RTSP demo and on my local network from Wowza with rtsp://[Wowza-IP]:1935/vod/mp4:sample.mp4. Both have 4-5 seconds latency.

    I also tested with a livestream from my webcam with FMLE 3.2 with the following settings:
    1. H.264 baseline profile, level 3.0, keyframe 2 sec, 24FPS, video bitrate 150, resolution 160/120. AAC audio, mono, 22kHz, 24bps.
    2. H.264 baseline profile, level 3.0, keyframe 2 sec, 24FPS, video bitrate 350, resolution 320/240, AAC audio, stereo, 44.1kHz, 96bps.

    Both start within 4-5 seconds.

    Also tested using RTMP with the Wowza LiveVideoStreaming client, in my Android web browser. Latency was a little quicker at about 3 seconds.


    Ensure that Wowza is patched to the latest version. There were some RTSP improvements recently.

  3. #3

    Default

    I am using the latest Wowza Server 3 (3.0.3) version but its too much delay.

    Though the RTMP streaming is quicker.


    -Mamoor

  4. #4
    Join Date
    Mar 2009
    Posts
    17

    Default

    yes,
    same probleme here 10-12 seconds... and rtmp starts 500ms-1 sec. any chance do make the rtsp start-up time lower?

  5. #5
    Join Date
    Sep 2011
    Posts
    1,931

    Default

    Hi
    You may have a client that changes from UDP to TCP, or TCP to UDP.
    UDP/TCP can't be forced by Wowza and the change that the client makes can range from 5seconds to 10 seconds when switching.

    In VLC for example you can set player to use TCP only by setting:
    Tools -> Preferences -> Input & Codecs RTP over RTSP (TCP)

    Try something like this to see if you sill get the delay locally,
    This may be a network issue that you can't control

    Jason

  6. #6

    Default

    I found my solution.

    By add 553 port in vhost beside 1935 and using the rtsp link without 1935 port it now shows video quickly.

    Basically it was UDP to TCP or TCP to UDP conversation issue.

    -Mamoor

  7. #7

    Default Doesn't work for me.. still slow.

    Quote Originally Posted by eboundservices.com View Post
    I found my solution.

    By add 553 port in vhost beside 1935 and using the rtsp link without 1935 port it now shows video quickly.

    Basically it was UDP to TCP or TCP to UDP conversation issue.

    -Mamoor
    I tried what you recommended and it doesn't work for me. Can you verify that this works on v3 of Wowza? And did you mean port 554? (You mentioned port 553, but that doesn't appear anywhere in the docs).

    If you could also please provide your complete RTSP URL that you used, that would be a great help.

    Thank you,
    Steven

  8. #8
    Join Date
    Sep 2011
    Posts
    1,931

    Default

    Hi
    RTSP URL should look like this,
    rtsp://[wowza-address]:1935/live/myStream

    If you have enabled port 554 you wont have to use :1935
    I think that 553 is a typo and he means port 554.

    Is there a firewall on any of the ports that Wowza uses as this may give you problems,
    Check out,
    http://www.wowza.com/forums/content....(RTSP-RTP-out)
    2. Networking (UDP and TCP setup)

    Jason

Similar Threads

  1. Replies: 1
    Last Post: 02-17-2012, 08:40 AM
  2. RTSP streaming starts just after SETUP
    By Aymen.Lakdhar in forum General Forum
    Replies: 3
    Last Post: 12-22-2011, 08:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •