Results 1 to 8 of 8

Thread: restreaming from rtsp to http

  1. #1
    Join Date
    Feb 2012
    Posts
    4

    Default restreaming from rtsp to http

    hi.

    I want to restream rtsp from av tech ip camera to http clients.
    I have all setup configured as in http://www.wowza.com/forums/content....e-streaming%29

    my avtech.stream got:
    rtsp://10.181.0.122/live/h264

    and when I try connect to wowza from any player with
    http://wowza:1935/aolliveinsecure/_d...m/manifest.f4m
    all I got is error and on server sie log:

    INFO stream create - -
    INFO server comment - MediaStreamHTTPStreamerRepeaterBuffer.initLiveStreamRepeating: receiverClass: com.wowza.wms.httpstreamer.sanjosestreaming.liverepeater.SanJoseStreamerLiveRepeaterReceiver
    INFO server comment - LiveMediaStreamReceiver.connect: rtsp://10.181.0.122/live/h264:rtmp://10.181.0.122:1935/live[h264]
    INFO server comment - SanJoseStreamerLiveRepeaterReceiver.close: aolliveinsecure/_definst_/avtech.stream:avtech.stream:sanjosestreamingpacketizer
    INFO server comment - MediaStreamMap.removeLiveStreamPacketizer[aolliveinsecure/_definst_/avtech.stream]: Destroy live stream packetizer: sanjosestreamingpacketizer
    INFO server comment - SanJoseStreamerLiveRepeaterReceiver.resetStream: aolliveinsecure/_definst_/avtech.stream:sanjosestreamingpacketizer
    INFO server comment - LiveStreamPacketizerSanJose.init[aolliveinsecure/_definst_/avtech.stream]: chunkDurationTarget: 10000
    INFO server comment - LiveStreamPacketizerSanJose.init[aolliveinsecure/_definst_/avtech.stream]: chunkDurationTolerance: 500
    INFO server comment - LiveStreamPacketizerSanJose.init[aolliveinsecure/_definst_/avtech.stream]: playlistChunkCount:4
    INFO server comment - MediaStreamMap.getLiveStreamPacketizer: Create live stream packetizer: sanjosestreamingpacketizer:avtech.stream
    INFO server comment - SanJosePacketHandler.startStream[aolliveinsecure/_definst_/avtech.stream]
    INFO server comment - LiveStreamPacketizerSanJose.handlePacket[aolliveinsecure/_definst_/avtech.stream]: Video codec: H264
    WARN server comment - NetConnectionConnection.connect: Failed to connect[10.181.0.122:1935]: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: Connection refused].
    WARN server comment - NetConnectionConnection.connect: Failed to connect[10.181.0.122:1935]: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: Connection refused].
    when i try rtmp://wowza:1935/aolliveinsecure/_definst_/avtech.stream
    the stream is played.

    why is it doing rtsp://10.181.0.122/live/h264:rtmp://10.181.0.122:1935/live[h264]??
    what does it mean? this camera has one port for rtsp and it is 554 wihout any possibility to change.

    I tried interleave and udp, and for both the result is the same.

    I'm totally stuck..

    BR,
    bratbob

  2. #2

    Default

    It sounds like it is working. The following notation is just for logging:

    rtsp://10.181.0.122/live/h264:rtmp://10.181.0.122:1935/live[h264]

    Charlie

  3. #3
    Join Date
    Feb 2012
    Posts
    4

    Default

    It is not working for rtsp->wowza->http.

    As in the log which I copy/pasted here look at the last lines:

    WARN server comment - NetConnectionConnection.connect: Failed to connect[10.181.0.122:1935]: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: Connection refused].

    WMS tries to connect to camera on 1935 and is not using established connection on 554. And I don't know why? Why, when client is asking for rtmp all is good, there is no new connections from WMS to camera, but when client asks for http stream, there is such behaviour? and since my camera does not stream anything at port 1935, there is connection problem and client receives error..

    br,
    Bartek

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    What is the contents of avtech.stream?

    Does the camera require authentication? If so, if it is basic authentication, you can authenticate in the URL like this:

    rtsp://richard:mypwd@10.181.0.122/live/h264
    Richard

  5. #5
    Join Date
    Feb 2012
    Posts
    4

    Default

    As I wrote on the begining avtech.stream contains
    rtsp://10.181.0.122/live/h264
    there is no need for authorization.

    it works for rtsp->wowza->rtmp
    it does not work for rtsp->wowza->http

    my application.xml contains:
    [...]
    <LiveStreamPacketizers>sanjosestreamingpacketizer, sanjosestreamingrepeater</LiveStreamPacketizers>
    [...]
    <HTTPStreamers>sanjosestreaming</HTTPStreamers>
    [...]
    and it works with other stream from vlc rtsp

    I does not work with avtech camera rtsp through WMS to flash http client

    In my first post I have pasted WMS log, when WMS tries to connect to some strange
    LiveMediaStreamReceiver.connect: rtsp://10.181.0.122/live/h264:rtmp://10.181.0.122:1935/live[h264]
    I cannot understand why?? camere has port 1935 shut. is there any switch or property that dictates this bahaviour?

    br,
    bartek

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    bartek,

    Remove "sanjosestreamingrepeater" from LiveStreamPacketizers. It should just look like this:
    <LiveStreamPacketizers>sanjosestreamingpacketizer</LiveStreamPacketizers>
    Unless this is an edge server, in which case remove "sanjosestreamingpacketizer" instead.

    What player, and what URL are you using? Try the Wowza example:

    [wowza-install-dir]/examples/LiveVideoStreaming /clientOSMF/bin-release/LiveOSMFPlayer.html

    I'm not sure about the connect failure. Seems to be reachable, but refused.

    Richard

  7. #7
    Join Date
    Feb 2012
    Posts
    4

    Default

    So simple..... how I missed function of it...
    THANKS!!! working great now

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Cool! Thanks for the quick update

    Richard

Similar Threads

  1. HTTP restreaming
    By mackms in forum Suggestions
    Replies: 5
    Last Post: 01-30-2014, 08:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •