Results 1 to 5 of 5

Thread: Smoothstreaming FourCC on video

  1. #1
    Join Date
    Mar 2012
    Posts
    9

    Default Smoothstreaming FourCC on video

    Hey All,

    I'm using Wowza 2.2.4.07 (waiting for my Wowza 3 license), and I'm having trouble with playback on my STB client.

    Looking at the Microsoft site http://msdn.microsoft.com/en-us/libr...(v=vs.90).aspx it says

    When the Type of the StreamIndex element is video, the FourCC attribute indicates the video codec. Supported values are:

    WVC1, which represents the VC-1 codec

    AVC1, which represents H.264 MPEG 4 Part 15. Other synonyms are X264, DAVC, and H264.

    AVCB, which represents H.264 MPEG 4 Annex B

    Note that X264, DAVC, H264 values should not be used; instead, use AVC1 as noted in the second bullet point above.
    Wowza appears to use the H264 FOURCC and it is stopping my STB client from playing, shouldnt it be using FOURCC AVC1 as per Microsoft ? Is this configurable at all ? Is this fixed in Wowza 3 or a another patch ?

    Let me know, thanks.

    Mal

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Wowza reflects the stream source.

    Richard

  3. #3
    Join Date
    Mar 2012
    Posts
    9

    Default

    Quote Originally Posted by rrlanham View Post
    Wowza reflects the stream source.

    Richard
    Indeed and the source is indeed H264, however Microsoft suggests (see link) that use of H264 as FOURCC is invalid, and it should be AVC1. Ask Mr Knowlton

    Mal

  4. #4

    Default

    I believe with Wowza Media Server 3 this is still set to H264. I will do a little research and look into either changing it to AVC1 or will make it configurable. I do not have a timeframe as to when this will happen but will report back to this thread with progress.

    Charlie

  5. #5

    Default

    I did add support for chaning this value. Install Wowza Media Server 3.0.5 then install this patch:

    [url=http://www.wowza.com/downloads/WowzaMediaServer-3-0-5/WowzaMediaServer3.0.5-patch4.zip]WowzaMediaServer3.0.5-patch4.zip[/ur]

    Then add the following property to the HTTPStreams/Properties in [install-dir]/conf/[application]/Application.xml:

    <Property>
    	<Name>smoothStreamingVideoCodecIDH264</Name>
    	<Value>AVC1</Value>
    </Property>
    We are still doing research to determine if we will change the default value to AVC1.

    Charlie

Similar Threads

  1. Align video and audio on wowza 2.2.4 for smoothstreaming
    By kavita in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 08-13-2013, 05:09 AM
  2. Windows Phone 7 SmoothStreaming
    By smokee in forum Media Players and Devices
    Replies: 10
    Last Post: 02-10-2012, 02:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •