Results 1 to 2 of 2

Thread: HTML5 video tag in iPad 1

  1. #1
    Join Date
    Jul 2012
    Posts
    5

    Default HTML5 video tag in iPad 1

    I'm having a strange problem streaming HLS on original iPad, running latest iOS5.

    Here is a simple video tag that I use:

    		
    	 
    	 	<video src="http://192.168.1.19:1935/app_demo/myStream.sdp/playlist.m3u8" width="640" height="390" autoplay>
                Your browser does not support the video tag.
            </video>          
    It works as expected in a webpage on iPhone4S. First showing the Play icon on top and when that clicked, plays full screen. All good here.

    When I try to input the URL directly into Safari URL on iPad:

    http://192.168.1.19:1935/app_demo/myStream.sdp/playlist.m3u8
    , it ALSO works fine.

    When I try to open the same exact webpage on iPad, it's just showing the black rectangle, no Play icon on top, not responding to touch either.

    I then decided to try Apple original samples here:

    HLS Examples

    And surprisingly my old iPad easily handles both Basic and Advanced HLS without a hitch.

    I'm also positive that this used to work when I was running full evaluation version, but now I downloaded (the same Wowza version) and installed Developer Evaluation.

    What could be wrong?

    G

  2. #2
    Join Date
    Jul 2012
    Posts
    5

    Default

    Quote Originally Posted by genekru View Post
    I'm having a strange problem streaming HLS on original iPad, running latest iOS5.

    Here is a simple video tag that I use:

    		
    	 
    	 	<video src="http://192.168.1.19:1935/app_demo/myStream.sdp/playlist.m3u8" width="640" height="390" autoplay>
                Your browser does not support the video tag.
            </video>          
    It works as expected in a webpage on iPhone4S. First showing the Play icon on top and when that clicked, plays full screen. All good here.

    When I try to input the URL directly into Safari URL on iPad:

    http://192.168.1.19:1935/app_demo/myStream.sdp/playlist.m3u8
    , it ALSO works fine.

    When I try to open the same exact webpage on iPad, it's just showing the black rectangle, no Play icon on top, not responding to touch either.

    I then decided to try Apple original samples here:

    HLS Examples

    And surprisingly my old iPad easily handles both Basic and Advanced HLS without a hitch.

    I'm also positive that this used to work when I was running full evaluation version, but now I downloaded (the same Wowza version) and installed Developer Evaluation.

    What could be wrong?

    G
    Solved by adding "controls" to the video tag:

    <video src="http://192.168.1.19:1935/app_demo/myStream.sdp/playlist.m3u8" width="640" height="390" autoplay controls>
                Your browser does not support the video tag.
            </video>

Similar Threads

  1. How to play live stream on mobile devices with html5 video tag?
    By vosovskiy in forum Live Streaming and Encoder Discussion
    Replies: 7
    Last Post: 08-28-2013, 07:12 PM
  2. Android > 4.0 Imposible to stream to device. html5 video tag.
    By Andres in forum Media Players and Devices Discussion
    Replies: 1
    Last Post: 05-31-2013, 10:07 AM
  3. Playback using html5 video tag, is that possible?
    By Andres in forum General Forum
    Replies: 7
    Last Post: 09-11-2012, 03:22 AM
  4. Can Connection Arguments be Passed when using HTML5 Video Tag?
    By SteveT in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 11-23-2011, 12:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •