Results 1 to 7 of 7

Thread: HTTP Session never destroy

  1. #1
    Join Date
    Aug 2012
    Posts
    25

    Default HTTP Session never destroy

    Hi,

    It's a really weird problem, and we're not able to reproduce it so far.

    Couple days ago, we found that after a time point, let's say, 20:00, all http session destroy events were not logged.
    It seemed many http sessions started without ended.

    According to log, our custom module on wowza experienced an IO exception (Too many open files) that day, about six hours earlier than this weird problem happened.

    java.io.IOException: Too many open files
    at sun.nio.ch.ServerSocketChannelImpl.accept0(Native Method)
    at sun.nio.ch.ServerSocketChannelImpl.accept(ServerSocketChannelImpl.java:226)
    at org.apache.mina.transport.socket.nio.SocketAcceptor$Worker.processSessions(Unknown Source)
    at org.apache.mina.transport.socket.nio.SocketAcceptor$Worker.run(Unknown Source)
    at org.apache.mina.util.NamePreservingRunnable.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:722)

    Could the exception be the cause?

    We would want to know if there's any chance that the timeout-timer for http session crashes and therefore prevents http sessions from being destroyed because of some programmatic error?

    Thanks in advance,

    weichung

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Take a look at the ulimit settings in the Tuning Guide:

    http://www.wowza.com/forums/content....ormance-tuning

    Richard

  3. #3
    Join Date
    Aug 2012
    Posts
    25

    Default

    Hi Richard,
    Thanks for the quick reply!

    Are you suggesting that it is the file open problem which overloads the server and thus no http session ends?
    Cause we thought so at the first place, but not quite sure.
    We have set the ulimit to be 65535 and temporarily fixed the problem, is this a good idea?

    On the other hand, we also have checked our custom module and refined the file open process.

    weichung

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Why 65335? That happens to be the number of UDP ports we recommend opening for RTSP streaming. The tuning guide recommends setting ulimit to 20000 (twenty thousand)

    Richard

  5. #5
    Join Date
    Aug 2012
    Posts
    25

    Default

    It seems that I kind of put the cart before the horse.

    We guess that the cause might be the crash of http session timeout-timer, and from that moment no http session ever ends.
    server log said that wowza exceeded the 20000 file-open limit and crashed a day and half later.

    If we're right, why would the timer fail?


    weichung

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I suppose you can try to raise the ulimit setting. I don't think the "http session timeout-timer crashed". It is very busy server, I take it.

    Richard

  7. #7
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Zip up and send /conf and /logs folders to support@wowza.com. Tell us which log file to look at, when did this happen? Have you changed any configuration since then? If so, please detail those changes so we know the difference between the logs we are looking at the configuration you are sending.

    Include a link to this thread for reference.

    Richard

Similar Threads

  1. HTTP Cupertino session Reject
    By pirateMan in forum Server-side Modules and Code Samples Discussion
    Replies: 7
    Last Post: 09-09-2014, 05:44 AM
  2. About HTTP session timeout problem
    By Roy0817 in forum General Forum
    Replies: 3
    Last Post: 03-14-2013, 07:47 AM
  3. http session stream change
    By notreg in forum Server-side Modules and Code Samples Discussion
    Replies: 2
    Last Post: 05-28-2012, 08:39 AM
  4. Play duration of http session
    By Roy0817 in forum General Forum
    Replies: 1
    Last Post: 05-17-2012, 07:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •