Results 1 to 3 of 3

Thread: Can wowza injest a RTP/MPEG2-TS Multicast stream

  1. #1
    Join Date
    Jan 2012
    Posts
    13

    Default Can wowza injest a RTP/MPEG2-TS Multicast stream

    I see my mulitcast packets coming into eth0 on the box:

    root@devstream1:/usr/local/WowzaMediaServer/bin# tshark -i eth0 host 224.6.6.6
    tshark: Lua: Error during loading:
    [string "/usr/share/wireshark/init.lua"]:45: dofile has been disabled
    Running as user "root" and group "root". This could be dangerous.
    Capturing on eth0
    0.000000 192.168.10.98 -> 224.6.6.6 UDP 1370 Source port: 10444 Destination port: 11111
    0.014040 192.168.10.98 -> 224.6.6.6 UDP 1370 Source port: 10444 Destination port: 11111

    I created a stream file:

    root@devstream1:/usr/local/WowzaMediaServer/content# cat envivio.stream
    rtsp://224.6.6.6:11111


    I put it in the Startup file:

    <StartupStream>
    <Application>live/_definst_</Application>
    <MediaCasterType>rtp</MediaCasterType>
    <StreamName>envivio.stream</StreamName>
    </StartupStream>

    But the wowza output shows:

    ERROR server comment - MediaCasterConnection.connect: Failed to connect[224.6.6.6:11111]: org.apache.mina.common.RuntimeIOException: Failed to get the session[java.net.SocketException: Network is unreachable].

    My firewall is off and eth0 shows MULTICAST support:
    root@devstream1:/usr/local/WowzaMediaServer/content# ifconfig eth0
    eth0 Link encap:Ethernet HWaddr 78:2b:cb:08:ad:92
    inet addr:192.168.10.97 Bcast:192.168.10.255 Mask:255.255.255.0
    inet6 addr: fe80::7a2b:cbff:fe08:ad92/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:45288 errors:0 dropped:0 overruns:0 frame:0
    TX packets:245930 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:11245848 (11.2 MB) TX bytes:299994434 (299.9 MB)


    Help appreciated. Thanks.

  2. #2
    Join Date
    Jan 2012
    Posts
    13

    Default

    ok think i found it on another thread. looks like it's working.
    udp://ip:port

  3. #3
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi
    I'm glad you got it working and thanks for the update.

    Jason

Similar Threads

  1. TS h.264 5mbps multicast stream in to wowza and needs to be rtmp 500k multicast out
    By panzer in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 05-15-2013, 12:16 PM
  2. RTP Multicast stream to Wowza
    By ehuman in forum Live Streaming and Encoder Discussion
    Replies: 11
    Last Post: 02-07-2012, 01:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •