Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Proxy issues with SMIL

  1. #1
    Join Date
    May 2013
    Posts
    15

    Question Proxy issues with SMIL

    Hi,

    I am trying to figure out what may cause the following problem.

    Several users are accessing a Wowza via a Squid proxy. The site uses jwplayer 6. Clients have the latest flash-player installed and active. Wowza listens on 1935 and 80.

    Problem: only the first video plays. As long as one video is playing on gets "Error loading stream: Manifest not found or invalid" for the other videos.

    I had a look with wireshark and can see that the second and following requests for the SMIL are answered by a new session id. That surprises me.

    First attempt looks like this:
    .
    HTTP/1.0 404 Not Found
    Content-Type: application/x-fcs
    Server: FlashCom/3.5.7
    Cache-Control: no-cache
    Content-Length: 0
    X-Cache: MISS from PROXY
    X-Cache-Lookup: MISS from LXBM-D6.NH-Hamburg.NewHorizons.de:3128
    Via: 1.0 LXBM-D6.NH-Hamburg.NewHorizons.de:3128 (squid/2.7.STABLE9)
    Connection: close
    
    
    [builds new connection]
    
    
    POST http://stream.instantlearning.biz/open/1 HTTP/1.1
    Content-Type: application/x-fcs
    User-Agent: Shockwave Flash
    Host: stream.instantlearning.biz
    Content-Length: 1
    Proxy-Connection: Keep-Alive
    Pragma: no-cache
    
    
    HTTP/1.0 200 OK
    Content-Type: application/x-fcs
    Server: FlashCom/3.5.7
    Cache-Control: no-cache
    Content-Length: 11
    X-Cache: MISS from LXBM-D6.NH-Hamburg.NewHorizons.de
    X-Cache-Lookup: MISS from LXBM-D6.NH-Hamburg.NewHorizons.de:3128
    Via: 1.0 LXBM-D6.NH-Hamburg.NewHorizons.de:3128 (squid/2.7.STABLE9)
    Connection: keep-alive
    Proxy-Connection: keep-alive
    
    1564440512
    
    
    POST http://stream.instantlearning.biz/idle/1564440512/0 HTTP/1.1
    Content-Type: application/x-fcs
    User-Agent: Shockwave Flash
    Host: stream.instantlearning.biz
    Content-Length: 1
    Proxy-Connection: Keep-Alive
    Pragma: no-cache
    
    
    HTTP/1.0 200 OK
    Content-Type: application/x-fcs
    Server: FlashCom/3.5.7
    Cache-Control: no-cache
    Content-Length: 1
    X-Cache: MISS from PROXY
    X-Cache-Lookup: MISS from PROXY:3128
    Via: 1.0 PROXY:3128 (squid/2.7.STABLE9)
    Connection: keep-alive
    Proxy-Connection: keep-alive
    So that looks as expected. The SMIL is loaded, the connection is attempted, the player realizes it has to go via the proxy, opens a new stream, gets an id and happily plays the video.

    But then the second attempt to get a SMIL looks like this:

    GET http://stream.instantlearning.biz/ilsgo/smil:ILS_3030020_ILS_First_Steps.smil/jwplayer.smil HTTP/1.1
    Accept: */*
    Accept-Language: de-DE
    Referer: http://go.instantlearning.biz/fileadmin/res/js/jwplayer.flash.swf
    x-flash-version: 11,7,700,169
    Accept-Encoding: gzip, deflate
    User-Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)
    Host: stream.instantlearning.biz
    Proxy-Connection: Keep-Alive
    
    
    HTTP/1.0 200 OK
    Content-Type: application/x-fcs
    Server: FlashCom/3.5.7
    Cache-Control: no-cache
    Content-Length: 11
    X-Cache: MISS from PROXY
    X-Cache-Lookup: MISS from PROXY:3128
    Via: 1.0 PROXY:3128 (squid/2.7.STABLE9)
    Connection: keep-alive
    Proxy-Connection: keep-alive
    
    1948670105
    
    
    POST http://stream.instantlearning.biz/idle/1564440512/105 HTTP/1.1
    Content-Type: application/x-fcs
    User-Agent: Shockwave Flash
    Host: stream.instantlearning.biz
    Content-Length: 1
    Proxy-Connection: Keep-Alive
    Pragma: no-cache
    
    
    HTTP/1.0 200 OK
    Content-Type: application/x-fcs
    Server: FlashCom/3.5.7
    Cache-Control: no-cache
    Content-Length: 1
    X-Cache: MISS from PROXY
    X-Cache-Lookup: MISS from PROXY:3128
    Via: 1.0 PROXY:3128 (squid/2.7.STABLE9)
    Connection: keep-alive
    Proxy-Connection: keep-alive
    The id 1948670105 is never used anywhere later. I wasn't expecting an id anyway, as the player sent a GET for a SMIL, not a POST to open a new stream.

    What may I be doing wrong?

    Best
    Henrik

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Henrik,

    First, apply the following patch because you are using a version that had a problem with this technique. You'll notice that the system-bitrate values are given as kbs in the jwplayer.smil rendition.

    http://www.wowza.com/downloads/Wowza...5.2-patch8.zip

    Do you have any other HTTPProviders defined in the /conf/VHost.xml /HostPort that you are using for the jwplayer.smil?

    Richard

  3. #3
    Join Date
    May 2013
    Posts
    15

    Default

    Thank you, Richard,

    Yes, it looks like this:
                            <HostPort>
                                    <ProcessorCount>4</ProcessorCount>
                                    <IpAddress>xxx</IpAddress>
                                    <!-- Separate multiple ports with commas -->
                                    <!-- 80: HTTP, RTMPT -->
                                    <!-- 554: RTSP -->
                                    <Port>1935,80</Port>
                                    <SocketConfiguration>
                                            <ReuseAddress>true</ReuseAddress>
                                            <!-- suggested settings for video on demand applications -->
                                            <ReceiveBufferSize>65000</ReceiveBufferSize>
                                            <ReadBufferSize>65000</ReadBufferSize>
                                            <SendBufferSize>65000</SendBufferSize>
                                            <!-- suggest settings for low latency chat and video recording applications
                                            <ReceiveBufferSize>32000</ReceiveBufferSize>
                                            <ReadBufferSize>32000</ReadBufferSize>
                                            <SendBufferSize>32000</SendBufferSize>
                                            -->
                                            <KeepAlive>true</KeepAlive>
                                            <!-- <TrafficClass>0</TrafficClass> -->
                                            <!-- <OobInline>false</OobInline> -->
                                            <!-- <SoLingerTime>-1</SoLingerTime> -->
                                            <!-- <TcpNoDelay>false</TcpNoDelay> -->
                                            <AcceptorBackLog>100</AcceptorBackLog>
                                    </SocketConfiguration>
                                    <HTTPStreamerAdapterIDs>cupertinostreaming,smoothstreaming,sanjosestreaming,dvrchunkstreaming</HTTPStreamerAdapterIDs>
                                    <HTTPProviders>
                                            <HTTPProvider>
                                                    <BaseClass>com.wowza.wms.http.HTTPCrossdomain</BaseClass>
                                                    <RequestFilters>*crossdomain.xml</RequestFilters>
                                                    <AuthenticationMethod>none</AuthenticationMethod>
                                            </HTTPProvider>
                                            <HTTPProvider>
                                                    <BaseClass>com.wowza.wms.http.HTTPClientAccessPolicy</BaseClass>
                                                    <RequestFilters>*clientaccesspolicy.xml</RequestFilters>
                                                    <AuthenticationMethod>none</AuthenticationMethod>
                                            </HTTPProvider>
                                            <HTTPProvider>
                                                    <BaseClass>com.wowza.wms.http.HTTPProviderMediaList</BaseClass>
                                                    <RequestFilters>*jwplayer.rss|*jwplayer.smil|*medialist.smil|*manifest-rtmp.f4m</RequestFilters>
                                                    <AuthenticationMethod>none</AuthenticationMethod>
                                            </HTTPProvider>
                                            <HTTPProvider>
                                                    <BaseClass>com.wowza.wms.http.HTTPServerVersion</BaseClass>
                                                    <RequestFilters>*</RequestFilters>
                                                    <AuthenticationMethod>none</AuthenticationMethod>
                                            </HTTPProvider>
                                    </HTTPProviders>
    If this looks clueless, it is. I just took over from somebody else.

    I'll apply the patch asap.

    Thanks again
    Henrik

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Henrik,

    That looks okay. See if applying that patch and getting the right system-bitrate fixes this. Let me know

    Richard

  5. #5
    Join Date
    May 2013
    Posts
    15

    Default

    Patch seems to have done the trick. I'll now try to understand the bitrate issue.

    Thank you very much!
    Henrik

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Cool. Thanks for the quick update

    Richard

  7. #7
    Join Date
    May 2013
    Posts
    15

    Default

    Okay, understood. Bitrates seem to be okay now as well.

  8. #8
    Join Date
    May 2013
    Posts
    15

    Default

    Gave the thumbs up too early. I forced all traffic to go via the proxy and there it is again.
    Last edited by SONIC-HZ; 05-14-2013 at 08:44 AM. Reason: mistyped

  9. #9
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You cannot proxy RTMP traffic.

    Richard

  10. #10
    Join Date
    May 2013
    Posts
    15

    Exclamation

    Same thing again. Sorry.

    I click on the second video. Used IE developer tools this time to capture the reuest and response.

    Request headers
    Key	Value
    Request	GET http://stream.instantlearning.biz/ilsgo/smil:ILS_215_0140_The_Ruler.smil/jwplayer.smil HTTP/1.1
    Accept	*/*
    Accept-Language	de-DE
    Referer	http://go.instantlearning.biz/fileadmin/res/js/jwplayer.flash.swf
    x-flash-version	11,7,700,169
    Accept-Encoding	gzip, deflate
    User-Agent	Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)
    Host	stream.instantlearning.biz
    Proxy-Connection	Keep-Alive
    Response headers
    Key	Value
    Response	HTTP/1.0 200 OK
    Content-Type	application/x-fcs
    Server	FlashCom/3.5.7
    Cache-Control	no-cache
    Content-Length	9
    X-Cache	MISS from PROXY
    X-Cache-Lookup	MISS from PROXY:3128
    Via	1.0 PROXY:3128 (squid/2.7.STABLE9)
    Connection	keep-alive
    Proxy-Connection	keep-alive
    and the response body
    54159775
    I was expecting the SMIL here. So was the player, it displays "Error loading stream: Manifest not found or invalid" again.

    I believe when I said it worked before, I had accidentally allowed direct internet access, so browser was able to talk to Wowza directly.

    Henrik

Page 1 of 2 12 LastLast

Similar Threads

  1. force rtmpt in SMIL generated by jwplayer.smil?
    By SONIC-HZ in forum Video On Demand Streaming Discussion
    Replies: 2
    Last Post: 05-14-2013, 07:39 AM
  2. Stream not found [live/smil:myStream.smil/manifest.f4m]: myStream.smil
    By viet_fpt in forum Live Streaming and Encoder Discussion
    Replies: 12
    Last Post: 04-08-2013, 07:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •