Results 1 to 4 of 4

Thread: HLS on IOS always stops. (works fine in flash)

  1. #1
    Join Date
    Jun 2013
    Posts
    4

    Default HLS on IOS always stops. (works fine in flash)

    http://media.ppcnseo.com:1935/live/n.../playlist.m3u8

    The stream above I am trying to get working on IOS.
    Currently available at http://ppcnseo.com/Media/ but subject to change.

    This page is streaming fine in chrome on linux.

    However the same page is not working well on IOS (testing on ipad mini).
    It will start to play, then after a second or 2 is stops - doing this everytime without fail.
    This is not just pausing like a buffering issue, the stream fully stops, needing to click play again to restart.
    jwplayer is not the issue, since using the stream link directly in the browser does the same (works but stops).

    I have also tried alternative version links with the same issue.
    http://media.ppcnseo.com:1935/live/p.../playlist.m3u8
    http://media.ppcnseo.com:1935/live/ppmg/playlist.m3u8
    Both work in chrome desktop, not on ipad.

  2. #2
    Join Date
    May 2013
    Posts
    680

    Default

    Are you receiving any errors in the logs after playback (from iOS)? You may want to take a look at the following as well:

    Cupertino-Streaming-segmenter-parameters-(iOS)

  3. #3
    Join Date
    Jun 2013
    Posts
    4

    Default

    I will give a quick overview of the various settings here.
    FMLE - H264 Baseline Level 3 (was 4). Keyframe 1s (was 5s)
    720x567 1000kbps source at 25fps
    Mp3 stereo 22050Hz 48Kbps

    Mostly unaltered default transrate settings
    360p 640x360 850Kb
    240p 360x240 350Kb
    160p 284x260 200Kb

    cupertinoChunkDurationTarget 6000
    cupertinoMaxChunkCount 10
    cupertinoPlaylistChunkCount 4
    cupertinoRepeaterChunkCount 4

    Server load is at low levels.

    Tried lowering the primary stream to 100Kbps to see if it was bandwidth related and still the same.
    Lowered it to 50Kbps and said no stream.




    Don't seem to receiving any errors related to IOS. Nothing new when I try streaming.

    Had some " Fragment duration greater than suggested range of 1-4 seconds. Adjust keyframe interval accordingly: Fragment durations: [5.0,5.0,5.0]" before
    But I have already lowered the keyframes on FMLE to 1 second now.


    Had this error a few days ago
    Strange since this stream is working in chrome desktop (http://media.ppcnseo.com:1935/live/p.../playlist.m3u8)
    WARN server comment 2013-07-10 07:46:44 - - - - - 0.249 - - - - - - - - HTTPStreamerAdapterCupertinoStreamer.getAppInstance: Stream not found [live/ppmg_160p/media_6961.ts?wowzasessionid=904704971]: ppmg_160p

    And same strange situation on this (stream works fine in chrome http://media.ppcnseo.com:1935/live/n.../playlist.m3u8)
    WARN server comment 2013-07-12 11:14:19 - - - - - 185255.218 - - - - - - - - HTTPStreamerAdapterCupertinoStreamer.getAppInstance: Stream not found [live/ngrppmg_all/chunklist-b249152.m3u8?wowzasessionid=100808118]: ppmg_160p

  4. #4
    Join Date
    May 2013
    Posts
    680

    Default

    Restart Wowza and try playing back from your iOS device again. Then zip up your [install-dir]/conf and [install-dir]/logs and send it to support@wowza.com

Similar Threads

  1. Live stream works everywhere except iOS HLS (where only audio works).
    By chocis in forum Live Streaming and Encoders
    Replies: 3
    Last Post: 04-23-2014, 09:24 AM
  2. Live streaming stuck on smooth player, works fine on HLS player (iPad)
    By Strashila in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 12-02-2013, 10:56 AM
  3. Stuttering of HLS, same video in progressiv dowload works fine
    By kontaktschmied in forum Video On Demand Streaming Discussion
    Replies: 0
    Last Post: 12-24-2012, 05:58 AM
  4. Apple iOS not streaming, everything else works fine.
    By rviteri in forum Live Streaming and Encoder Discussion
    Replies: 14
    Last Post: 11-24-2012, 04:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •