Results 1 to 4 of 4

Thread: JWPlayer cannot connect to server after there's roughly 20 users online

  1. #1
    Join Date
    Jul 2013
    Posts
    11

    Default JWPlayer cannot connect to server after there's roughly 20 users online

    Hi all,

    I am using Wowza on Amazon EC2. Streaming works great using JWPlayer as my web client, Wowza as my server and our hosts are using Wirecast. Today, after we had around 20-25 users connect, new users would get the Error loading stream message from JWPlayer. There aren't any firewall limitations on the wowza server. It's not in a load balanced environment and RTMP is completely unfiltered. My JWPlayer is a Pro license and my Wowza license is the one that's bundled with Amazon EC2. Is there a connection limitation somewhere that I'm overlooking that's on by default? The existing 20 users who were connected and did not have issues didn't experience latency or anything odd like that. CPU on the server was essentially 80% idle and there was plenty of resources on the instance to spread the wealth around. I didn't enable any additional modules to limit the number of users who can connect.

    Perhaps someone here with more experience can point me in the right direction of where to further debug. I've checked wowza error logs - nothing. I've checked access logs and there's nothing obvious there that looks incorrect. Any steps to further debug would be fantastic - I'll post anything asked of me.

    Thanks much all,

    /sf

  2. #2

    Default

    Hi,

    From your description, it sounds like you may have launched a Lickey Wowza instance but not provided your own Wowza License.

    Wowza has 2 instance types on EC2.

    DevPay which uses a built in license which is billed as part of the EC2 hourly rate. You cannot use premium addons with DevPay.

    Lickey which uses your own Wowza license and is billed at the normal EC2 rate. The Wowza License is billed separately from Wowza. You can use the premium addons with this instance type.

    The Lickey instances have a developer license installed so that the server will configure and start up correctly. This license is limited to 10 concurrent connections. You need to replace this license with your own and restart Wowza.

    More info on the different types is here.

    Roger.

  3. #3
    Join Date
    Jul 2013
    Posts
    11

    Default

    Hi Roger,

    I'll go ahead and take a look - this is entirely possible. Wouldn't there be an error message somewhere warning us about this? I'd love to confirm that is indeed the issue.

    /sf

  4. #4

    Default

    Hi,

    In the first few lines of the access logs you should see the license type and connections limit if there is any.

    Roger.

Similar Threads

  1. number of users online from connectioncounts.xml
    By nvanhaute1 in forum Server Administration Discussion
    Replies: 3
    Last Post: 01-30-2014, 08:44 AM
  2. Can't Connect To VOD With JWPlayer 5 on Windows Intranet
    By mj9999 in forum Video On Demand Streaming Discussion
    Replies: 2
    Last Post: 07-14-2013, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •