Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Audio only live streaming to Android 4.2

  1. #1
    Join Date
    Sep 2012
    Posts
    5

    Default Audio only live streaming to Android 4.2

    Hello,

    We are attempting to stream either an MP3 or AAC audio only stream to Android 4.2 devices. If we add a video stream it works just fine. We have tried rtsp and http but do not have any success beyond Android 4.1.1

    Sorry if this has been covered; I did search around quite a bt before posting.

    Thank you

  2. #2
    Join Date
    Sep 2012
    Posts
    5

    Default

    Forgot to mention, stream plays in VLC. Thanks

  3. #3
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I'm not sure if it is true with the Android device you are testing or other newer models, but it is our understanding that streaming mp3 audio does not work in Android devices. In any case, I would work with aac audio. Is the HTTP playback you are testing HLS (cupertino) streaming?

    What encoder are you using, and encoding details?

    Look at the access log, find the x-event "publish" row for that live stream, then look after below that at the cupertino packetizer log messages regarding audio codec and (if present) video codec, and the packetizing lines that show "a/v/k" numbers. What do you see?

    Richard

  4. #4
    Join Date
    Sep 2012
    Posts
    5

    Default

    Richard,

    Thanks for your reply. We are using FMLE 3.2, audio only stream, MP3 codec with 44.1 sample rate and 128 stereo bitrate.

    Encoder is on PC so attempting to avoid having our client purchase multiple AAC plug-ins. HTTP playback had HLS (cupertino) first and I now have made it the only option and restarted the application; same result. We did have the stream name with the mp4: prefix that doesn't seem to matter so we removed it from the encoder.

    From the access log:

    Publish:

    2013-10-04 12:30:34 CDT publish stream INFO 200 stream-mmp - _defaultVHost_ live-legacy27 _definst_ 0.066 [any] 1935 rtmp://server_address/live-legacy27 24.62.128.62 rtmp rtmp://server_adress/live-legacy27 FMLE/3.0 (compatible; FMSc/1.0) 760239315 3544 3608 1 0 0 0 stream-mmp videoKeyframeFrequency=0&totalDatarate=128 - - 0 0.0 rtmp://server_adress/live-legacy27/stream-mmp?videoKeyframeFrequency=0&totalDatarate=128 rtmp:/server_adress/live-legacy27/stream-mmp videoKeyframeFrequency=0&totalDatarate=128 rtmp://server_adress/live-legacy27 -



    I am not sure what the a/v/k numbers are but here are the lines pertaining to cupertino packetizer:

    INFO 200 - LiveStreamPacketizerCupertino.init[live-legacy27/_definst_/stream-mmp]: chunkDurationTolerance: 500 - - - 94273.641 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-04 12:30:35 CDT comment server INFO 200 - LiveStreamPacketizerCupertino.init[live-legacy27/_definst_/stream-mmp]: audioGroupCount: 3 - - - 94273.641 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-04 12:30:35 CDT comment server INFO 200 - LiveStreamPacketizerCupertino.init[live-legacy27/_definst_/stream-mmp]: playlistChunkCount:3 - - - 94273.641 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-04 12:30:35 CDT comment server INFO 200 - MediaStreamMap.getLiveStreamPacketizer: Create live stream packetizer: cupertinostreamingpacketizer:stream-mmp - - - 94273.641 - - - - - - - - - - - - - - - - - - - - - - - - -
    2013-10-04 12:30:35 CDT comment server


    Thanks again

  5. #5
    Join Date
    Sep 2012
    Posts
    5

    Default

    Lastly, rtsp that plays in VLC:

    rtsp://server_address:1935/live-legacy27/stream-mmp

    Code info shows:
    Type: Audio
    Codec: MPEG Audio Layer 1/2/3 (mpga)
    Sample rate: 44100 Hz
    Bitrate: 128 kb/s

    Thank you

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I think AAC audio is going to be necessary. If you want a free way to test AAC you can use VLC:

    http://www.wowza.com/forums/content....rver-(MPEG-TS)

    Here is a VLC command that will be aac audio-only

    vlc -vvv "%WMSAPP_HOME%/content/sample.mp4" --no-sout-video --sout "#transcode{acodec=mp4a,ab=96,channels=2,samplerate=48000}:rtp{dst=127.0.0.1,port=10000,mux=ts}"
    Follow the mpeg-ts guide to re-stream that.

    And this older VLC guide might be helpful if your users are connecting to a mic

    Richard

  7. #7
    Join Date
    Dec 2009
    Posts
    27

    Default

    Richard,

    I've been streaming live and ondemand mp3 files via m3u8 playlist for over 2 years now and it works fine on Chrome Browser (using <video> tags on Android 4.1). The same setup streaming to Android 4.3 no longer appears to work (AAC is fine and MP3 progressive download works fine). Your comment in this post caught my eye because I haven't found any information as to why this no longer works. Can you point me in the right direction?

    Thanks,

    Mike
    Last edited by elcapitan26; 10-23-2013 at 02:11 PM.

  8. #8
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    I don't think we do know why. Streaming MP3 to Android has been inconsistent in our experience, certainly doesn't seem to work at all with RTSP. HLS perhaps OK on some device / OS combinations. It certainly isn't uncommon for some functionality to mysteriously stop working between versions.
    Regarding MP3 in an m3u8 playlist working fine on Chrome Browser, do you have an example HTML5 page you would care to share with the community?

    Daren

  9. #9
    Join Date
    Dec 2009
    Posts
    27

    Default

    Daren,

    Here's an example

    http://www.webcasts.com/typhoon/labs...audiotest.html

    Both clips work in Chrome 30 on Android 4.1 but the second clip from Wowza does not work on Android 4.3.

    Files that use AAC work fine.

  10. #10
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi Mike,
    I'd expect the first one to work on any html5 compliant browser as it is progressive download (works in the old Android browser too).
    The second clip also worked for me on Android 4.2. I don't have any other devices to try on, but nice to see mp3 streaming to Android in this case. I suspect something broke in either Chrome on Android 4.3 or in the underlying HLS implementation with regards to mp3.
    Have you tried on many 4.3 devices?

    Daren

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 2
    Last Post: 09-13-2012, 08:31 AM
  2. Live Stream Audio Works for FLV Missing for RTSP on Android
    By complexcarb in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 08-15-2012, 03:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •