Results 1 to 5 of 5

Thread: No audio on output stream

  1. #1
    Join Date
    Feb 2014
    Posts
    3

    Default No audio on output stream

    Hi,

    I'm inputting to Wowza an RTP h264 .ts with MPEG1 Audio layer ll Mode and there is no Audio on the output stream

    What do I need to change in the config to make the audio work?

    I'm using Wowza 4, see sample log:

    #Version: 1.0
    #Start-Date: 2014-02-19 11:44:47 GMT
    #Software: Wowza Streaming Engine 4.0.0.00 build10425
    #Date: 2014-02-19
    #Fields: x-severity x-category x-event date time c-client-id c-ip c-port cs-bytes sc-bytes x-duration x-sname x-stream-id x-spos sc-stream-bytes cs-stream-bytes x-file-size x-file-length x-ctx x-comment
    WARN server comment 2014-02-19 11:44:47 - - - - - 43488.986 - - - - - - - - LiveStreamPacketizerSanJose.handlePacket[liveorigin/_definst_/test.stream][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Flash player.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43488.988 - - - - - - - - LiveStreamPacketizerCupertino.handlePacket[liveorigin/_definst_/test.stream][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable on iOS devices.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43488.988 - - - - - - - - LiveStreamPacketizerSmoothStreaming.handlePacket[liveorigin/_definst_/test.stream][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Silverlight player.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43488.998 - - - - - - - - LiveStreamPacketizerSanJose.handlePacket[liveorigin/_definst_/test.stream][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Flash player.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43488.998 - - - - - - - - LiveStreamPacketizerCupertino.handlePacket[liveorigin/_definst_/test.stream][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable on iOS devices.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43488.999 - - - - - - - - LiveStreamPacketizerSmoothStreaming.handlePacket[liveorigin/_definst_/test.stream][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Silverlight player.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43489.004 - - - - - - - - LiveStreamPacketizerSanJose.handlePacket[liveorigin/_definst_/test.stream_source][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Flash player.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43489.008 - - - - - - - - LiveStreamPacketizerSanJose.handlePacket[liveorigin/_definst_/test.stream_360p][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Flash player.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43489.009 - - - - - - - - LiveStreamPacketizerCupertino.handlePacket[liveorigin/_definst_/test.stream_360p][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable on iOS devices.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43489.008 - - - - - - - - LiveStreamPacketizerSmoothStreaming.handlePacket[liveorigin/_definst_/test.stream_360p][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Silverlight player.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43489.011 - - - - - - - - LiveStreamPacketizerCupertino.handlePacket[liveorigin/_definst_/test.stream_source][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable on iOS devices.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43489.013 - - - - - - - - LiveStreamPacketizerSmoothStreaming.handlePacket[liveorigin/_definst_/test.stream_source][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Silverlight player.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43489.013 - - - - - - - - LiveStreamPacketizerCupertino.handlePacket[liveorigin/_definst_/test.stream_160p][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable on iOS devices.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43489.012 - - - - - - - - LiveStreamPacketizerSanJose.handlePacket[liveorigin/_definst_/test.stream_160p][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Flash player.
    WARN server comment 2014-02-19 11:44:47 - - - - - 43489.015 - - - - - - - - LiveStreamPacketizerSmoothStreaming.handlePacket[liveorigin/_definst_/test.stream_160p][mp4a.40.33]: MP3 Audio: Audio is not MPEG1 Layer 3. May not be playable by Silverlight player.

  2. #2
    Join Date
    Feb 2014
    Posts
    3

    Default

    A bit more info: there is audio on stream recordings captured from incoming streams

    But no audio using the testplayer built into wowza 4

  3. #3

    Default

    A few questions:

    What is the source of the stream?
    Is there video as well as audio, or audio only?
    What player are you testing in?
    Can you encode to a different audio format with the encoder?
    Are there any other errors in the logs?
    Are you using the Wowza Transcoder in this workflow?

    Salvadore

  4. #4
    Join Date
    Feb 2014
    Posts
    3

    Default

    Hi Salvadore,

    Thanks for your reply, I was using the Transrate to transcode and had passthough set for the audio.

    It's working now

    Kevin

  5. #5

    Default

    Kevin, thanks for the update. Glad to hear it is working.

    Salvadore

Similar Threads

  1. Using Transcoder Add on to Disable Audio in the output
    By manojprasath in forum AddOn: Transcoder
    Replies: 9
    Last Post: 06-28-2013, 08:23 AM
  2. Output stream over RTSP
    By wilfredw in forum General Forum
    Replies: 1
    Last Post: 05-14-2012, 04:30 AM
  3. relay (repeater) rtmp video/audio to rtmp audio only output (strip video)
    By dptekco in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 03-22-2012, 07:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •