Results 1 to 3 of 3

Thread: Transcoder frame drop

  1. #1
    Join Date
    Sep 2013
    Posts
    18

    Default Transcoder frame drop

    Hi.

    I'm using Wowza Streaming Engine and Transcoder AddOn. The transcoder is currently encoding with QuickSync 1.4. I am getting frame drops and variable frame rate in transcoded stream. CPU is at 10% and I have plenty memory free.

    I have tried changing some quicksync settings as TargetUsage and NumReFrame but I still get Variable frame rate due to frame drops. When I record the stream it does show some bitrate variability but it is low, and video playbacks verry well.

    Source stream is 1Mbps and frame drops when playing back with strobe media playback are much less than playing back transcoded streams, although everything seems totaly random. I've tried playing back in different players and browsers but I can't get a smooth result.

    Any ideas?

    Regards
    Eduardo

  2. #2
    Join Date
    Sep 2013
    Posts
    18

    Default

    I'm still doing some checks and I think it is not related to Wowza neither the Transcoder.

    I was checking with single bitrate streams and fps dropped. Then I checked with Adaptive Bitrate through RTMP, and it started to work better. It seems as if OSMF or Strobe Media Playback, choose to drop frames instead of buffering when there is not enough bandwidth. This was solved with Adaptive Bitrate because the player ha the option of requesting a lower bitrate stream rather than dropping frames.

    I am checking with other players to confirm this is the issue, but it seems that's it.

    What I have noticed is that transcoded streams have variable frame rate, I would like to force Constant Frame Rate, there is enough CPU power to do this so I don't know why Wowza makes it variable.

    Eduardo

  3. #3
    Join Date
    Sep 2013
    Posts
    18

    Default

    I'm still having some issues with getting variable frame rate in Wowza Transcoder.
    Here are my encoder options, what can I tweak to get constant frame rate and aligned streams?

    # long: CodecId: MFX_CODEC_AVC=MFX_MAKEFOURCC('A','V','C',' '), MFX_CODEC_MPEG2=MFX_MAKEFOURCC('M','P','G','2'), MFX_CODEC_VC1 =MFX_MAKEFOURCC('V','C','1',' ') - - - 1880.079 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.CodecId: 541283905 - - - 1880.08 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: CodecProfile: 66=MFX_PROFILE_AVC_BASELINE, 77=MFX_PROFILE_AVC_MAIN, 100=MFX_PROFILE_AVC_HIGH - - - 1880.08 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.CodecProfile: 66 - - - 1880.081 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: CodecLevel: MFX_LEVEL_AVC_1=10, MFX_LEVEL_AVC_1b=9, MFX_LEVEL_AVC_11=11, MFX_LEVEL_AVC_12=12, MFX_LEVEL_AVC_13=13, MFX_LEVEL_AVC_2=20, MFX_LEVEL_AVC_21=21, MFX_LEVEL_AVC_22=22, MFX_LEVEL_AVC_3=30, MFX_LEVEL_AVC_31=31, MFX_LEVEL_AVC_32=32, MFX_LEVEL_AVC_4=40, MFX_LEVEL_AVC_41=41, MFX_LEVEL_AVC_42=42, MFX_LEVEL_AVC_5=50, MFX_LEVEL_AVC_51=51 - - - 1880.081 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.CodecLevel: 0 - - - 1880.082 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: NumThread: 0 = encoder decides - - - 1880.082 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.NumThread: 0 - - - 1880.082 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: TargetUsage: 0=MFX_TARGETUSAGE_UNKNOWN, 1=MFX_TARGETUSAGE_BEST_QUALITY, 4=MFX_TARGETUSAGE_BALANCED, 7=MFX_TARGETUSAGE_BEST_SPEED - - - 1880.083 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.TargetUsage: 4 - - - 1880.083 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: GopPicSize - - - 1880.084 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.GopPicSize: 0 - - - 1880.084 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: GopRefDist - - - 1880.085 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.GopRefDist: 1 - - - 1880.085 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: GopOptFlag: 1=MFX_GOP_CLOSED, 2=MFX_GOP_STRICT - - - 1880.086 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.GopOptFlag: 3 - - - 1880.086 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: IdrInterval - - - 1880.087 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.IdrInterval: 1 - - - 1880.087 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: RateControlMethod: 1=MFX_RATECONTROL_CBR, 2=MFX_RATECONTROL_VBR, 3=MFX_RATECONTROL_CQP - - - 1880.088 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.RateControlMethod: 2 - - - 1880.088 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: InitialDelayInKB - - - 1880.089 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.InitialDelayInKB: 0 - - - 1880.089 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: QPI - - - 1880.09 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.QPI: 0 - - - 1880.09 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: BufferSizeInKB - - - 1880.091 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.BufferSizeInKB: 0 - - - 1880.091 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: TargetKbps - - - 1880.091 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.TargetKbps: 700 - - - 1880.092 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: QPP - - - 1880.092 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.QPP: 700 - - - 1880.093 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: MaxKbps - - - 1880.093 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.MaxKbps: 770 - - - 1880.094 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: QPB - - - 1880.094 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.QPB: 770 - - - 1880.095 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: NumSlice - - - 1880.095 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.NumSlice: 0 - - - 1880.095 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: NumRefFrame - - - 1880.096 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.NumRefFrame: 0 - - - 1880.097 - - - - - - - - - - - - - - - - - - - - - - - - -
    # long: EncodedOrder: binary flag, 0 signals encoder to take frames in display order - - - 1880.097 - - - - - - - - - - - - - - - - - - - - - - - - -
    quicksync.EncodedOrder: 1

    Thanks for any help

Similar Threads

  1. The video frame rate drop
    By zhui.Dota in forum Video On Demand Streaming Discussion
    Replies: 1
    Last Post: 04-12-2012, 07:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •