Results 1 to 4 of 4

Thread: Audio introduce clicking noise after few minutes of live RTSP/RTP streaming

  1. #1
    Join Date
    Apr 2014
    Posts
    2

    Default Audio introduce clicking noise after few minutes of live RTSP/RTP streaming

    I'm using Directshow filters and getting clicking sound after few minutes of streaming. It's like a mouse clicking sound. If I do not use Reference clock, the issue resolve but the Audio-Video sync does not work and Lypsing doesn't work properly

    While using VLC Player it works fine.

    Please let me know the resolution ASAP as I am struggling since long for the resolution.


    Thanks,

  2. #2

    Default

    You could try adding a sort buffer to fix the out of sync audio/video:
    How to fix unaligned video and audio with a server-side sort buffer

    Salvadore

  3. #3
    Join Date
    Apr 2014
    Posts
    2

    Default

    Not working, I also tried by changing implementation of source filter, but still no success.

    Previously the graph prepared as below:

    Push Source -> ACM Wrapper -> DC-DSP Filter (Amplify filter) -> Render

    I checked using graph edit, that DC-DSP filter can implement before decoder so implement change as below:

    Push Source -> DC-DSP Filter (Amplify filter) -> ACM Wrapper -> Render

    I checked timestamps of audio and video is working and lipsync is ok.

    Is there any way to change the priority of audio in Directshow filter. In case of any delay in audio Directshow should not drop audio. In my case i think filter dropping audio not video, This may help to resolve this issue


    When I use reference clock I heard clicking sound after few mins. Not using reference clock issue resolve but after some time the AV Sync not works this is random issue not every time or specific time.

  4. #4

    Default

    What audio codec are you sending to Wowza? And what player are you experiencing this problem in?
    Also, what video codec are you sending to Wowza?

    Salvadore

Similar Threads

  1. Noise reduction audio filter
    By Artem Orlov in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 08-25-2014, 05:51 AM
  2. Live Streaming of Audio Only starting with RTP/PCMA
    By macropanther in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 05-22-2013, 06:43 PM
  3. Live Audio Streaming: Background Noise/Disturbance
    By Jaskaran81 in forum General Forum
    Replies: 4
    Last Post: 11-19-2012, 11:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •