Results 1 to 9 of 9

Thread: mac + eclipse + not compile

  1. #1

    Default mac + eclipse + not compile

    Hi,
    don't working compile in wowza 4 (ams 3.6 work fine)

    mac + eclipse +ide2

    1.create simple project


    public class Start extends ModuleBase {
    
    	public void onAppStart(IApplicationInstance appInstance) {
    		String fullname = appInstance.getApplication().getName() + "/"
    				+ appInstance.getName();
    		getLogger().info("onAppStart: " + fullname);
    	}
    
    	public void onAppStop(IApplicationInstance appInstance) {
    		String fullname = appInstance.getApplication().getName() + "/"
    				+ appInstance.getName();
    		getLogger().info("onAppStop: " + fullname);
    	}
    
    	public void onConnect(IClient client, RequestFunction function,
    			AMFDataList params) {
    		getLogger().info("onConnect: " + client.getClientId());
    	}	 
    }
    2. try compile

    Exception in thread "main" java.lang.NullPointerException
    	at java.util.Hashtable.put(Hashtable.java:394)
    	at java.util.Properties.setProperty(Properties.java:143)
    	at java.lang.System.setProperty(System.java:745)
    	at com.wowza.wms.bootstrap.Bootstrap.resolveServerHome(Bootstrap.java:1383)
    	at com.wowza.wms.bootstrap.Bootstrap.main(Bootstrap.java:61)

  2. #2

    Default

    Hi there, can you please confirm you have installed the Wowza IDE?

    How are you creating this project?
    Are you using the "New/Java Project" method? Or are you using "New/Other" Wowza Wizard?

    Salvadore

  3. #3

    Default

    Additionally, if you need it, here is the Wowza IDE

    Salvadore

  4. #4

    Default

    Quote Originally Posted by salvadore View Post
    Hi there, can you please confirm you have installed the Wowza IDE?

    How are you creating this project?
    Are you using the "New/Java Project" method? Or are you using "New/Other" Wowza Wizard?

    Salvadore
    "New/Other" Wowza Wizard

  5. #5

    Default

    tried to use instruction http://www.wowza.com/streaming/devel...oftware-update
    create new project "New/Other" - not work.
    (but I removed /manager conf / arguments program -start argument and VM arguments)
    Exception in thread "main" java.lang.NullPointerException
    	at java.util.Hashtable.put(Hashtable.java:394)
    	at java.util.Properties.setProperty(Properties.java:143)
    	at java.lang.System.setProperty(System.java:745)
    	at com.wowza.wms.bootstrap.Bootstrap.resolveServerHome(Bootstrap.java:1383)
    	at com.wowza.wms.bootstrap.Bootstrap.main(Bootstrap.java:61)
    Last edited by pidboretskyy; 05-07-2014 at 06:31 AM.

  6. #6

    Default

    (but I removed /manager conf / arguments program -start argument and VM arguments)
    Don't do this, you need those for a Wowza project. That's what the IDE puts in place when you create a new project and new module.

    Also, you need to create a new Wowza project before creating the new module.

    Salvadore

  7. #7

    Default

    not work
    program arguments:
    start
    
    VM arguments:
    -Xmx768M
    -Dcom.wowza.wms.AppHome="/Library/WowzaStreamingEngine"
    -Dcom.wowza.wms.ConfigHome="/Library/WowzaStreamingEngine"
    -Dcom.sun.management.jmxremote=true
    result
    Error starting: java.lang.reflect.InvocationTargetException
    java.lang.reflect.InvocationTargetException
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    	at java.lang.reflect.Method.invoke(Method.java:601)
    	at com.wowza.wms.bootstrap.Bootstrap.startServer(Bootstrap.java:555)
    	at com.wowza.wms.bootstrap.Bootstrap.main(Bootstrap.java:67)
    Caused by: java.lang.NoClassDefFoundError: org/apache/commons/lang/SystemUtils
    	at com.wowza.wms.bootstrap.BootstrapSystemTuningInfo.getSystemTuningInfo(BootstrapSystemTuningInfo.java:81)
    	at com.wowza.wms.server.ServerTuningHandler.<init>(ServerTuningHandler.java:248)
    	at com.wowza.wms.server.Server.<init>(Server.java:862)
    	at com.wowza.wms.server.Server.getInstance(Server.java:908)
    	at com.wowza.wms.server.Server.start(Server.java:957)
    	... 6 more
    Caused by: java.lang.ClassNotFoundException: org.apache.commons.lang.SystemUtils
    	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
    	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    	at java.security.AccessController.doPrivileged(Native Method)
    	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
    	at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
    	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
    	at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
    	... 11 more

  8. #8

    Default

    add -Dcom.wowza.wms.native.base="mac"
    work!
    thanks.

  9. #9

    Default

    Yes, that was the missing link. Thanks for the update and glad you got this sorted out and working.

    Salvadore

Similar Threads

  1. Unable to install Wowza Eclipse Software Update plugin in Eclipse
    By runenes in forum Wowza Streaming Server Java API
    Replies: 9
    Last Post: 07-25-2014, 06:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •