Results 1 to 4 of 4

Thread: Custom cache control when serving crossdomain.xml ??

  1. #1

    Default Custom cache control when serving crossdomain.xml ??


    I'd like to specify the cache-control header when serving the crossdomain.xml file.

    I tried doing a HTTPProvider that builds and sends this file. However it seems that it always takes the file in the conf directory.

    Here's my VHost.xml configuration for that HTTPProvider:

    And the HTTPProvider Code (is in another package so it doesn't collide with wowza.wms)
    public class HTTPCrossdomain extends HTTProvider2Base {
    	public void onHTTPRequest(IVHost vhost, IHTTPRequest req, IHTTPResponse resp) {
    		if (!doHTTPAuthentication(vhost, req, resp))
    		StringBuffer response = new StringBuffer();
    		response.append("<?xml version=\"1.0\"?>");
    		response.append("<!DOCTYPE cross-domain-policy SYSTEM \"\">");
    		response.append("<allow-access-from domain=\"*\"/>");
    		response.append("<site-control permitted-cross-domain-policies=\"all\"/>");
    		try {
    			resp.setHeader("Content-Type", "text/xml");
    			resp.setHeader("Cache-Control", "foo");
    			OutputStream out = resp.getOutputStream();
    			byte[] outBytes = response.toString().getBytes();
    		} catch (Exception e) {
    					"ERROR: " + e.toString());
    I've tried removing the file at the conf directory but then the server responds with 404. It doesn't take in consideration the HTTPProvider one :/

    Any help?

  2. #2
    Join Date
    Dec 2007


    Trying that out, not getting it to work either quite yet. I'll look more.


  3. #3
    Join Date
    Dec 2007


    Getting back to this with more tests, I can confirm. Your HTTPProvider does not run in the 1935 HostPort with RequestFilter "*crossdomain.xml", but it does run with any other RequestFilter, and it does run in the 8086 HostPort with RequestFilter "*.crossdomain.xml".

    We've been digging in and are seeing where the issue is, but have a few steps as yet to sort out and take direction to fix. I will update you with any further info, temporary work-around perhaps or patch.

    Thanks for the report,

  4. #4
    Join Date
    Oct 2011


    Hello, is that issue resolved? I can confirm with Wowza Streaming Engine 4.2.0 that "*crossdomain.xml" filter isn't working.

Similar Threads

  1. crossdomain.xml not accessable
    By INVINTUS in forum General Forum
    Replies: 0
    Last Post: 01-10-2013, 12:33 PM
  2. Crossdomain policy issue. Crossdomain.xml file doesn't reject connections
    By Andrey3k in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 1
    Last Post: 10-08-2012, 06:55 AM
  3. Playlist, chunklist - Cache-control: no-cache
    By mcaron in forum Server-side Modules and Code Samples Discussion
    Replies: 0
    Last Post: 06-18-2012, 04:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts