Results 1 to 2 of 2

Thread: Transcoder stops unexpectedly

  1. #1
    Join Date
    Jun 2014
    Posts
    1

    Default Transcoder stops unexpectedly

    I'm running Wowza on an EC2 instance. After 32 minutes of live streaming, the transcoder stopped unexpectedly. I've seen an issue on this forum that the driver for the graphics card could cause this. However, I would think EC2 isn't graphics accelerated. Does anyone have any insight into this?


    -------------------------------

    2014-06-18 01:14:57 UTC comment server INFO 200 - LiveStreamPacketizerCupertino.endChunkTS[livecf/_definst_/felder-forum_240p]: Add chunk: id:11 mode:TS[H264,AAC] a/v/k:52/165/11 duration:9764 - - - 2008684.38 - - - - - - - - - - - - - - - - - - - - - - - - -2014-06-18 01:46:46 UTC comment server INFO 200 - TranscodingSession.close[livecf/_definst_/felder-forum] - - - 2010593.418 - - - -
    - - - - - - - - - - - - - - - - - - - - -2014-06-18 01:46:46 UTC unpublish stream INFO 200 felder-forum - _defaultVHost_ livecf _definst_ 2019.43 [any] 1935 rtmp://ec2-54-188-95-252.us-west-2.c
    ompute.amazonaws.com/livecf 104.35.118.46 rtmp http://www.pherver.com/static/backst...rver_stage.swf MAC 14,0,0,125 1601968006 152585146 7505 1 0 152394831 0 felder-forum - - - 0 0.0 rtmp://ec2-54-188-95-252.us-west-2.compute.amazonaws.com/livecf/felder-forum rtmp://ec2-54-188-95-252.us-west-2.compute.amazonaws.com/liv
    ecf/felder-forum - rtmp://ec2-54-188-95-252.us-west-2.compute.amazonaws.com/livecf -2014-06-18 01:46:46 UTC comment server INFO 200 - TranscoderStreamNameGroup.removeInternal[_defaultVHost_:livecf/_definst_/felder-forum]: Remove name group: felder-forum_all - - - 2010593.424 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC destroy stream INFO 200 felder-forum - _defaultVHost_ livecf _definst_ 2019.43 [any] 1935 rtmp://ec2-54-188-95-252.us-west-2.compute.amazonaws.com/livecf 104.35.118.46 rtmp http://www.pherver.com/static/backst...rver_stage.swf MAC 14,0,0,125 1601968006 152585146 7505 1 0 152394831 0 felder-forum - - - 0 0.0 rtmp://ec2-54-188-95-252.us-west-2.compute.amazonaws.com/livecf/felder-forum rtmp://ec2-54-188-95-252.us-west-2.compute.amazonaws.com/livecf/felder-forum - rtmp://ec2-54-188-95-252.us-west-2.compute.amazonaws.com/livecf -
    2014-06-18 01:46:46 UTC comment server INFO 200 - TranscodingSession.shutdown[livecf/_definst_/felder-forum] - - - 2010593.427 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC decoder-video-stop transcoder INFO 200 felder-forum - - - - 2010593.427 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC decoder-audio-stop transcoder INFO 200 felder-forum - - - - 2010593.428 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC encoder-video-stop transcoder INFO 200 felder-forum {name: "480p"} - - - 2010593.428 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC encoder-audio-stop transcoder INFO 200 felder-forum {name: "480p"} - - - 2010593.428 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC encoder-video-stop transcoder INFO 200 felder-forum {name: "240p"} - - - 2010593.428 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC encoder-audio-stop transcoder INFO 200 felder-forum {name: "240p"} - - - 2010593.428 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC encoder-video-stop transcoder INFO 200 felder-forum {name: "360p"} - - - 2010593.428 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC encoder-audio-stop transcoder INFO 200 felder-forum {name: "360p"} - - - 2010593.429 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC encoder-audio-stop transcoder INFO 200 felder-forum {name: "PassthroughAAC"} - - - 2010593.429 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC encoder-video-stop transcoder INFO 200 felder-forum {name: "160p"} - - - 2010593.429 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC encoder-audio-stop transcoder INFO 200 felder-forum {name: "160p"} - - - 2010593.429 - - - - - - - - - - - - - - - - - - - - - - - - -
    2014-06-18 01:46:46 UTC unpublish stream INFO 200 felder-forum_480p - - - - 2019.276 - - - - - - - - - - 62 0 225608545 0 felder-forum_480p - - - 0 0.0 /felder-forum_480p /felder-forum_480p - - -
    2014-06-18 01:46:46 UTC destroy stream INFO 200 felder-forum_480p - - - - 2019.277 - - - - - - - - - - 62 0 225608545 0 felder-forum_480p - - - 0 0.0 /felder-forum_480p /felder-forum_480p - - -
    2014-06-18 01:46:46 UTC disconnect session INFO 200 1601968006 - _defaultVHost_ livecf _definst_ 2019.608 [any] 1935 rtmp

  2. #2
    Join Date
    Sep 2011
    Posts
    1,931

    Default

    Hi,
    You can have hardware acceleration using EC2, please see the guide below.
    How to configure NVIDIA NVENC accelerated encoding on Amazon EC2 (G2, NVENC)

    How many inbound streams are you transcoding and how many renditions are being created?
    Ensure that the server is not overwhelmed and is able to transcode the streams you're sending.

    Check the logs for any "SKIP" messages, this indicates that the server is unable to perform the required transcoding tasks due to the hardware not being powerful enough.
    Example:
    comment    server    INFO    200    -    TranscodingSession.updateBehindFilter[live/_definst_:myStream]: Video behind filter state change. New state: SKIP1FRAME    
    comment    server    INFO    200    -    TranscodingSession.updateBehindFilter[live/_definst_:myStream]: Video behind filter state change. New state: SKIP2FRAME    
    comment    server    INFO    200    -    TranscodingSession.updateBehindFilter[live/_definst_:myStream]: Video behind filter state change. New state: ALLFRAMESON
    For an idea on how many transcodes you're able to get please see the benchmark article below.
    Wowza Transcoder AddOn Performance Benchmark

    If the issue persists and you're not getting the above skip messages, please open a ticket by emailing support@wowza.com.
    Please include a detailed description of the issue, a link to this thread for reference and a zipped copy of the following directories:
    [Wowza-Install]/conf/
    [Wowza-Install]/logs/
    [Wowza-Install]/transcoder/
    [Wowza-Install]/manager/logs/

    Please do make sure you provide logs which show Wowza server starting.

    If you are not sure how to get this information please see the following tutorial.
    http://www.wowza.com/forums/content....c-OS-and-Linux

    Regards,
    Jason
    Last edited by JasonH; 06-23-2014 at 05:05 AM.

Similar Threads

  1. Transcoder stops after approximately one hour
    By petabyte in forum Wowza Transcoder
    Replies: 4
    Last Post: 06-16-2014, 02:35 PM
  2. Stream stops unexpectedly after 1-2 mins
    By hussanchoudhry in forum General Forum
    Replies: 5
    Last Post: 05-14-2013, 09:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •