Results 1 to 4 of 4

Thread: Problems installing Wowza 4.0.4 on 64-bit Windows Server R2 - no services.

  1. #1
    Join Date
    Jan 2012
    Posts
    4

    Default Problems installing Wowza 4.0.4 on 64-bit Windows Server R2 - no services.

    After the installation finished I'm left with a fully installed Wowza 4.0.4 but with no services.

    startup.bat works perfectly with no errors in the log.
    startmgr.bat works perfectly.

    Running either InstallWowzaStreamingEngineManager-Service or InstallWowzaStreamingEngine-Service leaves me with

    "Administrator privileges are required to install Wowza Streaming Engine, Please retry with Administrator privileges."

    regardless whether the script is executed as Administrator, from CMD started as Administrator or just as the regular user accout (which happens to be an administrator).
    All that happens is that installbatch.txt gets a new entry of:

    "InstallWSE: start
    InstallWSE: no admin privileges.
    InstallWSE: end "

    I've tried both with and without UAC.

    I have tried re-installing.
    I have tried uninstalling, removing all files from C:\Program Files (x86)\, restart the server and running the installation again.
    I have verified java (jre7).

    Does anyone out there have any insight into what might be the problem?

  2. #2
    Join Date
    Jan 2012
    Posts
    4

    Default

    Alright, I've lost my patience.
    This is how I fixed it.

    The InstallWowzaStreamingEngineManager-Service.bat contains enough info on how to install the service for your specific OS. Especially this line:

    %_NSSM_EXE% install "%WowzaVersion%" "%_REALPATH%startup.bat" "service"

    By following the variables I figured out what I needed to make this work:

    nssm_x64.exe install "Wowza Streaming Engine 4.0.4" "C:\Program Files (x86)\Wowza Media Systems\Wowza Streaming Engine 4.0.4\bin\startup.bat" "service"

    Which I ran in CMD (as an administrator) from the .\bin directory which gave me a pleasant: "Service "Wowza Streaming Engine 4.0.4" installed successfully!"

    Same went for the manager.

    nssm_x64.exe install "Wowza Streaming Engine Manager 4.0.4" "C:\Program Files (x86)\Wowza Media Systems\Wowza Streaming Engine 4.0.4\manager\bin\startmgr.bat" "service"

    Then it was just a trip to the Services snap in, start the services and Bob's your uncle.

  3. #3
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    I'm glad you where able to resolve this problem.
    Thanks for the update.

    Ticket reference 128639.

    Regards,
    Jason

  4. #4
    Join Date
    Jul 2015
    Posts
    1

    Default Thank You!

    Thank YOU!

    Quote Originally Posted by addmeister View Post
    Alright, I've lost my patience.
    This is how I fixed it.

    The InstallWowzaStreamingEngineManager-Service.bat contains enough info on how to install the service for your specific OS. Especially this line:

    %_NSSM_EXE% install "%WowzaVersion%" "%_REALPATH%startup.bat" "service"

    By following the variables I figured out what I needed to make this work:

    nssm_x64.exe install "Wowza Streaming Engine 4.0.4" "C:\Program Files (x86)\Wowza Media Systems\Wowza Streaming Engine 4.0.4\bin\startup.bat" "service"

    Which I ran in CMD (as an administrator) from the .\bin directory which gave me a pleasant: "Service "Wowza Streaming Engine 4.0.4" installed successfully!"

    Same went for the manager.

    nssm_x64.exe install "Wowza Streaming Engine Manager 4.0.4" "C:\Program Files (x86)\Wowza Media Systems\Wowza Streaming Engine 4.0.4\manager\bin\startmgr.bat" "service"

    Then it was just a trip to the Services snap in, start the services and Bob's your uncle.

Similar Threads

  1. Services auto starts then stops on Windows 2012 Server
    By malimar in forum General Forum
    Replies: 4
    Last Post: 08-15-2013, 03:36 PM
  2. Wowza Media Server 3 and Windows Media services
    By yrrab5 in forum Server Administration Discussion
    Replies: 4
    Last Post: 12-15-2011, 02:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •