Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Restart Wowza

  1. #1

    Default Restart Wowza

    Hey Everyone!

    I am with a problem that when I restart the Wowza Server in Wowza Streaming Engine he doesn't work more. Acessing http://[wowza-ip]:1935 the server isn't found. Acessing Wowza Streaming Engine and trying to add stream the message is shown:
    "MediaCaster type not found[live/_definst_]: rtp"
    Can anyone tell me what can be? Would it be a bug?

    Because i saw in Release Note [] that this issue ["Fixed RTP MediaCaster thread locking issue with application instance shutdown"] was corrected.

    P.S: Wowza Streaming Engine version 4.0.4 in AMI (Amazon Machine Images) with license Byol.
    AMI ID: WowzaStreamingEngine-ebs-byol-4.0.4-x86_64-5f03c7f6-de9b-43fe-a602-1c49f77d1a02-ami-1e847d76.2 (ami-574ae54a)
    Last edited by guinoz; 07-18-2014 at 01:30 PM.

  2. #2


    Hello there,

    Are you sure you restarted the stream upon Wowza restart? How are you starting the stream? /conf/StartupStreams.xml or from Stream Manager?


  3. #3


    Hello Salvadore,

    Yes, i have. Indeed i restart the Wowza service in Wowza Streaming Engine Interface and it stopped to work. I start the stream by Stream Manager too. When i try to access http://[wowza-ip]:1935 informations like "Wowza Streaming Engine 4 Developer Edition 4.0.4 build[numbers_here]" are not displayed.
    Last edited by guinoz; 07-21-2014 at 05:36 AM.

  4. #4


    Lets see what the logs have to say, start Wowza in stand alone mode, [install-dir]/bin/startup.bat( on Mac)

    This will display the logs in the console. Do you see any start up errors in the logs?


  5. #5


    INFO server comment - MediaCache[MediaCache]: Started
    INFO server comment - REST API: ready
    Error starting: java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.wowza.wms.bootstrap.Bootstrap.startServer(
    at com.wowza.wms.bootstrap.Bootstrap.main(
    Caused by: java.lang.UnsupportedClassVersionError: com/ipset/wms/httpprovider/StreamingRequest : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at Source)
    at Source)
    at$100(Unknown Source)
    at$ Source)
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at com.wowza.wms.util.VHostUtils.loadHTTPProvider(
    at com.wowza.wms.util.VHostUtils.loadHostPort(
    at com.wowza.wms.util.VHostUtils.loadHostPortList(
    at com.wowza.wms.util.VHostUtils.loadConfigFile(
    at com.wowza.wms.vhost.VHost.c(
    at com.wowza.wms.vhost.VHost.init(
    at com.wowza.wms.vhost.VHostSingleton.init(
    at com.wowza.wms.server.Server.startVHost(
    at com.wowza.wms.server.Server.startVHosts(
    at com.wowza.wms.server.Server.start(
    ... 6 more

    i see that the error happened in HTTPProvider created by me. But i create in a development environment with the same Wowza version. What would be a "Unsupported major.minor version 52.0"? Java version?

  6. #6


    In your run or debug configuration in eclipse, try adding the following to the VM Arguments on the Arguments tab.

  7. #7


    So Salvadore for to develop the HTTProvider i set this variable before. I saw in another thread here in the Forum.

  8. #8


    Be sure your JAVA_HOME environment variable is pointing at the the correct version of Java. Try opening a DOS prompt and enter:

    %JAVA_HOME%/bin/java -version

    See what that returns. If incorrect version then update the JAVA_HOME environment variable to point to the correct location.
    After installing latest Java version, java command is still using old Java (fix)

    I hope this helps.


  9. #9


    To update, it looks like the error you are getting suggests that you are running a newer version of java on the dev server then you are running on the production server.
    You should use the same version (or older version) on the dev machine that is running on the production machine.


  10. #10


    In fact the problem was the java version. Wowza in the production server has java 1.7.0_55 while in development environment was 1.8.0. Thus I downloaded the jre e jdk for 1.7.0_55 version and build again the project. That's worked.

    Thank you very much for your help Salvadore.

    Best Regards,


Page 1 of 2 12 LastLast

Similar Threads

  1. Wowza restart during nDVR operation
    By cnfcnf in forum AddOn: Wowza nDVR
    Replies: 1
    Last Post: 12-12-2011, 07:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts