Results 1 to 6 of 6

Thread: URL of MPEG-TS re-streaming, must end with ".stream" ?

  1. #1

    Default URL of MPEG-TS re-streaming, must end with ".stream" ?

    When using Wowza to re-stream incoming MPEG-TS to outgoing RTMP,
    Is there a way to set an access URL for clients which does not end with ".stream" ?

    StreamPublisher module which I know is one solution, cannot be used for reasons explained later.


    *In detail
    I have an existing Wowza system feeding live source from FMLE via RTMP.
    The source encoder is soon to be replaced with one using MPEG-TS (UDP).

    As this stream is currently fed to a good number of clients with the access URL hard-coded on their side, I would like to keep the access URL unchanged.
    However, following tutorials on how to re-stream MPEG-TS, I only know of how to set access URLs ending with ".stream".


    I know this can be overcome using the StreamPublisher module. However, it is already used to handle scheduling of other streams on the same Wowza application, which when reloading the schedule (.smil) file, causes a break in all managed streams.
    This is probably easy if the stream not requiring scheduling can be run on a separate Wowza application, but unfortunately that cannot be done.

    Thank you.

  2. #2
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    To change the name of a specific stream, you can use the StreamNameAlias AddOn.
    Please see How to get the StreamNameAlias AddOn and follow the instructions which are included in the download.

    Another option would be to use Push Publishing which is now built-in to Wowza Streaming Engine 4.
    How to push streams to CDNs and other services (Push Publishing)

    Regards,
    Jason
    Last edited by JasonH; 09-12-2014 at 02:30 AM.

  3. #3

    Default

    Hi Jason,

    I am now trying the suggested Stream Name Alias module.

    I see in the description,
    "Note: When this alias package is configured for a given application it will replace the built-in alias system that is implemented using .play and .stream files."
    This perhaps explains why, with my older .stream files, "Incoming streams" show a "Bytes In" reading of zero after installing the module.

    Would you please show example of what setting goes in which config file?
    I am trying to make,
    an MPEG-TS stream incoming at udp://0.0.0.0:10000,
    accessible to clients at rtmp://mydomain:1935/live/mystream.

    Thank you.
    Last edited by DavidS; 09-15-2014 at 10:04 PM.

  4. #4
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    Sorry, you can't alias an alias, which is why you can't use the StreamNameAlias for .stream files.

    The easier option would be to use the Push Publishing functionality to publish the stream you're receiving (MPEGTS.stream) to the same, or another application for your client to view.
    Push Publishing allows you to choose the name of the stream you're publishing so this could be called "myStream" if configured in the [Wowza-Install]/conf/PushPublishMap.txt file.

    In the [Wowza-Install]/conf/PushPublishMap.txt file you would have:
    MPEGTS.stream={profile:"rtmp", streamName:"myStream", host:"localhost", application:"live", userName:"myuser", password:"mypassword"}
    Please see the Push Publishing guide for configuration details.

    Regards,
    Jason

  5. #5

    Default

    Thank you Jason,
    Now everything is working as expected.
    What a beauty

  6. #6
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    That's great news, thanks for the update.

    Regards,
    Jason

Similar Threads

  1. "Buffering" appears at end of VOD movie
    By RonSTL in forum Video On Demand Streaming Discussion
    Replies: 3
    Last Post: 11-30-2012, 02:58 PM
  2. "Buffering" shown instead of end when a live show has ended
    By db_2011 in forum AddOn: Wowza nDVR
    Replies: 4
    Last Post: 11-04-2011, 03:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •