Results 1 to 4 of 4

Thread: Missing values in log fields in stats log

  1. #1
    Join Date
    Nov 2010
    Posts
    21

    Default Missing values in log fields in stats log

    Hi guys,

    I notice that some of the fields(x-severity, x-category, x-event) is missing from the stats log(wowzamediaserver_stats.log).

    x-app    x-severity    x-category    x-event    date    time    c-client-id    c-ip    c-port    cs-bytes    sc-bytes    x-duration    x-sname    x-stream-id    x-spos    sc-stream-bytes    cs-stream-bytes    x-file-size    x-file-length    x-ctx    x-comment
    420317720    INFO    rtsp    connect    9/17/2014    9:49:48    853364606    192.168.12.108    -    0    0    26.38    -    -    -    -    -    -    -    853364606    -
    420317720    INFO    stream    create    9/17/2014    9:49:48    853364606    192.168.12.108    -    0    0    0.025    420317720/small.mp4    1    0    0    0    -    -    -    -
    420317720    INFO    rtsp    describe    9/17/2014    9:49:48    853364606    192.168.12.108    -    0    0    0.205    420317720/small.mp4    -    0    -    -    26469936    596.544    853364606    -
    420317720    INFO    stream    play    9/17/2014    9:49:48    853364606    192.168.12.108    -    0    0    0.134    420317720/small.mp4    1    0    0    0    26469936    596.544    420317720/small.mp4    -
    420317720    INFO    rtsp    play    9/17/2014    9:49:48    853364606    192.168.12.108    -    0    0    0.241    420317720/small.mp4    -    0    -    -    26469936    596.544    853364606    -
    420317720    -    -    -    9/17/2014    9:50:07    853364606    192.168.12.108    -    0    817893    18.786    420317720/small.mp4    1    18458    817893    0    0    596.544    -    -
    420317720    -    -    -    9/17/2014    9:50:07    853364606    192.168.12.108    -    0    817893    18.863    420317720/small.mp4    1    18458    817893    0    0    596.544    -    -
    420317720    INFO    rtsp    disconnect    9/17/2014    9:50:07    853364606    192.168.12.108    -    0    0    18.971    -    -    -    -    -    -    -    853364606    -
    Then I blindly try to disable the INFO logging in our custom module, then the logging is fine. That's weird, it's like the logging in the custom module has somehow messed up with Wowza's logging.

    Here's how i defined the logger in the custom module:
    public static final WMSLogger logger = WMSLoggerFactory.getLogger(HTTPRandomAccessReader.class);
    Here's the original logging in the module:
        if (logger.isInfoEnabled())
    	logger.info("HTTPRandomAccessReader.init: status:" + this.status + " length:" +
    		this.length + " lastModified:" + this.lastModified);
    Any idea? Appreciate for any insight, thanks!

  2. #2

    Default

    Hi,

    In your logger statement you do not specify the category or the event, so see the API there are multiple .info definitions so you are using

    getLogger().info(comment)

    but you could use

    getLogger().info(comment, category, event)

    Example your logger line would change from

        if (logger.isInfoEnabled())
    	logger.info("HTTPRandomAccessReader.init: status:" + this.status + " length:" +
    		this.length + " lastModified:" + this.lastModified);
    to

        if (logger.isInfoEnabled())
    	logger.info("HTTPRandomAccessReader.init: status:" + this.status + " length:" +
    		this.length + " lastModified:" + this.lastModified,WMSLoggerIDs.CAT_application, WMSLoggerIDs.EVT_comment);
    Andrew.

  3. #3
    Join Date
    Nov 2010
    Posts
    21

    Default

    Ah Andrew, thanks! I will give this a try later on Let's see if this will work

  4. #4
    Join Date
    Nov 2010
    Posts
    21

    Default

    Unfortunately that does not work as well =(

    We have a custom module, and some simple INFO logging in, I don't understd why is it affects only RTSP streams... frustrated.

    I tried removing all the logging in our custom module, then the problem would be gone. But why? I don't want to remove the logging as they would be helpful during runtime. Please shed some light? Thanks!

Similar Threads

  1. Adding a custom log file and custom log fields.
    By arkroan in forum Server Administration Discussion
    Replies: 17
    Last Post: 01-28-2014, 05:59 AM
  2. Replies: 1
    Last Post: 09-24-2012, 03:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •