Results 1 to 4 of 4

Thread: How to run Wowza service to start / stop from non-root account?

  1. #1
    Join Date
    Feb 2014
    Posts
    11

    Default How to run Wowza service to start / stop from non-root account?

    Hi.

    I want to Wowza service to start / stop from non-root account to a security problem.

    The OS is Ubuntu 12.04 version.

    How to run Wowza Streaming Engine as a Named User (Linux and OS X)

    I've also found this part, if you run a service as non-root account

    / var / run / WowzaStreamingEngine ': Permission denied The only message occurs.

    Is there Wowza service can be controlled by a non-root account?

    Thanks.

  2. #2
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    Please see this article, How to run Wowza Media Server as non-root user on port 80.
    Hope this is what you're looking for.

    Regards,
    Jason

  3. #3
    Join Date
    Feb 2014
    Posts
    11

    Default

    Thanks for your answer.

    But after using this method to get off the 'service WowzaStreaming Engine start' command in the non-root account appears as follows and does not work.


    WowzaStreamingEngine stopped

    WowzaStreamingEngine: starting ...
    touch: can not touch `/ var / run / WowzaStreamingEngine ': Permission denied

    Please help me to know the way to start / stop the Wowza service under non-root account.
    Last edited by oxidecircle; 10-30-2014 at 12:26 AM.

  4. #4
    Join Date
    Feb 2014
    Posts
    11

    Default There are additional questions.

    I want to start / stop as Wowza service mode in non-root account.

    While applying both methods below, was denied permission in non-root account.

    http://www.wowza.com/forums/content....ux-and-OS-X%29

    http://www.wowza.com/forums/content....ser-on-port-80

    If WowzaStreamingEngine service mode to start and stop is impossible at non-root account,

    Can you explain why is impossible?

    Wait for answer.

    Thanks.
    Last edited by oxidecircle; 10-30-2014 at 08:14 PM.

Similar Threads

  1. Setting up Wowza to run as service (manually)
    By awax256 in forum General Forum
    Replies: 1
    Last Post: 09-10-2013, 09:56 PM
  2. Replies: 1
    Last Post: 11-15-2012, 04:20 PM
  3. WMS custom module doesn't work when run as a Windows service
    By Sunsight in forum Server-side Modules and Code Samples Discussion
    Replies: 1
    Last Post: 11-23-2011, 09:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •