Results 1 to 5 of 5

Thread: Audio problem on iOS and Windowphone device

  1. #1
    Join Date
    Jan 2015
    Posts
    8

    Default Audio problem on iOS and Windowphone device

    Dear Wowza-Team,

    I am transcoding a live MPEG-TS stream (Video: H264, main profile; Audio: mp2, 48kHz, stereo) into the profile:
    live.tv.stream {name:"360p", bitrate:512000, codec:H264, profile:Baseline, level:3.0, frameSize:640x360, displaySize:640x360, frameRate:25.0}
    live.tv.stream {name:"360p", bitrate:96000, codec:AAC, objectType:LC, sampleRate:48000, channels:2}

    The output stream is played well on Android device (both rtsp and http Cupertino streaming), but the audio is distorted (every about ten seconds i hear some "u u u.." sound over the original sound) when playing the stream on iOS (iPhone 3GS, 5), it also happens when i play on Test Player with Smooth streaming and a Windowphone device (Nokia Lumia 525).

    I found a susgestion in this article http://www.wowza.com/forums/showthre...storted-on-iOS, but this problem still happens.
    When i try to transcode the input stream following this article http://www.wowza.com/forums/content....rver-(MPEG-TS) (my vlc transcode params: #transcode{venc=x264{keyint=60,profile=baseline,level=3.0,nocabac},vcodec=x264,vb=512k,height=360,wi dth=640,acodec=mp4a,ab=96,channels=2,samplerate=48000}) and use Passthrough, i did not have this problem.

    Any ideal for my problem?

    Best Regards,
    Huy.

  2. #2
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    Are you using a trial or a developer license?
    Running with either of those licenses puts audio watermark tones in the stream every few seconds. Is that what you are hearing, or something else?
    What live encoder are you using to provide the source stream?

    Daren

  3. #3
    Join Date
    Jan 2015
    Posts
    8

    Default

    Hi Daren,

    Yes, i'm using a developer license. I hope that my problem is what you are talking about and I'm going to try a Transcoder AddOn Premium License soon.
    But if as you said, why i did not hear that sound on Android device?
    My source stream is provided by MPEG2 TV Encoder from television station.

    Thanks for your support,
    Huy.

  4. #4
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    With a Dev license you should certainly get the watermark tones if listening to a transcoded audio stream.
    It doesn't make sense that you wouldn't hear the tones on an Android device, unless you were listening
    to the source stream or passed-thru audio, but then I'm not sure if mp2 audio will stream/play on Android.

    Daren

  5. #5
    Join Date
    Jan 2015
    Posts
    8

    Default

    Hi,
    I'm sorry, after listening carefully the transcoded stream, i also hear that tones.
    And the mp2 audio can be played on Android.

    Thanks,
    Huy.

Similar Threads

  1. Replies: 1
    Last Post: 02-21-2014, 07:43 AM
  2. Textchat on Ios device
    By ripleyXLR8 in forum Server-side Modules and Code Samples Discussion
    Replies: 4
    Last Post: 02-07-2014, 02:52 PM
  3. Audio problem for 3GPP device
    By Jason Ng in forum General Forum
    Replies: 0
    Last Post: 01-09-2013, 01:20 AM
  4. Having problem with setting up caption for iOS device
    By gotofbi in forum Closed Captioning
    Replies: 1
    Last Post: 11-15-2012, 12:54 AM
  5. H.264/Speex To iOS Encoding Problem - No Audio
    By ImAStreamer in forum AddOn: Transcoder
    Replies: 1
    Last Post: 08-16-2012, 02:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •