Results 1 to 2 of 2

Thread: re stream cutting out

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default re stream cutting out

    Hi all,

    I am currently running a few ip cams to wowza over a 3g connection and then serving it to my web page through cloudfront. I keep getting the same problem where a stream will stop being sent out from wowza to the client. In the engine manager it is still showing as bytes coming in but none going out, the video is definitely fine because I am recording it and none of the videos are missing chunks.
    The strange thing is that when I use the test player on wowza manager it plays fine and then afterwards it starts sending data again. I don't know why the requests from the page and AWS are not making wowza provide the video but running the test player does. It only has this problem now and then and it does it randomly with each stream

    These are the errors I am getting in my Error and Access log when it is happening

    Error log

    WARN server comment 2015-03-03 10:32:42 - - - - - 7230892.968 - - - - - - - - HTTPStreamerAdapterCupertinoStreamer.onPlaylist: Stream not found [livehttp/cam2@g22.stream/chunklist.m3u8]: cam2@g22.stream
    WARN server comment 2015-03-03 10:32:44 - - - - - 7230894.165 - - - - - - - - HTTPStreamerAdapterCupertinoStreamer.onPlaylist: Stream not found [livehttp/cam2@g22.stream/chunklist.m3u8]: cam2@g22.stream
    WARN server comment 2015-03-03 10:32:57 - - - - - 7230911.761 - - - - - - - - RTPSessionDescriptionDataProviderBasic.getStreamInfo: RTSP/RTP re-streaming timeout.
    WARN server comment 2015-03-03 10:32:58 - - - - - 7230913.176 - - - - - - - - RTPSessionDescriptionDataProviderBasic.getStreamInfo: RTSP/RTP re-streaming timeout.
    WARN server comment 2015-03-03 10:33:12 - - - - - 7230927.121 - - - - - - - - RTPSessionDescriptionDataProviderBasic.getStreamInfo: RTSP/RTP re-streaming timeout.
    WARN server comment 2015-03-03 10:33:25 - - - - - 7230940.123 - - - - - - - - LiveStreamPacketizerSmoothStreaming.handlePacket[livehttp/_definst_/cam2@g51.stream]: Fragment duration greater than suggested range of 1-4 seconds. Adjust keyframe interval accordingly: Fragment durations: [4.8,4.0,4.9]
    I am now getting this from my error log
    WARN	server	comment	2015-03-03	13:17:54	-	-	-	-	-	7240804.203	-	-	-	-	-	-	-	-	HTTPStreamerAdapterCupertinoStreamer.onPlaylist: Stream not found [livehttp/cam2@g22.stream/playlist.m3u8]: cam2@g22.stream
    Access Log

    2015-03-03 10:37:29 HKT destroy stream INFO 200 cam2@g22.stream - _defaultVHost_ livehttp _definst_ 54.42 my_address.com 1935 http://my_address.com:1935/livehttp/cam2@g22.stream/playlist.m3u8 54.239.218.12 http (cupertino) - Amazon CloudFront 1569531339 0 753 40988 0 0 0 cam2@g22.stream - - - - - http://my_address.com:1935/livehttp/cam2@g22.stream/playlist.m3u8 http://my_address.com:1935/livehttp/cam2@g22.stream/playlist.m3u8 - http://my_address.com:1935/livehttp/cam2@g22.stream/playlist.m3u8 -
    2015-03-03 10:37:29 HKT disconnect cupertino INFO 200 1569531339 - _defaultVHost_ livehttp _definst_ 7231179.289 my_address.com 1935 http://my_address.com:1935/livehttp/cam2@g22.stream/playlist.m3u8 54.239.218.12 http (cupertino) - Amazon CloudFront 1569531339 0 75 - 0 - - cam2@g22.stream - - - - - http://my_address.com:1935/livehttp/cam2@g22.stream/playlist.m3u8 http://my_address.com:1935/livehttp/cam2@g22.stream/playlist.m3u8 - http://my_address.com:1935/livehttp/cam2@g22.stream/playlist.m3u8 -
    2015-03-03 10:38:03 HKT connect cupertino INFO 200 1569531339 - _defaultVHost_ livehttp _definst_ 7231213.431 my_address.com 1935 http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 54.239.218.12 http (cupertino) - Amazon CloudFront 1569531339 0 0 - 0 - - cam2@g22.stream - - - - - http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 - http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 -
    2015-03-03 10:38:03 HKT create stream INFO 200 cam2@g22.stream - _defaultVHost_ livehttp _definst_ 0.0 my_address.com 1935 http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 54.239.218.12 http (cupertino) - Amazon CloudFront 1569531339 0 0 40989 0 0 0 cam2@g22.stream - - - - - http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 - http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 -
    2015-03-03 10:38:42 HKT play stream INFO 200 cam2@g22.stream - _defaultVHost_ livehttp _definst_ 39.676 my_address.com 1935 http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 54.239.218.12 http (cupertino) - Amazon CloudFront 1569531339 0 10432 40989 1425350301250 0 0 cam2@g22.stream - - - - - http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 - http://my_address.com:1935/livehttp/cam2@g22.stream/chunklist.m3u8 -
    2015-03-03 10:38:50 HKT comment server INFO 200 - HTTPStreamerSessions.httpOriginIdToSessionId[_defaultVHost_:livehttp/_definst_/myStream[sanjosestreaming]:1462636087]: create - - - 7231260.486 - - - - - - - - - - - - - - - - - - - - - - - - -
    2015-03-03 10:38:58 HKT comment server INFO 200 - HTTPStreamerSessions.removeHTTPOriginSession[_defaultVHost_:livehttp/_definst_/myStream[sanjosestreaming]:1462636087]: remove - - - 7231268.96 - - - - - - - - - - - - - - - - - - - - - - - - -
    2015-03-03 10:39:08 HKT comment server INFO 200 - HTTPStreamerSessions.removeHTTPOriginSession[_defaultVHost_:livehttp/_definst_/myStream[sanjosestreaming]:1462636087]: remove - - - 7231278.48 - - - - - - - - - - - - - - - - - - - - - - - - -

    Thanks for any help

    Simon
    Last edited by Simon245; 03-02-2015 at 10:53 PM.

Similar Threads

  1. Stream cutting off
    By krissy in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 3
    Last Post: 11-11-2013, 11:27 AM
  2. Stream cutting in and out
    By krissy in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 2
    Last Post: 02-20-2013, 02:26 PM
  3. Wowza cutting off the stream?
    By coskel22 in forum Live Streaming and Encoder Discussion
    Replies: 8
    Last Post: 12-23-2012, 04:27 PM
  4. RTSP + Android + Wowza.v3 = Keeps Cutting Out After 90 sec
    By astudios in forum Media Players and Devices Discussion
    Replies: 28
    Last Post: 04-04-2012, 02:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •