Results 1 to 7 of 7

Thread: HLS Streaming when ports 1935 and 80 are closed

  1. #1

    Default HLS Streaming when ports 1935 and 80 are closed

    Hi there,

    I'm doing a live stream into a large bank, and there's to be 40,000 connections.

    For the purpose of streaming, I'm using wirecast with my output as rtmp


    stream is myStream

    (as usual)

    I am using an outside network to stream out. I am also using the transcoder add-on with ABR using 4 diff bitrates. The video is served up using jwplayer

    Everything looks good on the naked network I use. But when trying to view the livestream on the bank's network, I get the following:

    "Cannot load M3U8:crossdomain access denied"

    Is this a fault of jwplayer, or the wowza settings?

    Here is the actual page -

    Thanks to anyone who can help?

  2. #2


    To add to this thread, I've been able to stream into this workplace, with jwplayer serving up a single RTMP streaming.

    At that time, I had to use rtmp tunnelling to get into the bank's network

    The main problem I am having - how do I get HLS streaming to work in a place where ports 1935 and 80 are closed?



  3. #3


    This is what I am able to find about open ports at this location's network

    RTMP Port 1935 - yes
    RTMP Port 80 - no
    RTMP Port 443 - yes

    RTMPT (all ports) - yes

    It seems that I cannot get HLS streaming into this network. I wonder if there are some other ports I could try?

  4. #4


    Going a bit further, it seems the bank's network is blocking the HLS stream coming from Amazon EC2

    For example - the HLS stream "" is just plain blocked

    The error message when trying to directly open that stream on the bank network is

    "The Website you are attempting to access does not yet have a security classification. Access is temporarily restricted."

    I am going to guess there really is nothing I can do now, except get the bank to lift their security restrictions?

  5. #5


    I did a real bizarre workaround, which worked.

    I am using Wowza on EC2. For a long time, I was using Wowza Streaming Engine 4: Standard, paying $15/month and instance charges.

    I have since upgraded to Wowza Streaming Egine 4: Bring Your Own Licence - paying $65/month and instance charges

    I have been using the quick start AMI's provided by BYOL and adding my licence key, and doing it this way, I was never able to get through the bank's network.

    BUT, when I used one of the quick start AMI's provided by Streaming Engine 4: Standard, and adding my licence, I was able to get through the bank network.

    I realize they are different AMI's, but for this case, both had the exact same security settings attached to them.

    Streaming Engine 4 - AMI (this one worked)
    WowzaStreamingEngine-ebs-paid-standard-4.1.1-x86_64-433fbc8b-6e76-489b-8027-12fea483fb99-ami-74ec881c.2 (ami-1683e37e)
    Description: WowzaStreamingEngine-ebs-paid-standard-4.1.1-x86_64
    Security Group: Wowza Streaming Engine 4- Standard-4-1-1-AutogenByAWSMP-

    Streaming Engine 4 - (BYOL) AMI - (this did not work)
    WowzaStreamingEngine-ebs-byol-4.1.2-x86_64-5f03c7f6-de9b-43fe-a602-1c49f77d1a02-ami-806656e8.2 (ami-da437cb2)
    Description: WowzaStreamingEngine-ebs-byol-4.1.2-x86_64

    Security Group: Wowza Streaming Engine 4- Bring Your Own License-4-1-2-AutogenByAWSMP-

    For some reason, that was the difference. The Streaming Engine 4: Standard AMI had the proper security keys built in to bypass the bank's network, whereas the BYOL ami did not.

    I was able to add my licence to the Standard AMI and enable the transcoder.

    I wonder if there is something different between the two AMI settings that did this?

  6. #6
    Join Date
    Jun 2011


    There really shouldn't be such a difference in the AMIs.
    The only real requirements are:
    1) Enabling the streaming port 80 under Server->Vhost Setup->Host Ports
    2) Enabling TCP port 80 in your EC2 Security Group.


  7. #7
    Join Date
    Jun 2011


    This is now being handled in ticket #131213.


Similar Threads

  1. Different ports for streaming
    By baurzhan in forum General Forum
    Replies: 1
    Last Post: 07-30-2014, 12:32 PM
  2. Multiple addresses and ports in a .stream file
    By staubina in forum Live Streaming and Encoder Discussion
    Replies: 3
    Last Post: 05-30-2012, 12:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts