Results 1 to 5 of 5

Thread: Wowza crashed when start to transcode everytime

  1. #1

    Question Wowza crashed when start to transcode everytime

    Hello,

    I got a crash when started to transcode, the log as follows:

    iptv@CIKDECODESVR-TOR11:~/wowza/bin$ sudo ./startup.sh
    Configure logging: file:///usr/local/WowzaStreamingEngine/conf/log4j.properties
    INFO server server-start Wowza Streaming Engine 4 Monthly Edition 4.1.2 build13947 -
    INFO server comment - Server License Key: ENGM4-XXXXX-XXXXX-XXXXX-XXXXX-AvQBP
    INFO server comment - Maximum Connections: Unlimited
    INFO server comment - Maximum Incoming Streams: Unlimited
    INFO server comment - Transcoder Streams Available: Unlimited
    INFO server comment - Transcoder Watermark: No
    INFO server comment - nDVR Available: Yes
    INFO server comment - DRM Available: Yes
    INFO server comment - HTTP Origin Available: Yes
    INFO server comment - Push Publish Available: Yes
    INFO server comment - REST API Available: No
    INFO server comment - Hardware Available Processors: 8
    INFO server comment - Hardware Physical Memory: 9495MB/11807MB
    INFO server comment - Hardware Swap Space: 12075MB/12075MB
    INFO server comment - Max File Descriptor Count: 20000
    INFO server comment - Open File Descriptor Count: 64
    INFO server comment - OS Name: Linux
    INFO server comment - OS Version: 3.14.5-custom
    INFO server comment - OS Architecture: amd64
    INFO server comment - Java Name: Java HotSpot(TM) 64-Bit Server VM
    INFO server comment - Java Vendor: Oracle Corporation
    INFO server comment - Java Version: 1.8.0_45
    INFO server comment - Java VM Version: 25.45-b02
    INFO server comment - Java Spec Version: 1.8
    INFO server comment - Java Home: /usr/local/jdk/jre
    INFO server comment - Java Max Heap Size: 3933MB
    INFO server comment - Java Architecture: 64
    INFO server comment - Java Locale[user.language]: en
    INFO server comment - Java Locale[user.country]: CA
    INFO server comment - Java Locale[file.encoding]: UTF-8
    INFO server comment - Java Timezone[user.timezone]: America/Toronto
    INFO server comment - Java Args[0]: -Xmx4000M
    INFO server comment - Java Args[1]: -XX:+UseConcMarkSweepGC
    INFO server comment - Java Args[2]: -XX:+UseParNewGC
    INFO server comment - Java Args[3]: -XX:NewSize=256m
    INFO server comment - Java Args[4]: -Djava.net.preferIPv4Stack=true
    INFO server comment - Java Args[5]: -Dcom.sun.management.jmxremote=true
    INFO server comment - Java Args[6]: -Dcom.wowza.wms.runmode=standalone
    INFO server comment - Java Args[7]: -Dcom.wowza.wms.native.base=linux
    INFO server comment - Java Args[8]: -Dcom.wowza.wms.AppHome=/usr/local/WowzaStreamingEngine
    INFO server comment - Java Args[9]: -Dcom.wowza.wms.ConfigURL=
    INFO server comment - Java Args[10]: -Dcom.wowza.wms.ConfigHome=/usr/local/WowzaStreamingEngine
    INFO server comment - Server runmode: standalone
    INFO server comment - Server native.platform: linux
    INFO server comment - Server threads[h/t]: 480/320
    INFO server comment - RESTServer: Bind attempt ([any]:8087)
    INFO server comment - RESTServer: Bind successful ([any]:8087)
    INFO server comment - Wowza REST API started
    INFO server comment - RESTServer: Using configs from:/usr/local/WowzaStreamingEngine/
    INFO server comment - RESTServer: SSL:No
    INFO server comment - RESTServer: BasicAuth:No
    INFO server comment - RESTServer: Digest:Yes
    INFO server comment - RESTServer: XML Viewer:No
    INFO server comment - REST Documentation Server has been disabled.
    INFO server comment - CMDInterface now listening: [any]:8083
    INFO server comment - MediaCache[MediaCache]: Thread pool size: [writer/readahead]:16/8
    INFO server comment - MediaCache[MediaCache]: MAX Pending size: [writer/readahead]:500M/25M
    INFO server comment - MediaCache[MediaCache]: Add store: path:/usr/local/WowzaStreamingEngine/mediacache maxSize:10737418240
    INFO server comment - MediaCache[MediaCache]: Add source[dvrorigin]: prefix:dvrorigin/ basePath:http://
    INFO server comment - MediaCache[MediaCache]: Flushing cache: start
    INFO server comment - MediaCache[MediaCache]: Flushing cache: done
    INFO server comment - MediaCache[MediaCache]: Start MediaCache GC
    INFO server comment - MediaCache[MediaCache]: Started
    INFO server comment - REST API: ready
    INFO vhost vhost-start _defaultVHost_ -
    INFO server comment - _defaultVHost_ threads[h/t]:0/0 home:/usr/local/WowzaStreamingEngine
    INFO vhost comment _defaultVHost_ Bind attempt ([any]:1935:16)
    INFO vhost comment _defaultVHost_ Bind successful ([any]:1935)
    INFO vhost comment _defaultVHost_ Bind attempt ([any]:8086:4)
    INFO vhost comment _defaultVHost_ Bind successful ([any]:8086)
    INFO server comment - Server.startShutdownHook: Start server shutdown hook
    INFO server comment - StatsManager:startManager() Enabled=true
    INFO server comment - Wowza Streaming Engine is started!
    - - - - -
    INFO server comment - REST API: Restart Application: Application (live) shutdown
    INFO server comment - MediaCasterStreamValidator.init[live/_definst_]: Started
    INFO server comment - ModuleCoreSecurity.onAppStart[live/_definst_]: Publish: AllowedEncoders: securityPublishValidEncoders:Wirecast/|FME/|FMLE/|Wowza GoCoder*
    INFO server comment - ModuleCoreSecurity.onAppStart[live/_definst_]: Publish: block duplicate stream names : false
    INFO server comment - ModuleCoreSecurity.onAppStart[live/_definst_]: Publish: RTMP Authorization: password file:/usr/local/WowzaStreamingEngine/conf/publish.password
    INFO server comment - ModuleCoreSecurity.onAppStart[live/_definst_]: Play: SecureConnection: securityPlayRequireSecureConnection:false
    INFO server comment - ModuleCoreSecurity.onAppStart[live/_definst_]: Play: securitySecureTokenVersion property is missing, using SecureToken Version 1, play security enabled for RTMP only
    INFO application app-start _definst_ live/_definst_
    INFO server comment - RTPMediaCaster.create[243282559]
    INFO server comment - RTPMediaCaster.init[243282559]
    INFO server comment - RTPMediaCaster.Reconnector[243282559:live/_definst_:live11.stream]: start: 1
    INFO server comment - REST API: Stream File connected: live11.stream
    INFO server comment - RTPSessionDescriptionDataProviderBasic.getStreamInfo[live/_definst_]: URI: udp://235.1.1.11:267
    INFO stream create - -
    INFO server comment - RTPDePacketizerMPEGTS.init: Drop incomplete video frames
    INFO stream publish live11.stream -
    INFO server comment - MulticastTransport.bind[live/_definst_]: 235.1.1.11/267
    INFO server comment - RTPMediaCaster.Reconnector[243282559:live/_definst_:live11.stream]: done: 1
    INFO server comment - MulticastTransport.firstPacket: 235.1.1.11/267
    INFO server comment - [live/_definst_/live11.stream]: handleTransportStreamBlock: new MPTS.
    INFO server comment - [live/_definst_/live11.stream]: MPEG2PATAssembler:MonitorStart
    INFO server comment - [live/_definst_/live11.stream]: MPEG2MPTS:StartStream: PID: 0x0
    INFO server comment - [live/_definst_/live11.stream]: Received PAT
    INFO server comment - [live/_definst_/live11.stream]: PAT Version 2
    INFO server comment - [live/_definst_/live11.stream]: Program: 1 PMT PID: 0x1e0
    INFO server comment - [live/_definst_/live11.stream]: MPEG2PMTAssembler:MonitorStart: PID: 480 Program Number: 1
    INFO server comment - [live/_definst_/live11.stream]: MPEG2MPTS:StartStream: PID: 0x1e0
    INFO server comment - MediaCasterStreamValidator.addMonitor[live/_definst_/live11.stream]
    INFO server comment - [live/_definst_/live11.stream]: Received new PMT
    INFO server comment - [live/_definst_/live11.stream]: PMT: Version 2 PCR pid: 0x1e1
    INFO server comment - [live/_definst_/live11.stream]: Stream: Type: 0x02 PID: 0x1e1 Video
    INFO server comment - [live/_definst_/live11.stream]: Descriptor (131) : (1)
    INFO server comment - [live/_definst_/live11.stream]: Stream: Type: 0x81 PID: 0x1e2 Audio
    INFO server comment - [live/_definst_/live11.stream]: LanguageDescriptor (10) : Languages: eng Encoding: 0
    INFO server comment - [live/_definst_/live11.stream]: Stream: Type: 0x81 PID: 0x1e3 Audio
    INFO server comment - [live/_definst_/live11.stream]: LanguageDescriptor (10) : Languages: enm Encoding: 0
    INFO server comment - [live/_definst_/live11.stream]: RTPDePacketizerMPEGTS.pmtAvailable: IMPORT: videoPID[prg:0xffffffff,pid:0x1e1,filter:none]: streamType:MPEG2:2
    INFO server comment - [live/_definst_/live11.stream]: MPEG2MPTS:StartStream: PID: 0x1e1
    INFO server comment - [live/_definst_/live11.stream]: RTPDePacketizerMPEGTS.pmtAvailable: IMPORT: audioPID[prg:0x1,pid:0x1e2,filter:none]: streamType:AC3:129 audioLanguage:eng
    INFO server comment - [live/_definst_/live11.stream]: MPEG2MPTS:StartStream: PID: 0x1e2
    INFO server comment - [live/_definst_/live11.stream]: Received first video TS Packet
    INFO server comment - [live/_definst_/live11.stream]: Received first audio TS Packet
    INFO server comment - TranscoderSessionNative.loadLibrary: Load transcoder list file: /usr/local/WowzaStreamingEngine/lib-native/linux64/transcoder.list
    Java HotSpot(TM) 64-Bit Server VM warning: You have loaded library /usr/local/WowzaStreamingEngine-4.1.2/lib-native/linux64/libmc_bc_dec_avc.so which might have disabled stack guard. The VM will try to fix the stack guard now.
    It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
    INFO server comment - LiveStreamTranscoder.init[live/_definst_/live11.stream]: Load transcoder template: file:///usr/local/WowzaStreamingEngine/transcoder/templates/transcode.xml
    libva info: VA-API version 0.34.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
    libva info: Found init function __vaDriverInit_0_32
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    # SIGSEGV (0xb) at pc=0x00007fd266006783, pid=4947, tid=140541794977536
    #
    # JRE version: Java(TM) SE Runtime Environment (8.0_45-b14) (build 1.8.0_45-b14)
    # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.45-b02 mixed mode linux-amd64 compressed oops)
    # Problematic frame:
    # C [iHD_drv_video.so+0x11a783] __vaDriverInit_0_31(VADriverContext*)+0x2b9
    #
    # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
    #
    # An error report file with more information is saved as:
    # /usr/local/WowzaStreamingEngine-4.1.2/bin/hs_err_pid4947.log

    #
    # If you would like to submit a bug report, please visit:
    # http://bugreport.java.com/bugreport/crash.jsp
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    #
    ./startup.sh: line 51: 4947 Aborted (core dumped) $_EXECJAVA $WMSTUNE_OPTS $JMXOPTIONS -Dcom.wowza.wms.runmode="$mode" -Dcom.wowza.wms.native.base="linux" -Dcom.wowza.wms.AppHome="$WMSAPP_HOME" -Dcom.wowza.wms.ConfigURL="$WMSCONFIG_URL" -Dcom.wowza.wms.ConfigHome="$WMSCONFIG_HOME" -cp $WMSAPP_HOME/bin/wms-bootstrap.jar com.wowza.wms.bootstrap.Bootstrap start

    I hava tried "It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'." and "ulimit -c unlimited", it doesn't work for me.anything i can do.

    Thanks!
    Last edited by Leo Zheng; 06-25-2015 at 02:22 AM.

  2. #2

    Default

    Hi.

    You might try:
    execstack -c /usr/local/WowzaStreamingEngine-4.1.2/lib-native/linux64/libmc_bc_dec_avc.so
    Regards,

    Salvadore

  3. #3

    Default

    Hi.

    thanks for you kindness!
    i have figure it out with reinstall the intel-media driver, though i still confused!

  4. #4
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    If this was a new or updated installation then it's possible the libraries being used required more up-to-date Intel Media drivers
    to support the QuickSync accelerated transcoding.

    Daren

  5. #5

    Default

    Hi, thanks for the reply!

    I'm using the Intel Media drivers as mentioned in the QuickSync Configure Guide, "wget http://www.wowza.com/downloads/WowzaTranscoder-4-Components/intel-quicksync-linux/intel-linux-media_sles_16.3.1.18283_64bit.tar.gz".
    is there any update on the Intel Media Drivers?

Similar Threads

  1. Transcoding crashed server unexpectedly
    By myboynoy in forum AddOn: Transcoder
    Replies: 3
    Last Post: 09-12-2014, 03:56 PM
  2. Who should transcode ? Encoder or Wowza ?
    By azrilnazli in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 08-16-2012, 06:49 AM
  3. Replies: 2
    Last Post: 08-09-2012, 09:55 AM
  4. Replies: 1
    Last Post: 01-31-2012, 08:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •