Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: error when try to play H264 VOD content

  1. #1
    Join Date
    Mar 2015
    Posts
    10

    Default error when try to play H264 VOD content

    Hi,

    when try to play H264 content i get the following error:
    MediaReaderH264.open[vod/dt]: Not found: /usr/local/WowzaStreamingEngine/content/BBB_Main_10s_deu_20_12000k-HEVC-4K.mp4.mp4.: java.io.FileNotFoundException: /usr/local/WowzaStreamingEngine/content/BBB_Main_10s_deu_20_12000k-HEVC-4K.mp4.mp4 (No such file or directory)|at java.io.RandomAccessFile.open(Native Method)|at java.io.RandomAccessFile.(RandomAccessFile.java:243)|at com.wowza.io.WowzaRandomAccessFile.(WowzaRandomAccessFile.java:12)|at com.wowza.io.DirectRandomAccessReader.open(DirectRandomAccessReader.java:236)|at com.wowza.wms.mediareader.h264.MediaReaderH264.open(MediaReaderH264.java:252)|

    other files are played well

    please advice

    thanks

    Yariv

  2. #2

    Default

    Hello.

    Please check the playback URL for typos. It looks like you have .mp4.mp4 as the extension:
    BBB_Main_10s_deu_20_12000k-HEVC-4K.mp4.mp4
    Regards,

    Salvadore

  3. #3
    Join Date
    Mar 2015
    Posts
    10

    Default

    you right,

    that was after to many tries and was mistake

    the problem now is when i try to play i "get Playback failed null" with no specific reason - i have checked the content with VLC and he played well

    from the logs i can see that the system is not looking at folder dt

    from the logs : MediaReaderH264.open[vod/dt]: Not found: /usr/local/WowzaStreamingEngine/content/BBB_Main_10s_deu_20_16000k-HEVC-4K.mp4.: java.io.FileNotFoundException: /usr/local/WowzaStreamingEngine/content/BBB_Main_10s_deu_20_16000k-HEVC-4K.mp4 (No such file or directory)|at java.io.RandomAccessFile.open(Native Method)|at java.io.RandomAccessFile.(RandomAccessFile.java:243)|at com.wowza.io.WowzaRandomAccessFile.(WowzaRandomAccessFile.java:12)|at com.wowza.io.DirectRandomAccessReader.open(DirectRandomAccessReader.java:236)|at com.wowza.wms.mediareader.h264.MediaReaderH264.open(MediaReaderH264.java:252)|


    files on the Linux:
    /usr/local/WowzaStreamingEngine-4.2.0/content/dt
    [root@localhost dt]# ls
    BBB_10s_deu_51_0k.mpa BBB_Main_10s-HEVC-4K.mpd BBB_Main_10s-HEVC-4K.mpd.old BBB_Main_10s_deu_20_12000k-HEVC-4K.mp4 BBB_Main_10s_deu_20_16000k-HEVC-4K.mp4 BBB_Main_10s_deu_20_8000k-HEVC-4K.mp4 bbb2.mp4 sample.mp4
    [root@localhost dt]#



    thanks

    Yariv
    Last edited by yarlevi; 07-22-2015 at 01:15 AM.

  4. #4

    Default

    If you are trying to access files in a sub folder of the /content folder, for example /content/dt/your-file.mp4 toy will need to include _definst_ in the playback URL.

    For example:
    [protocol]://[ip-address]:1935/vod/_definst_/mp4:[sub-folder-name]/mp4:[some-file].mp4
    Regards,

    Salvadore

  5. #5
    Join Date
    Mar 2015
    Posts
    10

    Default

    Hi Salvadore,

    thank you for the help,

    i was doing this in the past without using _definst_ , but anyway its still not working with that as well, still not going to subdirectory from reason, http://10.56.194.240:1935/vod/_defin...4/manifest.f4m

    so now i recognize 2 issues
    1. when requesting the file from subdirectory under content its not working,
    2. the H.265 file is not playing even when its coming directly from content folder (bbb sample file is working well)

    thank you for the support

    Yariv

  6. #6
    Join Date
    Mar 2015
    Posts
    10

    Default

    what i see in the log that he used MediaReaderH264 and not H265

    MediaReaderH264.open[vod/_definst_]: Not found: /usr/local/WowzaStreamingEngine/content/dt/mp4:BBB_Main_10s_deu_20_12000k-HEVC-4K.mp4.: java.io.FileNotFoundException: /usr/local/WowzaStreamingEngine/content/dt/mp4_BBB_Main_10s_deu_20_12000k-HEVC-4K.mp4 (No such file or directory)|at java.io.RandomAccessFile.open(Native Method)|at java.io.RandomAccessFile.(RandomAccessFile.java:243)|at com.wowza.io.WowzaRandomAccessFile.(WowzaRandomAccessFile.java:12)|at com.wowza.io.DirectRandomAccessReader.open(DirectRandomAccessReader.java:236)|at com.wowza.wms.mediareader.h264.MediaReaderH264.open(MediaReaderH264.java:252)|

    what do you think?

  7. #7
    Join Date
    Mar 2015
    Posts
    10

    Default

    Quote Originally Posted by yarlevi View Post
    what i see in the log that he used MediaReaderH264 and not H265

    MediaReaderH264.open[vod/_definst_]: Not found: /usr/local/WowzaStreamingEngine/content/dt/mp4:BBB_Main_10s_deu_20_12000k-HEVC-4K.mp4.: java.io.FileNotFoundException: /usr/local/WowzaStreamingEngine/content/dt/mp4_BBB_Main_10s_deu_20_12000k-HEVC-4K.mp4 (No such file or directory)|at java.io.RandomAccessFile.open(Native Method)|at java.io.RandomAccessFile.(RandomAccessFile.java:243)|at com.wowza.io.WowzaRandomAccessFile.(WowzaRandomAccessFile.java:12)|at com.wowza.io.DirectRandomAccessReader.open(DirectRandomAccessReader.java:236)|at com.wowza.wms.mediareader.h264.MediaReaderH264.open(MediaReaderH264.java:252)|

    what do you think?
    so , this is the right syntax that its working with subfolder http://10.56.194.240:1935/vod/mp4:vo...4/manifest.f4m but still H265 content is not playing

    Yariv

  8. #8

    Default

    Support for h.265 was added to Wowza 4.1.0 but only as a preview.

    Assuming you are running Wowza 4.1.0 or higher, you can transcode an incoming h.265 stream as well as record the live stream for VOD playback. The playback options are also limited and in preview still.

    You can read about this in the Wowza 4.1.0 release notes

    Regards,

    Salvadore

  9. #9
    Join Date
    Mar 2015
    Posts
    10

    Default

    Quote Originally Posted by salvadore View Post
    Support for h.265 was added to Wowza 4.1.0 but only as a preview.

    Assuming you are running Wowza 4.1.0 or higher, you can transcode an incoming h.265 stream as well as record the live stream for VOD playback. The playback options are also limited and in preview still.

    You can read about this in the Wowza 4.1.0 release notes

    Regards,

    Salvadore
    thank you,
    i'm using the latest version and my MP4 is already H265 content and i'm suppose to stream it (i'm now getting manifest with the correct path) but cant play, maybe there is spacial config that i need to add?

    thanks

    Yariv

  10. #10

    Default

    According to the Wowza 4.1.0 release notes. The following support for H.265 was added:
    Added support for HEVC/H.265 stream ingestion and playback over MPEG-TS (preview)
    Added support for HEVC/H.265 stream ingestion and playback over RTP (preview)
    There is nothing notable about this in the Wowza 4.2.0 release notes to suggest anything has changed at this point.

    I can only figure that since HDS is not mentioned that it is not supported at this time.

    For further questions, you might consider opening a support ticket by emailing support@wowza.com

    They may be able to provide more detailed information for you in this regard.

    Salvadore

Page 1 of 2 12 LastLast

Similar Threads

  1. h264 to lower bitrate h264
    By djsashaz in forum Live Streaming and Encoder Discussion
    Replies: 5
    Last Post: 05-04-2013, 04:13 AM
  2. H264/g711 to h264/aac transcode
    By zinniazing in forum AddOn: Transcoder
    Replies: 2
    Last Post: 05-04-2012, 12:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •