Results 1 to 2 of 2

Thread: ABR Transcoding issue

  1. #1
    Join Date
    Oct 2015

    Default ABR Transcoding issue

    I have ABR streams setup successfully for one application but struggling on another.

    The one that works is a live streaming from FMLE and all runs as expected. full stream transcoded stream
    On the incoming streams page on streaming manager it shows the transcoder streams as separate lines.

    The application with issues is a different setup, re-streaming RTSP streams coming from a collection of IP cameras.
    With the source stream address located inside file.

    First question, what would the correct URL be once things are working ok.
    Or something different?

    Would it need an mp4: beforehand or not?
    Seen docs stating both with and without, the working stream was migrated from streaming server v3 so not sure if that affected the config.

    Next, are there any special steps to get transcoding setup when restreaming an existing stream or is there any reason why its not working?
    Transcoding is enabled for this application.
    Application is set to use transcoding template based on stream name (doesn't exist) or a generic template (does exist)
    Generic template for application appears error free and has several profiles (including 360p as tests above) enabled.
    No extra streams appear in the incoming streams section as they do for other live application.

  2. #2



    The URL should look like the following if using a .stream file to initiate the connection to the camera.
    You will notice the transcoder encode rendition name "_360p" is appended to the end of the stream name and the mp4: file type designation is not needed with a Live Stream.

    In the Wowza Streaming Engine Manager, under the Selected Application / Transcoder section, you may want to check your "Fallback Template" settings. It could be set to none, in which case unless the stream name matches a template name (if checked), transcoding would be skipped. This section should also show as Status Enabled.

    If the transcoder is enabled and actively transcoding your stream, you should see it under the Selected Application / Incoming Streams section. Here you can click on the stream rendition name and if you use the "Test Players..." it should auto-load the settings for the rendition into the player. Clicking the "Mobile" tab will give you the iOS URL syntax.

    Best regards,

Similar Threads

  1. Livestream playback issue with android when transcoding !!
    By shahzaibcb in forum AddOn: Transcoder
    Replies: 5
    Last Post: 12-11-2013, 07:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts