Results 1 to 2 of 2

Thread: Eclipse debug fails - server.xml not found

  1. #1
    Join Date
    Apr 2014

    Default Eclipse debug fails - server.xml not found

    Trying to debug a module in Eclipse using the Wowza IDE generated debug config, but receiving "ERROR: Server.xml not found: exiting." From other posts, usual cause is access permissions, i.e. running eclipse with elevated privilege (root on Linux, or as Administrator on Windows).

    On Windows 8.1, using Eclipse Mars (4.5.1), installed the Wowza IDE 4 extension from the Eclipse repo, generated a boiler-plate module with stubs, compiled cleanly, verified .jar file present in the Wowza lib directory, configured the module for an application in the Wowza admin. Have run Eclipse as Administrator, and as normal (un-privileged) user. Result is the same. Have attempted to alter the debug configuration, changing the working directory from the workspace default to specific directories (Wowza base, bin, and lib dirs). Result is the same.

    Are there any arguments that can be passed to the bootstrap class besides "start" to specify the location of the server.xml (and other config files)?

    Have set up same arrangement on Linux (openSuSE), with same result.

    Removed the Wowza IDE 4 extensions, and replaced with the Wowza IDE 2 extensions, spun up a new boiler-plate project. Have found two debug config items (Java VM arguments) present in IDE 2 that were not in IDE 4 debug config:

    -Dcom.wowza.wms.AppHome="C:/Program Files (x86)/Wowza Media Systems/Wowza Streaming Engine 4.3.0"
    -Dcom.wowza.wms.ConfigHome="C:/Program Files (x86)/Wowza Media Systems/Wowza Streaming Engine 4.3.0"

    Added these debug configuration items to original workspace/project, and can now start Wowza from the Eclipse debugger.
    Last edited by fredwoolard; 11-02-2015 at 09:22 AM. Reason: resolved

  2. #2


    Thank you for the update and the steps to resolve this issue.



Similar Threads

  1. Linux Wowza-Eclipse Debug Setup
    By dexadexa in forum Wowza Streaming Server Java API
    Replies: 1
    Last Post: 07-24-2015, 04:53 AM
  2. Unable to install Wowza Eclipse Software Update plugin in Eclipse
    By runenes in forum Wowza Streaming Server Java API
    Replies: 9
    Last Post: 07-25-2014, 06:23 AM
  3. Replies: 3
    Last Post: 02-21-2014, 04:48 PM
  4. Replies: 2
    Last Post: 03-01-2012, 11:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts