Results 1 to 4 of 4

Thread: AV sync issues duing wowza transcoder load testing

  1. #1
    Join Date
    Jan 2016

    Default AV sync issues duing wowza transcoder load testing

    I am trying to perform a load test of wowza transcoder. Below are the details of my setup.

    1. Host used : AWS EC2 C4.8x large instance
    2. WowzaStreaming engine version : 4.3.0 build16025
    3. Transcoder(transrate) settings:
    1920x1080(Pass through) 2Mbps
    1280x720 1.3Mbps
    640x360 850Kbps
    360x240 350Kbps

    4. Wowza application-‘live-http’ is configured with MPEG-DASH and Apple HLS as playback types.
    5. I am using ffmeg to generate rtsp interleaved stream as an input to wowza. I am using the default sample.mp4 as input file which is provided by wowza streaming engine.
    6. Here is the command I am using
    ffmpeg.exe -re -i sample.mp4 -vcodec libx264 -vb 500000 -g 60 -vprofile main -acodec aac -ab 128000 -ar 48000 -ac 2 -strict experimental -f rtsp -rtsp_transport tcp rtsp://<wowza-ip>/live-http/demo/

    7. I am playing the output HLS stream using HLS.js player.
    8. When I provide more than 3 input rtsp stream to wowza streaming engine, I see AV sync issues, video is not smooth in some of the streams when played through HLS.js player.
    9. Until 3 input streams, the output streams generated by wowza play fine without any issues.
    10. Also when I provided 5 input streams to wowza, all the system metrics such as cpu(~50%), memory(4GB), heap(~1GB), network and disk are all well within the limits.
    11. I also looked at the load numbers published by you guys . Since I am just performing transrating and not transcoding, Wowza on a C4.8x large should be supporting upto 8 sessions without any issues.
    12. But my tests indicate that I can only support upto 3 sessions. Can you please let me know what I might be doing wrong and how I could increase the capacity of my wowza server?
    13. Also When I ran just the pass through mode(with transcoder disabled) I could support upto 80 sessions without any issues.

    Thanks for your time.

  2. #2
    Join Date
    Sep 2011


    Thank you for this detailed information, this is very helpful. When using the transcoder in Wowza Streaming Engine the source stream should always be the highest bitrate and resolution stream as scaling up is not going to produce a good quality encode and requires the transcoder will require significantly more resources to try and create the encodes. Due to this, I recommend that you use a different source (encoded at 1920x1080 2Mbps or higher) if you're wanting to keep the above mentioned encodes during a load test, or change the encodes to be of a lower quality (bitrate and resolution) than the source you're transcoding.

    If you're still having issues after changing the source or encodes, I recommend that you open a ticket with our support team.
    When creating a ticket for our Support team, please provide a ZIP file containing the following directories for analysis:

    Please make sure you provide logs which show Wowza server starting.

    If you are not sure how to get this information please see the following tutorial.
    How to create a compressed zip file in Windows, OS X, and Linux

    Note that you can also try adding a sort-buffer to the application or sort-buffer to the transcoder if you're sources are having A/V sync issues.

    Last edited by JasonH; 01-08-2016 at 09:05 AM.

  3. #3
    Join Date
    Jan 2016


    Thank you for the repsonse. As you recommended I am using a source with 1920x1080, 30 fps and 2Mbps bit rate and increased the buffers. I still see the same issue. I have also filed a ticket with wowza support.

    I am getting the following errors even when i run just 3 sessions

    CupertinoPacketHandler.handlePacket[live-http/_definst_/demo5]: Timecode out of order [video]: 35110542:35110547
    If i run 5 or more session. I get these errors along with the timecode errors

    TranscodingSession.updateBehindFilter[live-http/_definst_/demo4]: Video behind filter state change. New state: SKIP1FRAME
    TranscodingSession.updateBehindFilter[live-http/_definst_/demo4]: Video behind filter state change. New state: ALLFRAMESON
    CupertinoPacketHandler.handlePacket[live-http/_definst_/demo5]: Timecode out of order [video]: 35110542:35110547

    I did some digging and threads in the forum suggests that wowza instance is being overworked. But i see that the CPU utilization is around 60% on c4.8x large instance for 6 sessions and 30% for 3 sessions.
    Does this mean i cannot run even 3 sessions on the wowza(c4.8xL with transcoder enabled)? Is there any config which i need to change prevent this error from happening? Thank you.

    Last edited by rmuniraju; 01-08-2016 at 06:31 PM.

  4. #4
    Join Date
    Jun 2011


    This is being handled in support ticket #153867


Similar Threads

  1. Wowza Streaming out of sync.. VLC in sync
    By WebDev4Life in forum Media Players and Devices Discussion
    Replies: 4
    Last Post: 07-25-2013, 06:40 PM
  2. Wowza Load Testing Tool
    By cussons in forum General Forum
    Replies: 4
    Last Post: 03-21-2012, 07:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts