Results 1 to 5 of 5

Thread: REST api GET request IP blocked

  1. #1

    Default REST api GET request IP blocked

    I'm trying to make a GET request at this URL : http://192.168.0.101:8087/v2/servers..._/applications to list the existing applications. The server gives the following ERROR message : "ERROR server comment - REST API: Server request (GET): IP WhiteList blocked (192.168.0.101)-403: http://192.168.0.101:8087/v2/servers/_defaultServer_/vhosts/_defaultVHost_/applications".
    My Server.xml file content is:
    "<?xml version="1.0" encoding="UTF-8"?>
    <Root version="2">
    <Server>
    <Name>Wowza Streaming Engine</Name>
    <Description>Wowza Streaming Engine is robust, customizable, and scalable server software that powers reliable streaming of high-quality video and audio to any device, anywhere.</Description>
    <RESTInterface>
    <Enable>true</Enable>
    <IPAddress>*</IPAddress>
    <Port>8087</Port>
    <!-- none, basic, digest-->
    <AuthenticationMethod>none</AuthenticationMethod>
    <DiagnosticURLEnable>true</DiagnosticURLEnable>
    <SSLConfig>
    <Enable>false</Enable>
    <KeyStorePath></KeyStorePath>
    <KeyStorePassword></KeyStorePassword>
    <KeyStoreType>JKS</KeyStoreType>
    <SSLProtocol>TLS</SSLProtocol>
    <Algorithm>SunX509</Algorithm>
    <CipherSuites></CipherSuites>
    <Protocols></Protocols>
    </SSLConfig>
    <IPWhitelist>192.168.0.101</IPWhitelist>
    <IPBlackList></IPBlackList>
    <EnableXMLFile>false</EnableXMLFile>
    <DocumentationServerEnable>true</DocumentationServerEnable>
    <DocumentationServerPort>8089</DocumentationServerPort>
    <!-- none, basic, digest-->
    <DocumentationServerAuthenticationMethod>none</DocumentationServerAuthenticationMethod>
    <Properties>
    <Property>
    <Name>restUserHTTPHeaders</Name>
    <Value>Access-Control-Allow-Origin:*|Access-Control-Allow-Methods:OPTIONS,GET,PUT,DELETE,POST|Access-Control-Allow-Headers:Content-Type</Value>
    </Property>
    </Properties>
    </RESTInterface>
    <CommandInterface>
    <HostPort>
    <ProcessorCount>${com.wowza.wms.TuningAuto}</ProcessorCount>
    <IpAddress>*</IpAddress>
    <Port>8083</Port>
    </HostPort>
    </CommandInterface>
    <AdminInterface>
    <!-- Objects exposed through JMX interface: Server, VHost, VHostItem, Application, ApplicationInstance, MediaCaster, Module, Client, MediaStream, SharedObject, Acceptor, IdleWorker -->
    <ObjectList>Server,VHost,VHostItem,Application,ApplicationInstance,MediaCaster,Module,IdleWorker</ObjectList>
    </AdminInterface>
    <Stats>
    <Enable>true</Enable>
    </Stats>
    <!-- JMXUrl: service:jmx:rmi://localhost:8084/jndi/rmi://localhost:8085/jmxrmi -->
    <JMXRemoteConfiguration>
    <Enable>false</Enable>
    <IpAddress>localhost</IpAddress> <!-- set to localhost or internal ip address if behind NAT -->
    <RMIServerHostName>localhost</RMIServerHostName> <!-- set to external ip address or domain name if behind NAT -->
    <RMIConnectionPort>8084</RMIConnectionPort>
    <RMIRegistryPort>8085</RMIRegistryPort>
    <Authenticate>true</Authenticate>
    <PasswordFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.password</PasswordFile>
    <AccessFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.access</AccessFile>
    <SSLSecure>false</SSLSecure>
    </JMXRemoteConfiguration>
    <UserAgents>Shockwave Flash|CFNetwork|MacNetwork/1.0 (Macintosh)</UserAgents>
    <Streams>
    <DefaultStreamPrefix>mp4</DefaultStreamPrefix>
    </Streams>
    <ServerListeners>
    <ServerListener>
    <BaseClass>com.wowza.wms.mediacache.impl.MediaCacheServerListener</BaseClass>
    </ServerListener>
    <!--
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.loadbalancer.ServerListenerLoadBalancerListener</BaseClass>
    </ServerListener>
    -->
    <!--
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.loadbalancer.ServerListenerLoadBalancerSender</BaseClass>
    </ServerListener>
    -->
    </ServerListeners>
    <VHostListeners>
    <!--
    <VHostListener>
    <BaseClass></BaseClass>
    </VHostListener>
    -->
    </VHostListeners>
    <HandlerThreadPool>
    <PoolSize>${com.wowza.wms.TuningAuto}</PoolSize>
    </HandlerThreadPool>
    <TransportThreadPool>
    <PoolSize>${com.wowza.wms.TuningAuto}</PoolSize>
    </TransportThreadPool>
    <RTP>
    <DatagramStartingPort>6970</DatagramStartingPort>
    <DatagramPortSharing>false</DatagramPortSharing>
    </RTP>
    <Manager>
    <!-- Properties defined are used by the Manager -->
    <Properties>
    </Properties>
    </Manager>
    <Transcoder>
    <PluginPaths>
    <QuickSync></QuickSync>
    </PluginPaths>
    </Transcoder>
    <!-- Properties defined here will be added to the IServer.getProperties() collection -->
    <Properties>
    </Properties>
    </Server>
    </Root>"

    I've also tried <IPWhitelist>*</IPWhitelist> and <IPWhitelist>127.0.0.1,192.168.0.101</IPWhitelist>
    Any advice is welcome.

  2. #2

    Default

    Solved: i was using my IP instead of localhost in the index.html file.

  3. #3

    Default

    Thanks for the update and glad to hear you got this sorted.

    Regards,

    Salvadore

  4. #4
    Join Date
    Apr 2016
    Posts
    2

    Default

    I have same issue, could you tell me how to fix it?
    Thank you.

  5. #5

    Default

    Hello,

    Can you check that you are using your localhost in the index.html file instead of using your IP address?

    Regards
    Jason Hatchett

Similar Threads

  1. REST API Get Stream files
    By imthehell in forum Wowza Streaming Engine REST API
    Replies: 1
    Last Post: 02-02-2016, 01:11 AM
  2. Replies: 1
    Last Post: 01-08-2016, 09:57 AM
  3. Get monthly network status use REST API
    By hanwook in forum Wowza Streaming Engine REST API
    Replies: 3
    Last Post: 11-03-2015, 07:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •