Wowza Community

64k bitrate EXT-X-TARGETDURATION value in HLS m3u8

Hi, I’m using Wowza Engine with AWS s3 storage.

I’ve implemented an adaptive bit-rate streaming.(12M, 6M, 3M, 64k)

I checked each index files in the m3u8 file.

Each value of EXT-X-TARGETDURATION was 10 but only 64k was 176.

Since that issue, when the bandwidth of internet was not good and after changing to 64k bit-rate streaming, the streaming bit-rate couldn’t be changed.

Is there any way for setting EXT-X-TARGETDURATION forcedly as 10 seconds even a bit-rate is 64k?


Hello there.

This may be an issue with your keyframe interval and fps settings from the encoder. Chunks must start on a keyframe, so it’s best to use a keyframe interval that’s a factor of the cupertinoChunkDurationTarget setting. For example, if cupertinoChunkDurationTarget is set to 10 seconds, use a keyframe interval of either 2, 2.5, 5, or 10 seconds.

You might try smaller cupertinoChunkDurationTarget. Set the encoder keyframe interval to 30 with fps at 15 (2 second keyframe interval). Then you can set cupertinoChunkDurationTarget as low as 2000, each chunk will be 2 seconds, which 1/5 the size of your 10 second chunks. That should be more manageable for low bandwidth clients.

I hope this helps.

Kind regards,