Wowza Community

Android 4.4 - Nexus - Not playing

Hi guys

I’m at a bit of a loss here, i hope that you can provide me with an answer or at least some insight. I have been running my trial edition of Wowza for 14 days now and with good results. Every IOS and android device has been playing what i wanted it to play. The other day though i updated one of our test devices from 4.3 (jelly bean) to Android 4.4 (kit kat) and suddenly it can’t play anything provided by wowza. I checked and rechecked my settings but to no avail. Finally i went to your website and tried playing the demos you have there, just to get a peace of mind. But to my astonishment the only thing i can get working is the “Direct URL to sample file”.

what’s gone wrong?



Looking at the Android Developer page for KitKat

There have been significant changes, if you look under the “New media capabilities” section.

There are mentions updates to HLS supported version, now supporting version 4. This may be significant.

What browsers did you try? Just Chrome, or other. I heard that 4.4 does not ship with a browser, but rather this is up to

the vendors to add browser when shipping devices?

What is the device (manufacture/model) you are using?

Does the RTSP link still work on this mobile page?


I am having no problems viewing HLS, or RTSP content on my Google Nexus 5 running 4.4 (Stock)

I’ve tried with both Chrome and Firefox, and I’m prompted to pick a media player as you would expect (i.e. open once vs always) - and content playback starts up.

Do you have logcat installed or anything? Not sure you’d get much useful out of it, but it may be worth a shot.

Either that, or, install the ADT bundle,, turn on dev tools on your phone and check it out and see if you get any useful debug when trying to start a stream on your phone.

EDIT - Well - I hooked this up to my IDE and tracing logcat at debug; make sure in the logcat filter settings, you’re not filtering on whatever module you throw in debug, i.e. “All Messages”. I’d imagine there are some specific filters we’d want to set up to try and track this down easily. I just don’t have time to look at it today!

HLS support in 4.4 seems to be good; I’m just doing some switching of playback based on useragent and minor/major device version - working well.


This is something that we are going to try and test.

Please open a ticket, by sending an email to

and reference this thread URL and attach zips of your conf and logs folders

(if too large then share and link to the files instead). Make sure the logs

are from dates/times when you have accessed the server with the 4.4 device.

We will post our findings back to this thread for the community.


There is actually such a link here on the Wowza mobile test page

The video/audio stream that the link provides is encoded such that it plays on a wide range of hardware and Android OS versions.



It is best to start with the Baseline profile, as Google themselves recommend here.

This profile is more likely to be device agnostic.

We haven’t run into the same problems described here in this thread while using our Nexus 7 updated to Android 4.4.


Android 4.4 doesn’t do rtsp playback from web browser anymore, you need to build an app for rtsp playback, else it will show as a broken link.

i am trying to work to find a work around for that when done i will post the solution.



rtsp playback is working on Android 4.4.2 using nexus 4 phone, i have did the implementation using href


Hi Daren

Thanks for returning my question.

It’s the google model on some kind of Asus hardware , latest generation. It ships with Chrome, but i have also tried Dolphin but to no avail

The link in question opens a window and you have to choose a player. The only player i have found that it is working with is VLC. The one it ships with from the factory does not work nor does VPlayer. Needless to say that i would hate to explain to some of my Android users that they have to download VLC in order to see my content.

Hi Guys there is a known problem with Android 4.4 see here . I’m seeing a massive difference between 4.4 and (4.3 & below) for live streaming - it appears to be a codec issue. I’m currently playing around with the server settings to see if I can find what specifically kills it.

I’m using H264 (baseline, 3.0) video with AAC audio. Video works fine on desktop through flash, and through HLS/HTML5 on iOS devices. It either doesn’t play, or sometimes gives audio-only through HLS/HTML5 on a Nexus 7 updated to 4.4.2 (Chrome, Boat, Dolphin, and Skyfire browsers tested).

We were working fine before the update on browsers that support HLS, and streaming RTSP to others. Now on 4.4.2 we’re dead in the water.

Of course it’s always after posting somewhere that I find a workaround…

Our chunk sizes were set to one second (cupertinoChunkDurationTarget=1000), with video encoding pushing one keyframe per second. I altered the Wowza config to two second chunk sizes (cupertinoChunkDurationTarget=2000), guaranteeing each chunk will have a keyframe, even in the case of minor timing errors. I’ve now got streams working on Android 4.4.2 devices (though, with lag about 5 seconds behind the iOS player).

Thanks - I also just tested your work around and got it working on Nexus 5 phone on Android 4.4.2