Wowza Community

Android can't play RTSP stream


I’m having a rough time re-streaming radio stream to my android devices for our project. The project’s goal is to re-stream/stream pre-encoded files and live streams to mobile devices (iOS/Android).

My Configuration:

VHost.xml -> added port 554

Application.xml -> and change RTPTransportMode to udp

Streammanager -> mediacaster to shoutcast

stream file content -> (mp3 stream produced and transcoded by vlc)

I’m able to play the stream produced by wowza to my iOS device (safari) and vlc (desktop) but with no luck with my android devices.

Here are the streams that’s up and running:

for iOS ->

for VLC (Playing) and Android (Not playing) -> rtsp:// or rtsp:// base from this artice

I really need my android devices to be able to play the stream.


Your Wowza didn’t appear to be running when I tried. What’s the output of vlc/ffmpeg?

Test RTSP streaming to Android with the sample.mp4 file to eliminate problems with your setup. If that works, ensure your encoding is compatible with Android.

I tried this in a browser:

You should see Wowza version and build displayed in the browser, but there is no response. Either Wowza is not running, or TCP port 1935 is blocked by a firewall, or that port is not properly mapped to your Woowza server in your network, you may need to port forward 1935 in your router.


I tried, but was not able to reach your server either, using the following from a browser:

Android streaming playback through rtsp requires UDP ports be open from your server to the client(s)

Are you able to play any video at all from your Wowza server to your Android devices?

When your server is running again, the following should work from Android if your udp ports are open:


Thanks for the quick response.

Hi Randall and Richard,

The server is down during the time you have tested the streams. The server is now up and running and you can test the streams.

PS: kindly disregard the stream without the port due to rollback of configurations.