Wowza Community

audio problem of rtmp with h.264 and mp3

I send a ts(h.264 and mp3) stream to wowza server then use live streaming to publish it.

I can use flash player to see the video,but there is no audio.i tried to use vlc to receive the rtsp stream from the same wowza server(i set the wowza server to provide rtsp and rtmp at the same time) and the audio is fine.Dose this mean that flash player doesn’t support mp3 as audio for rtmp?or i messed up some settings?

PS:I tried on both jwplayer and the demo player which is in wowza example/live folder


What does VLC say that the codec is for the stream?

You can get this by playing the stream then using “Tools > Codec Information” in the top bar.


Take a look at this VLC article and examples:

If you are transoding you might as well use AAC audio.


Probably the file is not encoded as MPEG-1 layer 3 (MP3).

That’s correct.

This is the codec info from vlc


MPEG Audio layer 1/2/3(mpga)


H264 - MPEG-4 AVC(part 10)(h264)

So h.264+mp3 should be no problem for flash player?

I am using vlc for transcode,so maybe it’s a problem with vlc audio encoder()?

I have problem with AAC encoder of vlc (version 2.0.2):<

But I can use some earlier version,so I guess I’d better to use AAC audio.

Thanks for your reply