Wowza Community

Clean install of 4.8.5 following WebRTC example and SimpleWebServer issue


I’m sure this must be something simple and probably staring me in the face…however I have a clean install of Streaming Engine 4.8.5 and trying to get the WebRTC examples working, by following this

However when I goto the link https://[my-streamlock-id] rather than opening the file, all browsers I’ve tried, download the html file??

Similarly if it try to goto https://[my-streamlock-id] it tries to download an empty webrtc file

I’ve had this working on my previous install of WSE 4.8, but since trying the upgrade it just want to download the files. (I’ve tried on 2 separate installs now and same result??)

Could you point me in the right direction?

The Vhost.xml/HostPort is exactly as written in the article

Many thanks


Sorry that’s happening. Can you send us a support ticket so the engineers can look more closely and see what happened? They don’t debug in the forums since they need full access to your files for testing. You can zip up your files and logs here and submit. Thanks…