Wowza Community

Configure an RTP jitter buffer and packet loss logging (RTP/MPEG-TS over RTP)

Great! Glad it’s working. Thanks for the update.

I suggest you keep the “provider=rtmp”. Sometimes it is actually optional, and other times it is necessary.


It should work. Try it. Use the private IPs instead.


No, it is not support.


will the blackbery support the multibitrate with smil file?


But client side it is flash-client I am asking for. can we do it ?

And on server side, I think jitter buffering is only for audio buffering, can it buffer video ?

  1. In which file this value can be set?

2)Is there any way to restrict the no of client connection to the Wowza server?

I mean the no of connections(for eg allow only 500 connections at a time)

  1. Is thre any way to view the client connections?

4)I need to record a live video from a particular point to another point (not the whole video). How to do that ?

1)I have used this Livestreamrecord package. And when accessing it i can get those options (start recording, stop recording). And i pressed the “start recording” and after some time stoped it by “stop recording”. But where this file saved ? I coudnt find it?

2)I think the above method is for clients(it can be used on server side also). Is there any other method that we can do on demand storage on the server side

Let me explain the process. First of all we will add those jar file to server(insalllocation/lib).

Then add the module in Application.xml. And suppose that we are hosting that page(I mean that “livestreamrecord.html” ) on our web server. And suppose that a remote client is accessing that page on its browser.

At that time he would have an option to start & stop record. …For this reason I think that this is for clients. …In this case where this file is saved?

  1. And u told that on the server side if we are recording it (by the start record & stop record options) a new video file is saved on the “install-location/content” directory. I have checked that location. But there is no such file created or saved. What is the problem.?

  2. My third question is Do we have any option to store some portion of video on the Wowza server (uploaded from a client(for example FMLE) ) using jconsole or any other way.


All ur information was very much helpful to me…

Thank u…

Jaseer TK

Software Engineer/System Administrator

Spark Support


thank u…

  1. Ok i will check my configuration. My configuration taken from quickstart.html->How to publish and play a live stream (RTMP or RSTP/RTP based encoder). The stream type I set as “live-record”. And added those module and copied .jar files to “install-dir/lib” locaion

2)I am using FMLE upload live videos to my Wowza server. I want to allow only some specific users to upload files using FMLE(or any other encoder). How to do that…?

Thank u

It was resolved already I have changed the stream from “live-record” to “live”

My live sream name is “vlc1.sdp” which is uploaded from FMLE. And the file stored as “vlc1.sdp.flv”. And the problem is I cannnot play those files :confused: .

2)I want to allow only some specific users to upoad to “live” application. how to do that…?

I have tried it by copying the video file (vlc1.sdp.flv ) in the content folder of the application “vod”. But when I am trying to play it ( using stream name “mp4:vlc1.sdp.flv”) it does not plays and with an output “Failed to play vlc1.sdp.flv; stream not found”.


Note: Using my “vod” application I cannot play the file “Extremists.flv” but “Extremists.m4v” is working fine…So does the “vod” cannot play flv files…?

Sorry It was my problem. I had to use “flv:Extremists.flv” instead of “mp4:Extremists.flv”.

It is working for “Extremists.flv” also

I have also changed “mp4:vlc1.sdp.flv” to “flv:vlc1.sdp.flv” Now that Output (“Failed to play vlc1.sdp.flv; stream not found.”) is gone. But even the video is not playing.


Is there any way to resolve the above problem…? …:frowning:

I couldnt find it.

I have configured a load balncer and an edge server…I want my loadbalancer should work as an edge server also…So I added the required lines to the config files of load balancer…and the out put of the query indicates that the configuraton is working fine…

here is the query…and output…





278 milliseconds





2 seconds 157 milliseconds


my setup: load balanser cum edge server server. woza on centos 5.3 windows XP installed on virtual box which is on

let me explain…my configuration…

I have configured the vod application in the load balancing wowza server( as an application that redirects to the least loaded server by contacting loadbalancer server ( when the least loaded server is the the edge server ( the redirection works correctly…But when the least loaded server is the load balancer itself (; it is also configured as an edge server…) theconnection request (ie…rtmp://") get redirected to the the edge server: (even the query "" displays the least loaded server as “redirect=” ). So what is the problem?..Does the load balancing wowza server can act as an edge server?

Make your test machine an Origin and an Edge. Then publish a stream to the Origin,

Sorry for asking this silly question…I have reffered the Readme.html given with the package to configure the load balancer server…So actually I dont know what is an origin

server and how to set up it…Can u plz help me…?

[*]Make your test machine an Origin and an Edge. Then publish a stream to the Origin, then connect to the Edge with a player and subscribe to the stream. When you see the stream playing from the edge that is being published to the origin, origin/edge is working.

thank u rishard,

I have tried with what u told in the first step. I created an 2 applications “liverepeater” (the orgin) “liverepeater2” (the edge ) on my server…and published to “liverepeater” …but I couldnt access it from the edge…(liverepeater2)…

but i can access it from the origin…

So I configured the liverpeater-edge server on another wowza machine (with the same name of origin ie “liverepeater” ) and it worked well …!!! So what is the problem when configuring both origin and edge on the same machine itself…?

And then I configured the origin application as a redirect application…then I restarted wowza …then the FMLE cannot connect to the server for publishing… When I removed the lines for redirection it is working as previous…

. There is no problem in configuring origin and edge applications on the same machine, I have done it many times.

I didnt intend to divert from the instructions give in the pdf…I thought it was the way for making a single server as an origin and edge…

  1. Do u mean to configure one single application as an origin and edge…? then what streamtype shall I give …liverepeater-origin or liverepeater-edge…?

  2. Or Do u mean to make origin application on one virtual host and the edge on another virtual host…?

Why would you configure the origin application as the redirect application? They are totally separate applications.

  1. Then how can I utilise the load balancing on this origin and edge server applications…?

4)Shall I develop a seperate redirecting application which will redirect to the least loaded liverepeater server…? I have done this but not working…what stream type shall I specify for this rediredting application…?

thank u richard,

I have done what you said…

My origin & edge servers working without any problems…

And I have created a new application “redirect” on the origin server itself…which will redirect to the least loaded liverepeater server (either the origin or edge…)…and when I am connecting to the “redirect” application it connects to the origin server as it the least loaded one…after that when I check the least loaded one (using the query “http://[load balancer ip]:1935/loadbalancer” ) it shows the edge server i have configured…

But when I make a second connection to the “redirect” application again it goes to the origin server (not to the least loaded one )…whats the problem…?

Note: I dont know which stream type I should specify for the “redirect” application…But I have tried everything…ie…default, live, livereater-origin, liverepeater-edge etc but no use…


Yaa I have 2 loadbalancer senders one of it is also working as a loadbalancer listner…My configuraion is shown below;

  1. first server IP= (Centos 5.3)- wowza-2.0.0

here I am running loadbalancer listner + loadbalancer sender + liverepeater-origin application (name “liverepeater”) + redirect application (name: “redirect” …) which will redirect to the “liverepeater” application

  1. Second server IP= (windows XP on virtualbox that is installed on… ie the above centos machine…)- wowza-2.0.0

here I am running loadbalancer sender + liverepeater-edge application (name “liverepeater”)

But when I connect to the “redirect” application(Server: rtmp://

Stream: vlc)

it does not load the video…leaving a message " Connection failed: Application rejected connection.

and the logs [install-dir]/logs/wowzamediaserver_access.log output is given below…

2010-06-02 08:43:20 EDT comment server INFO 200 - ModuleLoadBalancerRedirector.onAppStart: redirect/definst - - -2038.608 - - - - - - - - – - - - - - - - - - – - - - -

2010-06-02 08:43:20 EDT app-start application INFO 200 definst redirect/definst - - - 2038.612- - - - - - - - - - – - - - - - - - - - – - -

2010-06-02 08:43:20 EDT connect-pending session INFO 100 - defaultVHost redirect definst 0.064 [any] 1935 rtmp:// rtmp LNX 10,0,32,18 666959367 3465 3073 - - - - - - - – - - - - rtmp:// -

2010-06-02 08:43:20 EDT connect session INFO 302 - defaultVHost redirect definst 0.065 [any] 1935 rtmp:// rtmp LNX 10,0,32,18 666959367 3465 3073 - - - - - - - - – - - - rtmp:// -

2010-06-02 08:43:20 EDT disconnect session INFO 200 666959367 - defaultVHost redirect definst 0.079 [any] 1935 rtmp:// rtmp LNX 10,0,32,18 666959367 3481 3439 - - - - - - - – - - - - rtmp:// -


But I can Connect when i replace the application name as “liverepeater”…(working for both & ie edge and orgin works fine…)

This is working correctly. The connection rejection is how redirect works. You can use JW Player 5 to handle the rejection/redirect. It is all covered in the documentation, and in previous posts in this thread.


1)Can I play with flow player…? thats what I currently use…

2)There is one more issue related with flow player…I cannot the play the live stream from liverepeater origin or edge servers…but works with the default player provided with wowza…