Wowza Community

Encode with VLC isn't working

Good evening,

I am attempting to use VLC to encode a stream to the Wowza server and am following the tutorial here.

I get the following error.

Streaming/Transcoding failed:

VLC could not open the encoder.

We are currently encoding successfully to the Wowza server using Flash Media Encoder but need other options as the Flash encoder is way out of date and some of our users cannot use it anymore.

If anyone has other suggestions for free encoders to use with Wowza that would be great.



Which of the commands are you using from this page?

A quick Google search turns up several forum posts on the VLC pages regarding the same error appearing in earlier version of VLC 2.0.1

Not sure what version of VLC you are using currently, but it might be worth updating if you are not on their latest release.


Make sure you are running the latest version of VLC.

These guides should provide the instructions you need to set this up:

How to use VLC as a live stream encoder with Wowza Media Server (MPEG-TS)

How to publish and play a live stream (MPEG-TS based encoder)


vlc -vvv “%WMSAPP_HOME%/content/sample.mp4” --sout “#transcode{venc=x264{keyint=60,profile=main},vcodec=x264,vb=500,scale=1,acodec=mp4a,ab=128,channels=2,samplerate=48000}:rtp{dst=,port=10000,mux=ts}”

VLC Media PLayer 2.1.2

Thanks for the reply.

Command used

C:\Program Files (x86)\VideoLAN\VLC>vlc -vvv “%WMSAPP_HOME%/content/sample.mp4”

–sout "#transcode{venc=x264{keyint=60,profile=main},vcodec=x264,vb=500,scale=1,


=ts}" --extraintf=http:logger --verbose=2 --file-logging --logfile=vlc-log.txt

Log file:

Command without acodec=mp4a

C:\Program Files (x86)\VideoLAN\VLC>vlc -vvv “%WMSAPP_HOME%/content/sample.mp4”

–sout "#transcode{venc=x264{keyint=60,profile=main},vcodec=x264,vb=500,scale=1,

ab=128,channels=2,samplerate=48000}:rtp{dst=,port=10000,mux=ts}" --extr

aintf=http:logger --verbose=2 --file-logging --logfile=vlc-log2.txt

Log File:

The first command generated the normal error with vlc. The second command didn’t generate an error but I didn’t see anything in VLC so how do I know if it worked? I don’t see anywhere in the command given by VLC to set the stream name so not sure how to tap into a stream with this command.

Not sure what you mean by ingesting the stream. In all previous cases when streaming to our Wowza server we would specify an alias of some sort which would allow us to setup a folder on the wowza server for the settings on the page you sent me to.

Guess it would be too much trouble for someone to put together a video tutorial going through this step by step since I am still having issues.

Can you paste in more detailed logs or add the command line option(s) for logging similar to the following:

--extraintf=http:logger --verbose=2 --file-logging --logfile=vlc-log.txt

Also, try it without acodec=mp4a

You can ingest the stream and attempt playback through Wowza.