Wowza Community

Error during WebSocket handshake: Unexpected response code: 200

I am using webrtc publisher for streaming video recordings to wowza media server. I tried using my own security certificate but it showed error loading certificate in logs. So, I tried it with wowza streamlock certificate which seems to be loading correctly but I cant still stream videos as it gives me following error:

“WebSocket connection to ‘wss://’ failed. Error during WebSocket handshake: Unexpected response code: 200”

Hello @Kulwinder Kaur

To further track down why you are getting a WebSocket handshake error, I would recommend sending the below info into a support ticket for review. Link

[install-dir]/logs (Only latest logs are needed showing a Wowza Server restart and WebRTC connection attempts)

If you are not sure how to get this information please see the following tutorial.

If the files are larger than the 16mb email limit, please send a downloadable link to the files.



Hi Jason

I have submitted a ticket (228750) already but not getting very prompt responses. I need to solve this urgently. Can you please look into it as you assisted me with the security certificate configuration on my local server. Now, I am having issue swith certificate on my production server.

I am still waiting on my ticket number 228750

I also encountered this problem too!, i just use this link and supplied my streamlock and encountered the same error. I also checked the logs but there was no error

@Kulwinder Kaur

  • were you able to solve this issue? I’m encountering the same thing, with no errors in the logs.


I had the same issue! Got it working after I realized I had placed I had mistakenly placed the WebRTC HTTPProvider (below) under my 1935 HostPort entry rather than my 443 (SSL port) entry. You could double check this configuration in your VHost.xml file.



Important put this section beefor section with *


This was exactly my problem. Thanks for the helpful comment!

I encountered this issue also. I had it working after modifying [install-dir]/conf/Server.xml then adding the following to the end of file: