Wowza Community

Expected stream target endpoint path when publishing DASH to Akamai

In version 4.7.5, the playback URL for the published DASH stream on Akamai is:



After upgraded to version 4.8.0, we found that for the same Stream Targets settings, the URL for the MDP file didn’t change, but the element inside MPD file changed from




As you can see the base url became invalid, i.e. any file would be resolved to:

When it should be:

It worked fine before the upgrade. Now, the playback doesn’t work because of 404 error for the segments.

Can you confirm if this is a bug? Or is there anything wrong in our usage?

By the way: If we don’t set the Akamai Event Name, the playback works again. In that case, the MDP URL becomes:



Does it mean the Akamai Event Name setting is unsupported in the new version?

Our engineering team is looking at this, but they have a few questions. What player are you using? We do support Akamai Event Name, but we are wondering if it might be your player that is not handling this correctly.

Engineers need to see your map file entry & config. Can you please create a support ticket so we can further assist?

Thanks for the response.

I just created one support ticket # (352474). However, I was thinking to attach the map file into the ticket after I created, but seems like after the ticket is created there is no way to edit it anymore.

Here is it: PushPublishMap.txt (“host” has been modified)

The BaseURL in the mpd file downloaded from Akamai is:


I tried uploading the mpd file here, but it tells me it’s invalid.

I used the demo player from ShakaPlayer:

I don’t think it’s a problem of the player, since clearly the URL is wrong.

We looked into this further and confirmed what you were seeing as well as another bug. Recommended workaround is using absolute paths, as they appear to be correct.

I’ll work with the support team to make sure they get your information from this forum post on your ticket.

Thanks for the confirmation. We understand.

Right now we still uses relative path but without the akamai event name.