Wowza Community

Hauppauge Streameez-pro ios HLS

everything went well on the set-up, i was able to stream adobe rtmp and hds via test player, however when i tried streaming HLS via ios, there is no video and only audio was able to stream. I tried playing around the settings in Hauppauge but with no avail, there is still no video and i also noticed that the video stream output from Streameez-pro is not sharp at 1000kbps. I hope anyone can help me resolve this and would appreciate if anyone can share their settings on the streameez-pro as well.


It sounds like the video codec may not be compatible on an HLS/iOS playback. Test playing back the Wowza RTMP stream in VLC, and then check Codec Info to see what the codecs are in your source stream. For HLS, ideally you should have H.264 for video, and AAC for audio.


I would check the Profile and Level, since though I’m not sure of the particulars, I know various IOS devices/versions have varying levels of support. In particular, not going higher than Main profile and level either 3.1 or something like that. Anyway, worth checking if you haven’t sorted it out yet.

Hello Jerome,

I believe Matt is on the right track, and beyond checking the profile I would suggest reviewing this article:

I would also have you check that your resolution is playable on the particular device you are testing on, this could explain why you can view this on an iPad but not on the iPhones.


Jason Hatchett


Hauppauge is streaming h.264 and aac. The ipad is able to view with no problem, video and audio but streaming it using iphone 6, 6s is not able to show video but audio only. Any thoughts?