Wowza Community

I am a Noob - HTTPStreamerAdapterCupertinoStreaming.onPlaylist: Application context n

I get this error :HTTPStreamerAdapterCupertinoStreaming.onPlaylist: Application context not loaded [vids/mp4:e.m4v.playlist.m3u8]: defapp/definst

this is a new install on my first attempt I had the sample video (after I renamed it) playing on an itouch. when I loaded I loaded my own videos i started getting this error. I then tried to play the sample video again and I get the same error (I renamed the video to e.m4v) I have restarted the server, and the service multiple times and I still get the same error.

My applications.xml is the default one I made no changes to it and it was working just fine.

here it is


























Client Logging





Here is the error while trying to access video from an itouch:

root@(none):/usr/local/WowzaMediaServer/bin# ./

Configure logging: file:///usr/local/WowzaMediaServer/conf/

INFO server server-start Wowza Media Server 2 Developer 2.2.0 build26280 -

INFO server comment - Serial number: XXXXX-XXXXX-XXXXX-XXXXX-DU33G

INFO server comment - Maximum connections: 10

INFO server comment - Hardware Available Processors: 2

INFO server comment - Hardware Physical Memory: 646MB/993MB

INFO server comment - Hardware Swap Space: 2997MB/2997MB

INFO server comment - Max File Descriptor Count: 20000

INFO server comment - Open File Descriptor Count: 37

INFO server comment - OS Name: Linux

INFO server comment - OS Version: 2.6.35-22-generic-pae

INFO server comment - OS Architecture: i386

INFO server comment - Java Name: Java HotSpot™ Server VM

INFO server comment - Java Vendor: Sun Microsystems Inc.

INFO server comment - Java Version: 1.6.0_20

INFO server comment - Java VM Version: 16.3-b01

INFO server comment - Java Spec Version: 1.6

INFO server comment - Java Home: /usr/lib/jvm/java-6-sun-

INFO server comment - Java Max Heap Size: 1160MB

INFO server comment - Java Architecture: 32

INFO server comment - Java Encoding[file.encoding]: UTF-8

INFO server comment - Java Args[0]: -Xmx1200M

INFO server comment - Java Args[1]:

INFO server comment - Java Args[2]:

INFO server comment - Java Args[3]: -Dcom.wowza.wms.AppHome=/usr/local/WowzaMediaServer

INFO server comment - Java Args[4]: -Dcom.wowza.wms.ConfigURL=

INFO server comment - Java Args[5]: -Dcom.wowza.wms.ConfigHome=/usr/local/WowzaMediaServer

INFO server comment - Java GC[0]: Copy

INFO server comment - Java GC[1]: MarkSweepCompact

INFO server comment - Server threads[h/t]: 10/10

INFO server comment - CMDInterface now listening: [any]:8083

INFO vhost vhost-start defaultVHost -

INFO server comment - defaultVHost threads[h/t]:120/80 home:/usr/local/WowzaMediaServer

INFO vhost comment defaultVHost Bind attempt ([any]:1935:4)

INFO vhost comment defaultVHost Bind successful ([any]:1935)

INFO vhost comment defaultVHost Bind attempt ([any]:1936:4)

INFO vhost comment defaultVHost Bind successful ([any]:1936)

INFO vhost comment defaultVHost Bind attempt ([any]:8086:1)

INFO vhost comment defaultVHost Bind successful ([any]:8086)

WARN server comment - HTTPStreamerAdapterCupertinoStreaming.onPlaylist: Application context not loaded [vids/mp4:e.m4v.playlist.m3u8]: defapp/definst

What am I doing wrong

I think it is just typo in your client-side link. You have dot separating file name and playlist.m3u8. It should be forward slash.

Change this:




Is “vids” a sub-folder of the content location? If so, make it like this:


For example:



Just glad it’s working. Thanks for the update


This is duplicate. I answered here


Sorry. yes everything is working great now thank you

Hi all. It’s my first time using the Wowza Media Server and I having some troubles. I start the server and in firefox/safari when I put try to access the server by the port 8060 I get success, but when I try 1935 port I get “page not found”. I’m trying to set up a new application by the tutorial that I found in the Wowza Tutorials page, the ‘vod’ application. I have some questions:

  1. How can I do to create a new file playlist.m3u8 and witch the folder is it?

  2. What is the data needs inside the playlist.m3u8?

  3. I trying to play a video using html5

  1. The playlist.m3u8 have to be in the ‘vod’ folder?

I want to test it in the iPhone/iPad browser (Safari) using the html5 tag, so how can I set it up to get the video playing?

Thanks in advance!