Wowza Community

I have a problem with ModuleRefererValidate.

I’m writing on the forum because “support” can not in any way to help me.

The problem looks like this:

I tried a few weeks ago: ModuleRefererValidate. then everything worked beautifully …

I did not changed my application and Vhost.xml.


And I installed the update (from 403 to next, and now to 406)

And I installed a new module collection

Today I can not cope with this …

It is very important to me.

I sent logs, etc. conf. to support. 7 days …and nothing.

when the error 403 - work

now is not working.

does not accept the given domain - as good. I do not see streams.

Now I tested:

Application for Live

Application for VOD

no change …

Do any of you have a similar problem?

or… only I have one…

Hi there,

If you have a ticket open with the support team you are in good hands. They will be able to figure something out for you so it would be best for you to refer to that ticket with the team.

Without all the logging and configuration details we can not really help troubleshoot this issue for you. So to save from having to post all that here, you should work with the support team in the ticket system.

With that said, if you have not done so already, it would be helpful I am sure for the support team if you enabled “refererValidateDebugLog” to help pinpoint any issues that are occurring with the setup.

Thank you for your patience and I apologize for any inconveniences.


“If you have a ticket open with the support team you are in good hands.” - yes, I have. But “time is money”.

Support work on the problem lasts longer 7 days.

Logs, setup, etc. - everything has been sent.

No answer for this issue.

That’s why I turn to the forum participants.

Support - can work on it.

Maybe someone had a similar problem.

Of course - there is always a way out: a new installation, clean.

But now it does not interest me.

Salvadore … Thanks again.

… But …

everything you wrote - has been done.

everything asked Support - sent to them.

seven days ago.

Do you know a specific solution - write. We are happy to read it. Maybe it’ll help.

Thanks again.

of course. All the time waiting for the information from the support.

I understand.

Therefore, explain:

I created a new application. Even two.

First - live. Second - VOD

Everything I’ve done in accordance with the submitted suggestions of support. and … it did not work.

More - the second my server … also does not work. I’ll send this information to support. :slight_smile:

Up to this point I would say - something wrong with the server / configuration /.

Now I’m convinced that something is wrong with the module.

or a code embedded in the Web - example:

but the support received all my files, code of web pages - and has no objections.

Today is…

I have a new dedicated server. Wowza installed the developer version. It is new one.

and … nothing works. It is exactly the same.

I made 3 tests. compressed files and waiting for support.

This new machine, completely clean. Only Java and Wowza 406.


I believe that this module is not functioning properly … something is not right.


I wrote already.

The content below:

BUT (!!!) … it is very importent news for you:

This is the IP -46.171.XX.XX- of my computer. This computer test done viewing the following pages. … why???

Please, again verify your review now, knowing it.

According to me - this is a mistake … I play streaming to the following pages in the domain - xxxx

I do not do this locally.

About this:




I forgot improved. Now is change.

But now I am waiting for your suggestion. And why there is my local-computer IP ??

in the second - gave the data to the server.

and this:

WARN server comment 2014-08-31 16:12:43 - - - - - 209.696 - - - - - - - - HTTPStreamerAdapterCupertinoStreamer.onPlaylist[hdstream1/hdleci/playlist.m3u8]: Session not accepted[400729829]

WARN server comment 2014-08-31 16:12:43 - - - - - 209.887 - - - - - - - - HTTPStreamerAdapterCupertinoStreamer.onPlaylist[hdstream1/hdleci/playlist.m3u8]: Session not accepted[1168756975]

but I only ONE open this site/player…

It is Ok?

But I still think that the problem is in the module / manager … I do not know.

Why IP is checked and not the domain of what is given?


I changed the computer and internet - I have a different IP address.

I did a test and … in the logs IP appeared a new computer.

interesting …

matt_y and what do you think?


introduced changes to the files listed /vhost.xml/.

tests done. all tests with negative results - streaming does not work.

then introduced his IP as refererValidateReferers - as told to do.

tests done. all tests with negative results - streaming does not work.

I sent you an email. - zip download from the specified address: http://xx/

What now?

I waiting now.

Let me remind you - I look forward to solving the problem of Aug. 19, 2014.

Andrew - you are Great!!!

and I’ve lost my hope … tests commissioned by Andrew - and I think we have a solution to the problem. Only one day, several hours.:wink:

Is improved - Module Collection.

build 12557

  • Fixed HttpRefererValidate to handle multiple HostPorts CORRECTLY

build 12496

  • Fixed HttpRefererValidate it CORRECTLY refererse handle with non-default http ports

If you want to post your application configuration and logs in the forum please feel free.

Again, please enable “refererValidateDebugLog” so those logs are included.

You can start Wowza in stand-alone mode [install-dir]/bin/startup.bat and view the logs in a console window.

Or you might wish to create a new application and configure it with the module and see if that clears up the issue.

Otherwise, I am sure the support team will be in touch with you very shortly.

Thanks again.


I’m sorry, I guess I should mention I and the rest of the forum users, do not have access to anything you have sent to the support team via the ticket system.

My suggestion would be to create a new application as you have recently updated Wowza. And configure the module in the new app. That may fix the issue. Or maybe support will be able to find a solution in the very near future for you.


Sounds like you have this figured out. That’s great! Thanks for the update.


Please refer to ticket #100657 for updates as there has been a response.