Wowza Community

IDE setup (linux)

Hi Guys,

I don’t see any updates available via (just checked in Eclipse)

For anyone looking to dev against the 4.x Wowza Engine, you’ll need to make a few small edits to your Debug / Run Configurations.

VM arguments just need a quick edit:



Change to:



You’ll also need to re-add all your libraries to your classpath.

I’ve also just run through the process in my Windows setup too - and just make sure you edit your paths accordingly.

Feel free to bug me if you want more info.

Edit - not 100% working yet - I’ll post back.

Try first deleting the build.xml from the project, then deleting the project, but without checking the box to delete from disk (which is not checked by default). Then create a new project with the same name, the files will all be there since they were not deleted.

Then I had to add this to this to the VM Arguments tab:



Cool, you’re welcome. Enjoy!



Tidy! Thanks Richard :slight_smile:

Yep - confirmed building happily and launching in debug - awesome :slight_smile:


where can you download the IDE, i can’t find anymore link on wowza website ?

Thank you for replies.

I am currently testing IDE installation under Linux.

IDE successfully installed using “install new software” feature in Eclipse.

(i had to enter “ide” in search text field, and then click “select all”, and click “next” button. Because for unknown reason, title was blank and i could not select it with mouse click, but maybe it is due to my desktop theme configuration).

I use our maven template for wowza development and after Engine released it stop debuging.

Thank you guys for pointing to -Dcom.wowza.wms.native.base= in this thread. Now it works fine

So working VM params to debug using exec:java is

-agentlib:jdwp=transport=dt_socket,address=,suspend=y,server=n -Xmx768M -Dcom.wowza.wms.AppHome=/usr/local/WowzaStreamingEngine -Dcom.wowza.wms.ConfigHome=/usr/local/WowzaStreamingEngine -Dcom.wowza.wms.native.base=“linux” -classpath “/usr/local/WowzaStreamingEngine/bin/wms-bootstrap.jar” com.wowza.wms.bootstrap.Bootstrap start

@MichalisZ - What have you tried? What errors are you getting? What OS?

@kslimani - You should be able to “Install new software” in eclipse and add this URL

@kslimani - also, for windows, you’ll want to add the following to the VM->arguments tab



has anyone managed to change the Wowza IDE2 to work with the wowza 4.0 under windows?

Can you provide any instructions?