Wowza Community

M3U8 not working


Very new to this technology and I have tried to do as much as I can myself but I am now at an impasse.

We are using Wowza to convert an RTSP stream to RTMP and M3U8 so we can embed it into a mobile app, therefore the stream must be flash and iOS compatible. I have the RTMP stream working no problem but the M3U8 stream is not working.

I think it is a codec issue but I think I have set everything up correctly as per this thread but it is still not showing either in a HTML5 player or using VLC.

Is there anything else I could be missing or doing wrong? Could the company firewall be affecting it and not the RTMP?

Hi there,

What is the source of the stream?

What is the video and audio codec of the stream?

Can you explain what you have tried so far?

And have you seen any errors in the logs? You can start Wowza in stand-alone mode [install-dir]/bin/startup.bat ( and view the output in the console.


I would suggest reviewing this article:

How to set up live streaming using an RTMP-based encoder

Also, what is the playback URL you are using for iOS?

It should look something like this:



Also, verify your settings in Flash Media Live Encoder are set to:

Video format: H264 (default is VP6)

Audio Format: AAC if available.

With H.264 video set, click the little “wrench” icon and check that profile is set to “baseline” 3.1

The video setting may be the issue here.


Sorry, forgot to mention, if the audio is mp3 it should be 4100Hz, 64 or 128kb.


Thanks for the update and I am glad I could help.

Please let us know if there is anything else we can help you with in the future.


Thanks for replying Salvadore.

The source of the stream is a webcam going to Adobe Flash Media Encoder then onto Wowza.

Unfortunately Video is not my area of expertise but I think its h.264 (thats taken from Flash Media Encoder)

In regards to the feed I have tried exactly what’s in this post. As for testing the feed, directly trying the url on a iPad and iPhone (1st generation and iPhone 5c), embedding in HTML5 video tags, embedding using Flowplayer and JW player). None will show.

BUT all of a sudden it has started to work with VLC, which now makes me think the codecs will be fine?

Thanks again, very very new to this so any help is very gratefully accepted. I will give that article a good read.

The url looks exactly like so at least something is going right. :slight_smile:

Thanks for you help Salvadore.

It was the setup of the web cam that was causing the problem